]> git.pld-linux.org Git - packages/calibre.git/blob - calibre.spec
- up to 6.23.0
[packages/calibre.git] / calibre.spec
1 #
2 # TODO: - rewrite generate-tarball.sh script to provide locales.zip handling (if needed)
3 #       - make separate server package with init-scripts, etc...
4 #
5 # NOTE:
6 # Upstream packages contain some non-free fonts which we cannot redistribute,
7 # so when upgrading calibre we should download upstream tarball by hand from
8 # https://download.calibre-ebook.com/ and run generate-tarball.sh script
9 # included as SourceX.
10 #
11 Summary:        E-book converter and library management
12 Summary(pl.UTF-8):      Konwerter oraz biblioteka dla e-booków
13 Name:           calibre
14 Version:        6.23.0
15 Release:        1
16 License:        GPL v3+
17 Group:          Applications/Multimedia
18 Source0:        %{name}-%{version}-nofonts.tar.xz
19 # Source0-md5:  e0a8b9d98f888d1996e3a594edf13cb5
20 Source1:        generate-tarball.sh
21 Source2:        %{name}-mount-helper
22 Patch0:         %{name}-prefix.patch
23 Patch1:         %{name}-locales.patch
24 Patch2:         shebang-python-fix.patch
25 Patch3:         desktop-integration.patch
26 Patch4:         %{name}-env_module.patch
27 %define         baeutifulsoup_ver 3.0.5
28 %define         pil_ver 1.1.6
29 %define         pyqt6_ver 6.3.1
30 %define         apsw_ver 3.38.0
31 %define         cssselect_ver 0.7.1
32 %define         cssutils_ver 1:0.9.9
33 %define         dateutil_ver 1.4.1
34 %define         dns_ver 1.6.0
35 %define         lxml_ver 2.2.1
36 %define         mechanize_ver 0.1.11
37 %define         msgpack_ver 1.0.0
38 %define         netifaces_ver 0.8
39 %define         psutil_ver 0.6.1
40 URL:            https://calibre-ebook.com/
41 BuildRequires:  ImageMagick-devel >= 6.6.4.7
42 BuildRequires:  Qt6Core-devel
43 BuildRequires:  Qt6DBus-devel
44 BuildRequires:  Qt6Gui-devel
45 BuildRequires:  Qt6WebEngine-devel
46 BuildRequires:  Qt6Widgets-devel
47 BuildRequires:  chmlib-devel >= 0.40
48 BuildRequires:  hunspell-devel
49 BuildRequires:  hyphen-devel
50 BuildRequires:  libicu-devel
51 BuildRequires:  libinput-devel
52 BuildRequires:  libmtp-devel >= 1.1.5
53 BuildRequires:  libwmf-devel >= 0.2.8
54 BuildRequires:  mtdev-devel
55 BuildRequires:  pkgconfig
56 BuildRequires:  podofo-devel >= 0.8.2
57 BuildRequires:  poppler-glib-devel >= 0.28.1
58 BuildRequires:  poppler-qt6-devel >= 0.28.1
59 BuildRequires:  python3-PyQt6-devel-tools >= %{pyqt6_ver}
60 BuildRequires:  python3-PyQt-builder
61 BuildRequires:  python3-PyQt6 >= %{pyqt6_ver}
62 BuildRequires:  python3-PyQt6-uic >= %{pyqt6_ver}
63 BuildRequires:  python3-PyQt6-WebEngine
64 BuildRequires:  python3-apsw >= %{apsw_ver}
65 BuildRequires:  python3-bs4 >= %{baeutifulsoup_ver}
66 BuildRequires:  python3-css_parser
67 BuildRequires:  python3-cssselect >= %{cssselect_ver}
68 BuildRequires:  python3-cssutils >= %{cssutils_ver}
69 BuildRequires:  python3-dateutil >= %{dateutil_ver}
70 BuildRequires:  python3-devel >= 1:2.7.1
71 BuildRequires:  python3-dns >= %{dns_ver}
72 #BuildRequires: python3-genshi
73 BuildRequires:  python3-html5-parser
74 BuildRequires:  python3-jeepney
75 BuildRequires:  python3-lxml >= %{lxml_ver}
76 BuildRequires:  python3-mechanize >= %{mechanize_ver}
77 BuildRequires:  python3-msgpack >= %{msgpack_ver}
78 BuildRequires:  python3-netifaces >= %{netifaces_ver}
79 BuildRequires:  python3-pillow >= %{pil_ver}
80 BuildRequires:  python3-psutil >= %{psutil_ver}
81 BuildRequires:  python3-regex
82 BuildRequires:  qt6-build
83 BuildRequires:  rpm-build >= 4.6
84 BuildRequires:  rpm-pythonprov
85 BuildRequires:  rpmbuild(macros) >= 1.714
86 BuildRequires:  sed >= 4.0
87 BuildRequires:  sip6
88 BuildRequires:  sip-PyQt6 >= %{pyqt6_ver}
89 BuildRequires:  sqlite3-devel
90 BuildRequires:  tar >= 1:1.22
91 BuildRequires:  unzip
92 BuildRequires:  xdg-utils
93 BuildRequires:  xz >= 1:4.999.7
94 Requires:       Qt6Svg
95 Requires:       Qt6WebEngine
96 Requires:       python3-PyQt6 >= %{pyqt6_ver}
97 Requires:       python3-PyQt6-WebEngine
98 Requires:       python3-apsw >= %{apsw_ver}
99 Requires:       python3-bs4 >= %{baeutifulsoup_ver}
100 Requires:       python3-css_parser
101 Requires:       python3-cssselect >= %{cssselect_ver}
102 Requires:       python3-cssutils >= %{cssutils_ver}
103 Requires:       python3-dateutil >= %{dateutil_ver}
104 Requires:       python3-dns >= %{dns_ver}
105 #Requires:      python3-genshi
106 Requires:       python3-html5-parser
107 Requires:       python3-jeepney
108 Requires:       python3-lxml >= %{lxml_ver}
109 Requires:       python3-mechanize >= %{mechanize_ver}
110 Requires:       python3-msgpack >= %{msgpack_ver}
111 Requires:       python3-netifaces >= %{netifaces_ver}
112 Requires:       python3-pillow >= %{pil_ver}
113 Requires:       python3-psutil >= %{psutil_ver}
114 Requires:       python3-regex
115 Suggests:       ImageMagick-coder-jpeg
116 Suggests:       ImageMagick-coder-png
117 ### FIXME: libunrar.so is needed for rar-packed files
118 Suggests:       libunrar-devel
119 Suggests:       poppler-progs
120 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
121
122 %description
123 Calibre is meant to be a complete e-library solution. It includes
124 library management, format conversion, news feeds to ebook conversion
125 as well as e-book reader sync features.
126
127 Calibre is primarily a ebook cataloging program. It manages your ebook
128 collection for you. It is designed around the concept of the logical
129 book, i.e. a single entry in the database that may correspond to
130 ebooks in several formats. It also supports conversion to and from a
131 dozen different ebook formats.
132
133 Supported input formats are: MOBI, LIT, PRC, EPUB, CHM, ODT, HTML,
134 CBR, CBZ, RTF, TXT, PDF and LRS.
135
136 %description -l pl.UTF-8
137 Calibre to bardzo dobry i darmowy program do czytania e-książek.
138
139 Calibre umożliwia zarówno czytanie e-książek jak i konwersję wielu
140 formatów do ich postaci. Program obsługuje następujące typy plików:
141 import: LRF, PDF, LIT, RTF, OPF, MOBI, PRC, EPUB, FB2, IMP, RB i HTML
142 eksport: Mobi, LRF i EPUB oraz do aplikacji iPhone-reader i Stanza.
143
144 Ten czytnik e-książek oferuje również pobieranie okładek, komiksów i
145 najnowszych wiadomości z serwisów poświęconym e-książkom. Twórcy
146 dołączyli również aplikację, którą użytkownik może wykorzystać jako
147 swój własny serwer darmowych książek.
148
149 %package -n bash-completion-calibre
150 Summary:        bash-completion for calibre
151 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla calibre
152 Group:          Applications/Shells
153 Requires:       %{name} = %{version}-%{release}
154 Requires:       bash-completion
155 BuildArch:      noarch
156
157 %description -n bash-completion-calibre
158 bash-completion for calibre.
159
160 %description -n bash-completion-calibre -l pl.UTF-8
161 Pakiet ten dostarcza bashowe uzupełnianie nazw dla calibre.
162
163 %package -n zsh-completion-calibre
164 Summary:        zsh-completion for calibre
165 Summary(pl.UTF-8):      uzupełnianie nazw dla calibre w powłoce zsh
166 Group:          Applications/Shells
167 Requires:       %{name} = %{version}-%{release}
168 Requires:       bash-completion
169
170 %description -n zsh-completion-calibre
171 zsh-completion for calibre.
172
173 %description -n zsh-completion-calibre -l pl.UTF-8
174 Pakiet ten dostarcza uzupełnianie nazw dla calibre w powłoce zsh.
175
176 %prep
177 %setup -q
178 %patch0 -p1
179 %patch1 -p1
180 %patch2 -p1
181 %patch3 -p1
182 %patch4 -p1
183
184 # 64bit target build fix
185 %{__sed} -i -e "s!'/usr/lib'!'%{_libdir}'!g" setup/build_environment.py
186
187 # upstream decides to store locale files in a single zip file but we prefer separate .mo
188 mkdir resources/localization/locales
189 unzip resources/localization/locales.zip -d resources/localization/locales
190 chmod 755 resources/localization/locales/*
191 rm -f resources/localization/locales.zip
192
193 %build
194 CC="%{__cc}" \
195 CXX=%{__cxx} \
196 OVERRIDE_CFLAGS="%{rpmcflags}" \
197 OVERRIDE_LDFLAGS="%{rpmldflags}" \
198 QMAKE="%{_bindir}/qmake-qt6" \
199 %{__python3} setup.py build
200
201 %install
202 rm -rf $RPM_BUILD_ROOT
203 # create directories for xdg-utils
204 install -d $RPM_BUILD_ROOT%{_datadir}/{icons/hicolor,packages,mime/packages,desktop-directories} \
205 $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{zsh_compdir}}
206
207 export XDG_DATA_DIRS="$RPM_BUILD_ROOT%{_datadir}"
208 export XDG_UTILS_INSTALL_MODE="system"
209 export LIBPATH="%{_libdir}"
210 %{__python3} setup.py install \
211         --no-compile \
212         --root=$RPM_BUILD_ROOT \
213         --prefix=%{_prefix} \
214         --bindir=%{_bindir} \
215         --libdir=%{_libdir} \
216         --sharedir=%{_datadir}
217
218 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python3}\1,' \
219          -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
220         $RPM_BUILD_ROOT%{_bindir}/* \
221         $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}/devices/cli.py \
222         $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}/devices/mtp/unix/upstream/update.py
223
224 cp -p resources/images/library.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}-gui.png
225 cp -p resources/images/viewer.png $RPM_BUILD_ROOT%{_pixmapsdir}/calibre-viewer.png
226
227 %py3_comp $RPM_BUILD_ROOT%{_libdir}/%{name}
228 %py3_ocomp $RPM_BUILD_ROOT%{_libdir}/%{name}
229
230 %{__mv} $RPM_BUILD_ROOT%{_datadir}/%{name}/localization/locales $RPM_BUILD_ROOT%{_localedir}
231
232 # set proper filenames for locales (TODO: switch to patch if possible)
233 for file in $RPM_BUILD_ROOT%{_localedir}/*; do
234         lang=$(echo $file|%{__sed} 's:.*locale/\(.*\).*:\1:')
235         mkdir $RPM_BUILD_ROOT%{_localedir}/$lang/LC_MESSAGES
236         %{__mv} $RPM_BUILD_ROOT%{_localedir}/$lang/*.mo \
237                 $RPM_BUILD_ROOT%{_localedir}/$lang/LC_MESSAGES
238 done;
239 for file in $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/messages.mo; do
240         lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
241         %{__mv} $RPM_BUILD_ROOT%{_localedir}/$lang/LC_MESSAGES/messages.mo \
242                 $RPM_BUILD_ROOT%{_localedir}/$lang/LC_MESSAGES/%{name}.mo
243 done;
244 for file in $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/iso639.mo; do
245         lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
246         %{__mv} $RPM_BUILD_ROOT%{_localedir}/$lang/LC_MESSAGES/iso639.mo \
247                 $RPM_BUILD_ROOT%{_localedir}/$lang/LC_MESSAGES/%{name}_iso639.mo
248 done;
249 for file in $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/iso3166.mo; do
250         lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
251         %{__mv} $RPM_BUILD_ROOT%{_localedir}/$lang/LC_MESSAGES/iso3166.mo \
252                 $RPM_BUILD_ROOT%{_localedir}/$lang/LC_MESSAGES/%{name}_iso3166.mo
253 done;
254
255 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{km_KH,km}
256 # duplicates of bn,sl
257 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{bn_BD,sl_SI}
258 # unsupported
259 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{jv,ltg,uz@Latn}
260
261 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}
262
263 %find_lang %{name} --all-name
264 for file in $RPM_BUILD_ROOT%{_localedir}/*/lcdata.calibre_msgpack; do
265         lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/.*:\1:')
266         echo $file | %{__sed} "s:$RPM_BUILD_ROOT\(.*\):%lang($lang) \1:" >>%{name}.lang
267 done;
268
269 %clean
270 rm -rf $RPM_BUILD_ROOT
271
272 %post
273 %update_desktop_database
274 %update_mime_database
275 %update_icon_cache hicolor
276
277 %postun
278 if [ $1 -eq 0 ] ; then
279         %update_desktop_database
280         %update_mime_database
281         %update_icon_cache hicolor
282 fi
283
284 %files -f %{name}.lang
285 %defattr(644,root,root,755)
286 %doc Changelog.txt COPYRIGHT README.md
287 %attr(755,root,root) %{_bindir}/calibre
288 %attr(755,root,root) %{_bindir}/calibre-complete
289 %attr(755,root,root) %{_bindir}/calibre-customize
290 %attr(755,root,root) %{_bindir}/calibre-debug
291 %attr(755,root,root) %{_bindir}/calibre-mount-helper
292 %attr(755,root,root) %{_bindir}/calibre-parallel
293 %attr(755,root,root) %{_bindir}/calibre-server
294 %attr(755,root,root) %{_bindir}/calibre-smtp
295 %attr(755,root,root) %{_bindir}/calibredb
296 %attr(755,root,root) %{_bindir}/ebook-convert
297 %attr(755,root,root) %{_bindir}/ebook-device
298 %attr(755,root,root) %{_bindir}/ebook-edit
299 %attr(755,root,root) %{_bindir}/ebook-meta
300 %attr(755,root,root) %{_bindir}/ebook-polish
301 %attr(755,root,root) %{_bindir}/ebook-viewer
302 %attr(755,root,root) %{_bindir}/fetch-ebook-metadata
303 %attr(755,root,root) %{_bindir}/lrf2lrs
304 %attr(755,root,root) %{_bindir}/lrfviewer
305 %attr(755,root,root) %{_bindir}/lrs2lrf
306 %attr(755,root,root) %{_bindir}/markdown-calibre
307 %attr(755,root,root) %{_bindir}/web2disk
308 %{_libdir}/%{name}
309 %{_datadir}/%{name}
310 %{_datadir}/metainfo/calibre-ebook-edit.metainfo.xml
311 %{_datadir}/metainfo/calibre-ebook-viewer.metainfo.xml
312 %{_datadir}/metainfo/calibre-gui.metainfo.xml
313 %{_desktopdir}/calibre-ebook-edit.desktop
314 %{_desktopdir}/calibre-ebook-viewer.desktop
315 %{_desktopdir}/calibre-gui.desktop
316 %{_desktopdir}/calibre-lrfviewer.desktop
317 %{_iconsdir}/hicolor/*x*/apps/calibre-*.png
318 %{_iconsdir}/hicolor/*x*/mimetypes/application-lrf.png
319 %{_iconsdir}/hicolor/*x*/mimetypes/application-x-kindle-application.png
320 %{_iconsdir}/hicolor/*x*/mimetypes/application-x-mobi8-ebook.png
321 %{_iconsdir}/hicolor/*x*/mimetypes/application-x-mobipocket-ebook.png
322 %{_iconsdir}/hicolor/*x*/mimetypes/application-x-topaz-ebook.png
323 %{_iconsdir}/hicolor/*x*/mimetypes/gnome-mime-application-lrf.png
324 %{_iconsdir}/hicolor/*x*/mimetypes/gnome-mime-application-x-kindle-application.png
325 %{_iconsdir}/hicolor/*x*/mimetypes/gnome-mime-application-x-mobi8-ebook.png
326 %{_iconsdir}/hicolor/*x*/mimetypes/gnome-mime-application-x-mobipocket-ebook.png
327 %{_iconsdir}/hicolor/*x*/mimetypes/gnome-mime-application-x-topaz-ebook.png
328 %{_iconsdir}/hicolor/*x*/mimetypes/gnome-mime-text-lrs.png
329 %{_iconsdir}/hicolor/*x*/mimetypes/text-lrs.png
330 %{_datadir}/mime/packages/calibre-mimetypes.xml
331 %{_pixmapsdir}/calibre-gui.png
332 %{_pixmapsdir}/calibre-viewer.png
333
334 %files -n bash-completion-calibre
335 %defattr(644,root,root,755)
336 %{bash_compdir}/*
337
338 %files -n zsh-completion-calibre
339 %defattr(644,root,root,755)
340 %{zsh_compdir}/_calibre
This page took 0.132845 seconds and 4 git commands to generate.