]> git.pld-linux.org Git - packages/c-ares.git/blob - c-ares.spec
- updated to 1.28.1
[packages/c-ares.git] / c-ares.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        A library that performs asynchronous DNS operations
6 Summary(pl.UTF-8):      Biblioteka do wykonywania asynchronicznych zapytań DNS
7 Name:           c-ares
8 Version:        1.28.1
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 #Source0Download: https://c-ares.org/
13 Source0:        https://c-ares.org/download/%{name}-%{version}.tar.gz
14 # Source0-md5:  2b0f0df7491538a0d10f3310e13d4b5f
15 Patch0:         %{name}-resolv.conf-reading-is-not-fatal.patch
16 URL:            https://c-ares.org/
17 BuildRequires:  autoconf >= 2.69
18 BuildRequires:  automake >= 1:1.9.6
19 # for tests
20 #BuildRequires: libstdc++-devel >= 6:5
21 BuildRequires:  libtool >= 2:2
22 BuildRequires:  rpmbuild(macros) >= 1.527
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 c-ares is a C library that performs DNS requests and name resolves
27 asynchronously. c-ares is a fork of the library named 'ares', written
28 by Greg Hudson at MIT.
29
30 %description -l pl.UTF-8
31 c-ares jest napisaną w C biblioteką do asynchronicznego wykonywania
32 zapytań DNS. c-ares jest to fork biblioteki 'ares' napisanej przez
33 Grega Hudsona w MIT.
34
35 %package devel
36 Summary:        Development files for c-ares library
37 Summary(pl.UTF-8):      Pliki nagłówkowe dla biblioteki c-ares
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 Header files for c-ares library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe biblioteki c-ares.
46
47 %package static
48 Summary:        Static c-ares library
49 Summary(pl.UTF-8):      Statyczna biblioteka c-ares
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static c-ares library.
55
56 %description static -l pl.UTF-8
57 Statyczna biblioteka c-ares.
58
59 %prep
60 %setup -q
61 %patch0 -p1
62
63 %build
64 %{__libtoolize}
65 %{__aclocal} -I m4
66 %{__autoconf}
67 %{__autoheader}
68 %{__automake}
69 %configure \
70         --disable-silent-rules \
71         %{__enable_disable static_libs static} \
72         --disable-tests \
73         --enable-shared
74
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 # no external dependencies + obsoleted by pkg-config
84 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcares.la
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post   -p /sbin/ldconfig
90 %postun -p /sbin/ldconfig
91
92 %files
93 %defattr(644,root,root,755)
94 %doc AUTHORS CHANGES LICENSE.md NEWS README.cares README.md RELEASE-NOTES.md TODO
95 %attr(755,root,root) %{_libdir}/libcares.so.*.*.*
96 %attr(755,root,root) %ghost %{_libdir}/libcares.so.2
97
98 %files devel
99 %defattr(644,root,root,755)
100 %attr(755,root,root) %{_libdir}/libcares.so
101 %{_includedir}/ares.h
102 %{_includedir}/ares_build.h
103 %{_includedir}/ares_dns.h
104 %{_includedir}/ares_dns_record.h
105 %{_includedir}/ares_nameser.h
106 %{_includedir}/ares_rules.h
107 %{_includedir}/ares_version.h
108 %{_mandir}/man3/ares_*.3*
109 %{_pkgconfigdir}/libcares.pc
110
111 %if %{with static_libs}
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/libcares.a
115 %endif
This page took 0.122797 seconds and 4 git commands to generate.