]> git.pld-linux.org Git - packages/brltty.git/blob - brltty.spec
- updated to 6.6
[packages/brltty.git] / brltty.spec
1 # TODO: user/group (see Autostart/Systemd/sysusers)
2 #
3 # Conditional build:
4 %bcond_without  apidocs                 # documentation generated with doxygen
5 %bcond_without  java                    # Java bindings
6 %bcond_without  lua                     # Lua bindings
7 %bcond_without  ocaml                   # OCaml bindings
8 %bcond_without  python                  # Python bindings
9 %bcond_without  python3                 # Python 3.x bindings
10 %bcond_without  tcl                     # Tcl bindings
11 %bcond_without  x                       # X11-based utilities
12 %bcond_without  gpm                     # mouse tracking via GPM
13 %bcond_without  libbraille              # libbraille Braille driver
14 %bcond_without  liblouis                # liblouis in-line contracted Braille support
15 %bcond_without  espeak                  # eSpeak synthesizer driver
16 %bcond_without  espeak_ng               # eSpeak-NG synthesizer driver
17 %bcond_without  flite                   # Flite synthesizer driver
18 %bcond_with     mikropuhe               # Mikropuhe synthesizer driver [commercial, Finnish]
19 %bcond_without  speech_dispatcher       # Speech Dispatcher synthesizer driver
20 %bcond_with     swift                   # Swift synthesizer driver [commercial, from Cepstral]
21 %bcond_with     theta                   # Theta synthesizer driver [commercial, from Cepstral]
22 %bcond_with     viavoice                # IBM ViaVoice synthesizer driver [commercial]
23 %bcond_with     at_spi                  # AtSpi screen driver
24 %bcond_without  at_spi2                 # AtSpi2 screen driver
25
26 %define         brlapi_ver      0.8.5
27
28 %{?with_java:%{?use_default_jdk}}
29
30 Summary:        Braille display driver for Linux/Unix
31 Summary(pl.UTF-8):      Sterownik do wyświetlaczy Braille'a
32 Name:           brltty
33 Version:        6.6
34 Release:        1
35 License:        GPL v2+ (brltty and drivers), LGPL v2.1+ (APIs)
36 Group:          Daemons
37 Source0:        http://mielke.cc/brltty/archive/%{name}-%{version}.tar.xz
38 # Source0-md5:  ad3fd352481a7720d2b2fdf9ae64cf79
39 Patch1:         %{name}-speech-dispatcher.patch
40 Patch4:         %{name}-glibc25.patch
41 URL:            http://mielke.cc/brltty/
42 BuildRequires:  alsa-lib-devel
43 %{?with_at_spi:BuildRequires:   at-spi-devel}
44 %{?with_at_spi2:BuildRequires:  at-spi2-core-devel >= 2.0}
45 BuildRequires:  autoconf >= 2.64
46 BuildRequires:  automake
47 BuildRequires:  bison
48 # just headers
49 BuildRequires:  bluez-libs-devel
50 %{?with_at_spi2:BuildRequires:  dbus-devel >= 1.0}
51 %{?with_apidocs:BuildRequires:  doxygen}
52 %{?with_espeak:BuildRequires:   espeak-devel}
53 %{?with_espeak_ng:BuildRequires:        espeak-ng-devel}
54 BuildRequires:  expat-devel
55 %{?with_flite:BuildRequires:    flite-devel}
56 BuildRequires:  gettext-tools
57 %{?with_at_spi2:BuildRequires:  glib2-devel >= 2.0}
58 %{?with_gpm:BuildRequires:      gpm-devel}
59 %{?with_java:%buildrequires_jdk}
60 %{?with_java:BuildRequires:     jpackage-utils}
61 %{?with_libbraille:BuildRequires:       libbraille-devel}
62 BuildRequires:  libicu-devel
63 %{?with_liblouis:BuildRequires: liblouis-devel}
64 %{?with_lua:BuildRequires:      lua-devel}
65 BuildRequires:  ncurses-devel
66 %{?with_ocaml:BuildRequires:    ocaml}
67 BuildRequires:  pcre2-32-devel
68 BuildRequires:  pkgconfig
69 BuildRequires:  polkit-devel
70 %{?with_ptyhon:BuildRequires:   python}
71 %{?with_python:BuildRequires:   python-Cython}
72 %{?with_python3:BuildRequires:  python3}
73 %{?with_python3:BuildRequires:  python3-Cython}
74 BuildRequires:  rpm-build >= 4.6
75 %{?with_java:BuildRequires:     rpm-javaprov}
76 %{?with_python:BuildRequires:   rpm-pythonprov}
77 BuildRequires:  rpmbuild(macros) >= 2.021
78 BuildRequires:  sed >= 4.0
79 %{?with_speech_dispatcher:BuildRequires:        speech-dispatcher-devel >= 0.8}
80 BuildRequires:  systemd-devel >= 1:209
81 BuildRequires:  tar >= 1:1.22
82 %{?with_tcl:BuildRequires:      tcl-devel >= 8.5}
83 %if %{with x}
84 BuildRequires:  xorg-lib-libX11-devel
85 BuildRequires:  xorg-lib-libXaw-devel
86 BuildRequires:  xorg-lib-libXext-devel
87 BuildRequires:  xorg-lib-libXfixes-devel
88 BuildRequires:  xorg-lib-libXt-devel
89 BuildRequires:  xorg-lib-libXtst-devel
90 %endif
91 #%{?with_mikropuhe:BuildRequires:       Mikropuhe-devel (-lmikropuhe <mpwrfile.h>)}
92 #%{?with_swift:BuildRequires:   Swift-devel (-lswift <swift.h>)}
93 #%{?with_theta:BuildRequires:   Theta-devel (-ltheta <theta.h>)}
94 #%{?with_viavoice:BuildRequires:        ViaVoice-devel (-libmeci50 <eci.h>)}
95 BuildRequires:  xz
96 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
97
98 %description
99 BRLTTY is a background process (daemon) which provides access to the
100 Linux/Unix console (when in text mode) for a blind person using a
101 refreshable Braille display. It drives the Braille display, and
102 provides complete screen review functionality. Some speech capability
103 has also been incorporated.
104
105 %description -l pl.UTF-8
106 BRLTTY jest demonem, który udostępnia dostęp do linuksowej konsoli (w
107 trybie tekstowym) dla niewidomych używających wyświetlaczy Braille'a z
108 odświeżaniem (refreshable Braille display). BRLTTY steruje
109 wyświetlaczem Braille'a i dostarcza funkcjonalność całkowitego
110 przeglądu ekranu. Do tego pakietu została włączona możliwość syntezy
111 mowy.
112
113 %package -n dracut-brltty
114 Summary:        Braille support for Dracut
115 Summary(pl.UTF-8):      Obsługa Braille'a dla Dracuta
116 Group:          Applications/Text
117 Requires:       %{name} = %{version}-%{release}
118 Requires:       dracut
119
120 %description -n dracut-brltty
121 Braille support for Dracut.
122
123 %description -n dracut-brltty -l pl.UTF-8
124 Obsługa Braille'a dla Dracuta.
125
126 %package -n brlapi
127 Summary:        Application Programming Interface for BRLTTY
128 Summary(pl.UTF-8):      API do BRLTTY
129 License:        LGPL v2.1+
130 Group:          Libraries
131
132 %description -n brlapi
133 This package provides the run-time support for the Application
134 Programming Interface to BRLTTY.
135
136 Install this package if you have an application which directly
137 accesses a refreshable Braille display.
138
139 %description -n brlapi -l pl.UTF-8
140 Ten pakiet zawiera środowisko uruchomieniowe dla programów
141 korzystających z API BRLTTY.
142
143 Zainstaluj ten pakiet jeśli masz aplikację, która bezpośrednio używa
144 wyświetlacza Braille'a z odświeżaniem.
145
146 %package -n brlapi-devel
147 Summary:        Headers and documentation for BrlAPI
148 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do BrlAPI
149 License:        LGPL v2.1+
150 Group:          Development/Libraries
151 Requires:       brlapi = %{version}-%{release}
152
153 %description -n brlapi-devel
154 This package provides the header files, shared object linker
155 reference, and reference documentation for BrlAPI (the Application
156 Programming Interface to BRLTTY). It enables the implementation of
157 applications which take direct advantage of a refreshable Braille
158 display in order to present information in ways which are more
159 appropriate for blind users and/or to provide user interfaces which
160 are more specifically atuned to their needs.
161
162 Install this package if you're developing or maintaining an
163 application which directly accesses a refreshable Braille display.
164
165 %description -n brlapi-devel -l pl.UTF-8
166 Ten pakiet zawiera pliki nagłówkowe oraz dokumentację do BrlAPI (API
167 do BRLTTY). BrlAPI pozwala implementować aplikacje, które bezpośrednio
168 korzystają z wyświetlaczy Braille'a dostarczając interfejs użytkownika
169 bardziej przystosowany dla osób niewidomych.
170
171 Zainstaluj ten pakiet, jeśli tworzysz lub nadzorujesz aplikację
172 korzystającą bezpośrednio z odświeżalnych wyświetlaczy Braille'a.
173
174 %package -n brlapi-static
175 Summary:        Static BrlAPI library
176 Summary(pl.UTF-8):      Statyczna biblioteka BrlAPI
177 License:        LGPL v2.1+
178 Group:          Development/Libraries
179 Requires:       brlapi-devel = %{version}-%{release}
180
181 %description -n brlapi-static
182 This is package with static BrlAPI library.
183
184 %description -n brlapi-static -l pl.UTF-8
185 Ten pakiet zawiera statyczną wersję biblioteki BrlAPI.
186
187 %package -n brlapi-apidocs
188 Summary:        BrlAPI documentation
189 Summary(pl.UTF-8):      Documentacja BrlAPI
190 Group:          Documentation
191 BuildArch:      noarch
192
193 %description -n brlapi-apidocs
194 Documentation for BrlAPI in HTML format generated from brltty sources
195 by doxygen.
196
197 %description -n brlapi-apidocs -l pl.UTF-8
198 Dokumentacja BrlAPI w formacie HTML generowane ze źrodeł brltty przez
199 doxygen.
200
201 %package -n java-brlapi
202 Summary:        BrlAPI library for Java
203 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Javy
204 License:        LGPL v2.1+
205 Group:          Libraries
206 Requires:       brlapi = %{version}-%{release}
207
208 %description -n java-brlapi
209 BrlAPI library for Java.
210
211 %description -n java-brlapi -l pl.UTF-8
212 Biblioteka BrlAPI dla Javy.
213
214 %package -n lua-brlapi
215 Summary:        BrlAPI library for Lua
216 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Lua
217 License:        LGPL v2.1+
218 Group:          Libraries
219 Requires:       brlapi = %{version}-%{release}
220
221 %description -n lua-brlapi
222 BrlAPI library for Lua.
223
224 %description -n lua-brlapi -l pl.UTF-8
225 Biblioteka BrlAPI dla Lua.
226
227 %package -n ocaml-brlapi
228 Summary:        OCaml binding for BrlAPI
229 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI
230 License:        LGPL v2.1+
231 Group:          Libraries
232 Requires:       brlapi = %{version}-%{release}
233 %requires_eq    ocaml-runtime
234
235 %description -n ocaml-brlapi
236 OCaml binding for BrlAPI.
237
238 %description -n ocaml-brlapi -l pl.UTF-8
239 Wiązania OCamla do BrlAPI.
240
241 %package -n ocaml-brlapi-devel
242 Summary:        OCaml binding for BrlAPI - development files
243 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI - pliki programistyczne
244 License:        LGPL v2.1+
245 Group:          Libraries
246 Requires:       ocaml-brlapi = %{version}-%{release}
247 %requires_eq    ocaml
248
249 %description -n ocaml-brlapi-devel
250 OCaml binding for BrlAPI - development files.
251
252 %description -n ocaml-brlapi-devel -l pl.UTF-8
253 Wiązania OCamla do BrlAPI - pliki programistyczne.
254
255 %package -n python-brlapi
256 Summary:        Python 2.x interface to BrlAPI
257 Summary(pl.UTF-8):      Interfejs Pythona 2.x do BrlAPI
258 License:        LGPL v2.1+
259 Group:          Libraries
260 Requires:       brlapi = %{version}-%{release}
261
262 %description -n python-brlapi
263 Python 2.x interface to BrlAPI.
264
265 %description -n python-brlapi -l pl.UTF-8
266 Interfejs Pythona 2.x do BrlAPI.
267
268 %package -n python3-brlapi
269 Summary:        Python 3.x interface to BrlAPI
270 Summary(pl.UTF-8):      Interfejs Pythona 3.x do BrlAPI
271 License:        LGPL v2.1+
272 Group:          Libraries
273 Requires:       brlapi = %{version}-%{release}
274
275 %description -n python3-brlapi
276 Python 3.x interface to BrlAPI.
277
278 %description -n python3-brlapi -l pl.UTF-8
279 Interfejs Pythona 3.x do BrlAPI.
280
281 %package -n brlapi-tcl
282 Summary:        BrlAPI library for Tcl
283 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Tcl
284 License:        LGPL v2.1+
285 Group:          Libraries
286 Requires:       brlapi = %{version}-%{release}
287
288 %description -n brlapi-tcl
289 BrlAPI library for Tcl.
290
291 %description -n brlapi-tcl -l pl.UTF-8
292 Biblioteka BrlAPI dla Tcl.
293
294 %prep
295 %setup -q
296 %patch1 -p1
297 %patch4 -p1
298
299 %{__sed} -i -e '1s,/usr/bin/python$,%{__python},' Tables/Contraction/latex-access.ctb
300 %{__sed} -i -e '1s,/usr/bin/env bash,/bin/bash,' brltty-term brltty-ttysize
301
302 %build
303 %{__aclocal} -I m4
304 %{__autoconf}
305 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
306 %configure \
307         %{?with_java:JAVA_HOME=%{java_home}} \
308         --with-install-root="$RPM_BUILD_ROOT" \
309         %{!?with_libbraille:--without-libbraille} \
310         %{!?with_espeak:--without-espeak} \
311         %{!?with_espeak_ng:--without-espeak_ng} \
312         %{!?with_flite:--without-flite} \
313         %{!?with_speech_dispatcher:--without-speechd} \
314         %{!?with_ocaml:--disable-caml-bindings} \
315         %{!?with_gpm:--disable-gpm} \
316         %{!?with_java:--disable-java-bindings} \
317         %{!?with_liblouis:--disable-liblouis} \
318         --enable-lisp-bindings \
319         %{!?with_lua:--disable-lua-bindings} \
320         %{!?with_python:--disable-python-bindings} \
321         %{!?with_tcl:--disable-tcl-bindings} \
322         %{!?with_x:--disable-x} \
323         --with-speech-driver="-vv" \
324         --enable-api
325
326 %{__make} -j1
327
328 %if %{with python}
329 cd Bindings/Python
330 %py_build
331 cd ../..
332 %endif
333
334 %if %{with python3}
335 cd Bindings/Python
336 %py3_build
337 cd ../..
338 %endif
339
340 %install
341 rm -rf $RPM_BUILD_ROOT
342 install -d $RPM_BUILD_ROOT/var/lib/brltty
343
344 %{__make} -j1 install install-appstream install-dracut install-polkit install-systemd install-udev \
345         OCAML_INSTALL_TARGET=install-without-findlib \
346         UDEV_PARENT_LOCATION=/lib
347
348 # findlib-specific, useless in rpm
349 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so.owner
350
351 %if %{with python}
352 cd Bindings/Python
353 %py_install
354 cd ../..
355 %endif
356
357 %if %{with python3}
358 cd Bindings/Python
359 %py3_install
360 cd ../..
361 %endif
362
363 %if "%{_lib}" != "lib"
364         # Fix java plugin install path on 64-bit archs
365         install -d $RPM_BUILD_ROOT%{_libdir}/java
366         %{__mv} $RPM_BUILD_ROOT%{_prefix}/{lib,%{_lib}}/java/libbrlapi_java.so
367 %endif
368
369 install Bootdisks/bp2cf $RPM_BUILD_ROOT%{_bindir}/brltty-bp2cf
370 cp -p Documents/brltty.conf $RPM_BUILD_ROOT%{_sysconfdir}
371
372 # no sign in source wheter it is zh_CN or zh_TW
373 # but seems to contain Traditional Chinese characters
374 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{zh,zh_TW}
375
376 # packaged as %doc
377 %{__rm} $RPM_BUILD_ROOT%{_prefix}/lib/dracut/modules.d/99brltty/README
378
379 %find_lang %{name}
380
381 %clean
382 rm -rf $RPM_BUILD_ROOT
383
384 %pre
385 # The pre-install scriptlet.
386
387 # If a configuration file already exists then rpm installs the new one as
388 # <path>.rpmnew. If this is done then the .rpmnew file is overwritten if it
389 # already exists.
390
391 # There's no explicit way to tell if a configuration file has been installed
392 # as itself or as a .rpmnew file. The way we'll figure it out, therefore, is by
393 # erasing the .rpmnew file now so that we can see if it gets created later.
394 rm -f "%{_sysconfdir}/brltty.conf.rpmnew"
395
396 %post
397 # If BRLTTY's boot parameter has been specified then update the just installed
398 # configuration file template to reflect the options supplied thereby.
399
400 # First, we need to determine which file to update. If there's a .rpmnew file
401 # then update it since a previous configuration file must already have existed.
402 file="%{_sysconfdir}/brltty.conf"
403 new="${file}.rpmnew"
404 [ -f "${new}" ] && file="${new}"
405
406 # Update the configuration file template via the Bootdisks/bp2cf script.
407 %{_bindir}/brltty-bp2cf -u -f "${file}" >/dev/null 2>&1 || :
408
409 %post   -n brlapi -p /sbin/ldconfig
410 %postun -n brlapi -p /sbin/ldconfig
411
412 %files -f %{name}.lang
413 %defattr(644,root,root,755)
414 %doc Documents/{Manual-BRLTTY/English/BRLTTY*,ChangeLog,HISTORY,TODO}
415 %attr(755,root,root) %{_bindir}/brltty
416 %attr(755,root,root) %{_bindir}/brltty-atb
417 %attr(755,root,root) %{_bindir}/brltty-bp2cf
418 %{_bindir}/brltty-config.sh
419 %attr(755,root,root) %{_bindir}/brltty-clip
420 %attr(755,root,root) %{_bindir}/brltty-cldr
421 %attr(755,root,root) %{_bindir}/brltty-ctb
422 %attr(755,root,root) %{_bindir}/brltty-genkey
423 %attr(755,root,root) %{_bindir}/brltty-hid
424 %attr(755,root,root) %{_bindir}/brltty-ktb
425 %attr(755,root,root) %{_bindir}/brltty-lscmds
426 %attr(755,root,root) %{_bindir}/brltty-lsinc
427 %attr(755,root,root) %{_bindir}/brltty-mkuser
428 %attr(755,root,root) %{_bindir}/brltty-morse
429 %{_bindir}/brltty-prologue.bash
430 %{_bindir}/brltty-prologue.lua
431 %{_bindir}/brltty-prologue.sh
432 %{_bindir}/brltty-prologue.tcl
433 %attr(755,root,root) %{_bindir}/brltty-setcaps
434 %attr(755,root,root) %{_bindir}/brltty-term
435 %attr(755,root,root) %{_bindir}/brltty-trtxt
436 %attr(755,root,root) %{_bindir}/brltty-ttb
437 %attr(755,root,root) %{_bindir}/brltty-ttysize
438 %attr(755,root,root) %{_bindir}/brltty-tune
439 %attr(755,root,root) %{_bindir}/eutp
440 %attr(755,root,root) %{_bindir}/vstp
441 %{?with_x:%attr(755,root,root) %{_bindir}/xbrlapi}
442 %dir %{_libdir}/brltty
443 # Braille drivers
444 %attr(755,root,root) %{_libdir}/brltty/libbrlttybal.so
445 %attr(755,root,root) %{_libdir}/brltty/libbrlttybat.so
446 %attr(755,root,root) %{_libdir}/brltty/libbrlttybba.so
447 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbc.so
448 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbd.so
449 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbg.so
450 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbl.so
451 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbm.so
452 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbn.so
453 %attr(755,root,root) %{_libdir}/brltty/libbrlttybcb.so
454 %attr(755,root,root) %{_libdir}/brltty/libbrlttybce.so
455 %attr(755,root,root) %{_libdir}/brltty/libbrlttybcn.so
456 %attr(755,root,root) %{_libdir}/brltty/libbrlttybdp.so
457 %attr(755,root,root) %{_libdir}/brltty/libbrlttybec.so
458 %attr(755,root,root) %{_libdir}/brltty/libbrlttybeu.so
459 %attr(755,root,root) %{_libdir}/brltty/libbrlttybfa.so
460 %attr(755,root,root) %{_libdir}/brltty/libbrlttybfs.so
461 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhd.so
462 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhm.so
463 %attr(755,root,root) %{_libdir}/brltty/libbrlttybht.so
464 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhw.so
465 %attr(755,root,root) %{_libdir}/brltty/libbrlttybic.so
466 %attr(755,root,root) %{_libdir}/brltty/libbrlttybir.so
467 %{?with_libbraille:%attr(755,root,root) %{_libdir}/brltty/libbrlttyblb.so}
468 %attr(755,root,root) %{_libdir}/brltty/libbrlttyblt.so
469 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmb.so
470 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmd.so
471 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmm.so
472 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmn.so
473 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmt.so
474 %attr(755,root,root) %{_libdir}/brltty/libbrlttybnp.so
475 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpg.so
476 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpm.so
477 %attr(755,root,root) %{_libdir}/brltty/libbrlttybsk.so
478 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtn.so
479 %attr(755,root,root) %{_libdir}/brltty/libbrlttybts.so
480 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtt.so
481 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvd.so
482 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvo.so
483 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvr.so
484 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvs.so
485 %{?with_x:%attr(755,root,root) %{_libdir}/brltty/libbrlttybxw.so}
486 # speech synthesizer drivers
487 %attr(755,root,root) %{_libdir}/brltty/libbrlttysal.so
488 %attr(755,root,root) %{_libdir}/brltty/libbrlttysbl.so
489 %attr(755,root,root) %{_libdir}/brltty/libbrlttyscb.so
490 %{?with_espeak_ng:%attr(755,root,root) %{_libdir}/brltty/libbrlttysen.so}
491 %{?with_espeak:%attr(755,root,root) %{_libdir}/brltty/libbrlttyses.so}
492 %{?with_flite:%attr(755,root,root) %{_libdir}/brltty/libbrlttysfl.so}
493 %attr(755,root,root) %{_libdir}/brltty/libbrlttysfv.so
494 %attr(755,root,root) %{_libdir}/brltty/libbrlttysgs.so
495 %{?with_mikropuhe:%attr(755,root,root) %{_libdir}/brltty/libbrlttysmp.so}
496 %{?with_speech_dispatcher:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssd.so}
497 %{?with_swift:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssw.so}
498 %{?with_theta:%attr(755,root,root) %{_libdir}/brltty/libbrlttysth.so}
499 %{?with_viavoice:%attr(755,root,root) %{_libdir}/brltty/libbrlttysvv.so}
500 %attr(755,root,root) %{_libdir}/brltty/libbrlttysxs.so
501 # screen drivers
502 %{?with_at_spi2:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxa2.so}
503 %{?with_at_spi:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxas.so}
504 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxem.so
505 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxfv.so
506 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxlx.so
507 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxsc.so
508 %if "%{_libexecdir}" != "%{_libdir}"
509 %dir %{_libexecdir}/brltty
510 %endif
511 %attr(755,root,root) %{_libexecdir}/brltty/brltty-pty
512 %attr(755,root,root) %{_libexecdir}/brltty/systemd-wrapper
513 %attr(755,root,root) %{_libexecdir}/brltty/udev-wrapper
514 %{_sysconfdir}/brltty
515 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/brltty.conf
516 /lib/udev/rules.d/90-brltty-hid.rules
517 /lib/udev/rules.d/90-brltty-uinput.rules
518 /lib/udev/rules.d/90-brltty-usb-customized.rules
519 /lib/udev/rules.d/90-brltty-usb-generic.rules
520 %{systemdunitdir}/brltty.path
521 %{systemdunitdir}/brltty@.path
522 %{systemdunitdir}/brltty@.service
523 %{systemdunitdir}/brltty-device@.service
524 %{systemdtmpfilesdir}/brltty.conf
525 #%{_prefix}/lib/sysusers.d/brltty.conf
526 #%attr(3777,brltty,brltty)
527 %dir /var/lib/BrlAPI
528 #%attr(2770,brltty,brltty)
529 %dir /var/lib/brltty
530 %{_mandir}/man1/brltty.1*
531 %{_mandir}/man1/eutp.1*
532 %{_mandir}/man1/vstp.1*
533 %{?with_x:%{_mandir}/man1/xbrlapi.1*}
534
535 %if %{with x}
536 # gdm autostart - subpackage?
537 #%{_datadir}/gdm/greeter/autostart/xbrlapi.desktop
538 #/etc/X11/Xsession.d/90xbrlapi
539 %{_datadir}/metainfo/org.a11y.brltty.metainfo.xml
540 %endif
541 %{_datadir}/polkit-1/actions/org.a11y.brlapi.policy
542 %{_datadir}/polkit-1/rules.d/org.a11y.brlapi.rules
543
544 %files -n dracut-brltty
545 %defattr(644,root,root,755)
546 %doc Initramfs/Dracut/README
547 %dir %{_prefix}/lib/dracut/modules.d/99brltty
548 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/alsa-start.sh
549 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/bluetooth-start.sh
550 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/brltty-start.sh
551 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/brltty-stop.sh
552 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/dbus-start.sh
553 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/module-setup.sh
554 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/pulse-start.sh
555 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/pulse-stop.sh
556 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/speechd-start.sh
557
558 %files -n brlapi
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{_libdir}/libbrlapi.so.*.*.*
561 %attr(755,root,root) %ghost %{_libdir}/libbrlapi.so.0.8
562
563 %files -n brlapi-devel
564 %defattr(644,root,root,755)
565 %doc Documents/Manual-BrlAPI/English/BrlAPI*
566 %attr(755,root,root) %{_libdir}/libbrlapi.so
567 %{_includedir}/brltty
568 %{_includedir}/brlapi*.h
569 %{_pkgconfigdir}/brltty.pc
570 %{_mandir}/man3/brlapi_*.3*
571
572 %files -n brlapi-static
573 %defattr(644,root,root,755)
574 %{_libdir}/libbrlapi.a
575
576 %if %{with apidocs}
577 %files -n brlapi-apidocs
578 %defattr(644,root,root,755)
579 %doc Documents/BrlAPIref/html/*
580 %endif
581
582 %if %{with java}
583 %files -n java-brlapi
584 %defattr(644,root,root,755)
585 %attr(755,root,root) %{_libdir}/java/libbrlapi_java.so
586 %{_javadir}/brlapi.jar
587 %endif
588
589 %if %{with lua}
590 %files -n lua-brlapi
591 %defattr(644,root,root,755)
592 %attr(755,root,root) %{_libdir}/lua/*.*/brlapi.so
593 %endif
594
595 %if %{with ocaml}
596 %files -n ocaml-brlapi
597 %defattr(644,root,root,755)
598 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so
599
600 %files -n ocaml-brlapi-devel
601 %defattr(644,root,root,755)
602 %dir %{_libdir}/ocaml/brlapi
603 %{_libdir}/ocaml/brlapi/META
604 %{_libdir}/ocaml/brlapi/brlapi.cm[aix]*
605 %{_libdir}/ocaml/brlapi/brlapi.mli
606 %{_libdir}/ocaml/brlapi/libbrlapi_stubs.a
607 %endif
608
609 %if %{with python}
610 %files -n python-brlapi
611 %defattr(644,root,root,755)
612 %attr(755,root,root) %{py_sitedir}/brlapi.so
613 %{py_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
614
615 %if %{with python3}
616 %files -n python3-brlapi
617 %defattr(644,root,root,755)
618 %attr(755,root,root) %{py3_sitedir}/brlapi.cpython-*.so
619 %{py3_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
620 %endif
621 %endif
622
623 %if %{with tcl}
624 %files -n brlapi-tcl
625 %defattr(644,root,root,755)
626 %dir %{_libdir}/brlapi-%{brlapi_ver}
627 %attr(755,root,root) %{_libdir}/brlapi-%{brlapi_ver}/libbrlapi_tcl.so
628 %{_libdir}/brlapi-%{brlapi_ver}/pkgIndex.tcl
629 %endif
This page took 0.108547 seconds and 4 git commands to generate.