]> git.pld-linux.org Git - packages/botan2.git/blob - botan2.spec
- release 2 (by relup.sh)
[packages/botan2.git] / botan2.spec
1 # TODO: fix sphinx docs build (sphinx-build hangs?)
2 #
3 # Conditional build:
4 %bcond_without  tests           # unit tests
5 %bcond_with     apidocs         # Sphinx based HTML documentation [hangs, FIXME]
6 %bcond_without  static_libs     # static library
7 %bcond_without  python          # Python bindings
8 %bcond_without  python2         # CPython 2.x binding
9 %bcond_without  python3         # CPython 3.x binding
10
11 %if %{without python}
12 %undefine       with_python2
13 %undefine       with_python3
14 %endif
15 Summary:        Crypto library written in C++
16 Summary(pl.UTF-8):      Biblioteka kryptograficzna napisana w C++
17 Name:           botan2
18 Version:        2.7.0
19 Release:        2
20 License:        BSD
21 Group:          Libraries
22 Source0:        https://botan.randombit.net/releases/Botan-%{version}.tgz
23 # Source0-md5:  c819fce944ee688e01b07bb6332d9586
24 URL:            https://botan.randombit.net/
25 BuildRequires:  bzip2-devel
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  openssl-devel
28 BuildRequires:  python >= 1:2.7
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  rpmbuild(macros) >= 1.714
31 %{?with_apidocs:BuildRequires:  sphinx-pdg}
32 BuildRequires:  zlib-devel
33 %if %{with python2}
34 BuildRequires:  python-devel >= 1:2.7
35 %endif
36 %if %{with python3}
37 BuildRequires:  python3-devel >= 1:3.4
38 %endif
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Botan is a BSD-licensed crypto library written in C++. It provides a
43 wide variety of basic cryptographic algorithms, X.509 certificates and
44 CRLs, PKCS#10 certificate requests, a filter/pipe message processing
45 system, and a wide variety of other features, all written in portable
46 C++. The API reference, tutorial, and examples may help impart the
47 flavor of the library.
48
49 %description -l pl.UTF-8
50 Botan to biblioteka kryptograficzna na licencji BSD, napisana w C++.
51 Zapewnia szeroki zakres algorytmów kryptograficznych, certyfikaty
52 X.509 oraz CRL, żądania certyfikatów PKCS#10, system przetwarzania
53 komunikatów z filtrowaniem/potokami i wiele innych funkcji, wszystko
54 napisane w przenośnym C++. Dodatkowe udogodnienia to dokumentacja API,
55 wprowadzenie oraz przykłady.
56
57 %package devel
58 Summary:        Header files for Botan library
59 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Botan
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       bzip2-devel
63 Requires:       gmp-devel
64 Requires:       openssl-devel
65 Requires:       zlib-devel
66
67 %description devel
68 This package contains the header files for developing applications
69 that use Botan.
70
71 %description devel
72 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
73 wykorzystujących bibliotekę Botan.
74
75 %package static
76 Summary:        Static Botan library
77 Summary(pl.UTF-8):      Statyczna biblioteka Botan
78 Group:          Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description static
82 Static Botan library.
83
84 %description static -l pl.UTF-8
85 Statyczna biblioteka Botan.
86
87 %package apidocs
88 Summary:        Botan API documentation
89 Summary(pl.UTF-8):      Dokumentacja API biblioteki Botan
90 Group:          Documentation
91 %if "%{_rpmversion}" >= "5"
92 BuildArch:      noarch
93 %endif
94
95 %description apidocs
96 API and internal documentation for Botan library.
97
98 %description apidocs -l pl.UTF-8
99 Dokumentacja API biblioteki Botan.
100
101 %package -n python-botan
102 Summary:        Python 2.x binding for Botan library
103 Summary(pl.UTF-8):      Wiązanie Pythona 2.x do biblioteki Botan
104 Group:          Libraries/Python
105 Requires:       %{name} = %{version}-%{release}
106
107 %description -n python-botan
108 Python 2.x binding for Botan library.
109
110 %description -n python-botan -l pl.UTF-8
111 Wiązanie Pythona 2.x do biblioteki Botan.
112
113 %package -n python3-botan
114 Summary:        Python 3.x binding for Botan library
115 Summary(pl.UTF-8):      Wiązanie Pythona 3.x do biblioteki Botan
116 Group:          Libraries/Python
117 Requires:       %{name} = %{version}-%{release}
118
119 %description -n python3-botan
120 Python 3.x binding for Botan library.
121
122 %description -n python3-botan -l pl.UTF-8
123 Wiązanie Pythona 3.x do biblioteki Botan.
124
125 %prep
126 %setup -q -n Botan-%{version}
127
128 # kill shebang, nothing to execute directly
129 %{__sed} -i -e '1d' src/python/botan2.py
130
131 %build
132 # we have the necessary prerequisites, so enable optional modules
133 %define enable_modules bzip2,lzma,zlib,openssl,sqlite3,tpm,pkcs11
134
135 # fixme: maybe disable unix_procs, very slow.
136 %define disable_modules %{nil}
137
138 ./configure.py \
139         --prefix=%{_prefix} \
140         --libdir=%{_lib} \
141         --cc=gcc \
142         --os=linux \
143         --cpu=%{_arch} \
144         --enable-modules=%{enable_modules} \
145         --disable-modules=%{disable_modules} \
146 %if %{with python2}
147         --with-python-version=%{py_ver} \
148 %endif
149         %{!?with_apidocs:--without-sphinx}
150
151 # (ab)using CXX as an easy way to inject our CXXFLAGS
152 %{__make} \
153         CXX="%{__cxx} -pthread" \
154         CXXFLAGS="%{rpmcxxflags}"
155
156 %if %{with apidocs}
157 %{__make} docs
158 %endif
159
160 %if %{with tests}
161 LD_LIBRARY_PATH=. ./botan-test
162 %endif
163
164 %install
165 rm -rf $RPM_BUILD_ROOT
166
167 %{__make} install \
168         INSTALL_CMD_EXEC="install -p -m 755" \
169         INSTALL_CMD_DATA="install -p -m 644" \
170         DESTDIR=$RPM_BUILD_ROOT
171
172 %if %{with python2}
173 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
174 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
175 %py_postclean
176 %endif
177
178 %if %{with python3}
179 install -d $RPM_BUILD_ROOT%{py3_sitedir}
180 cp -p src/python/botan2.py $RPM_BUILD_ROOT%{py3_sitedir}
181 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
182 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
183 %endif
184
185 # packaged as %doc
186 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/botan-%{version}
187
188 %if %{with apidocs}
189 install -d $RPM_BUILD_ROOT%{_examplesdir}
190 cp -pr doc/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
191 %endif
192
193 %clean
194 rm -rf $RPM_BUILD_ROOT
195
196 %post   -p /sbin/ldconfig
197 %postun -p /sbin/ldconfig
198
199 %files
200 %defattr(644,root,root,755)
201 %doc license.txt news.rst readme.rst doc/{authors.txt,credits.rst,reading_list.txt,manual/roadmap.rst,security.rst,todo.rst}
202 %attr(755,root,root) %{_bindir}/botan
203 %attr(755,root,root) %{_libdir}/libbotan-2.so.*.*
204 %attr(755,root,root) %ghost %{_libdir}/libbotan-2.so.7
205 %{_mandir}/man1/botan.1*
206
207 %files devel
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_libdir}/libbotan-2.so
210 %{_includedir}/botan-2
211 %{_pkgconfigdir}/botan-2.pc
212
213 %if %{with static_libs}
214 %files static
215 %defattr(644,root,root,755)
216 %{_libdir}/libbotan-2.a
217 %endif
218
219 %if %{with apidocs}
220 %files apidocs
221 %defattr(644,root,root,755)
222 # FIXME: update path after fixing sphinx build
223 %doc _doc/manual/{_static,*.html,*.js}
224 %{_examplesdir}/%{name}-%{version}
225 %endif
226
227 %if %{with python2}
228 %files -n python-botan
229 %defattr(644,root,root,755)
230 %{py_sitedir}/botan2.py[co]
231 %endif
232
233 %if %{with python3}
234 %files -n python3-botan
235 %defattr(644,root,root,755)
236 %{py3_sitedir}/botan2.py
237 %{py3_sitedir}/__pycache__/botan2.cpython-*.py[co]
238 %endif
This page took 0.111861 seconds and 4 git commands to generate.