]> git.pld-linux.org Git - packages/botan2.git/blame - botan.spec
- up to 1.8.14
[packages/botan2.git] / botan.spec
CommitLineData
7f5657d3
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4%bcond_without apidocs # do not build and package API docs
5%bcond_without static_libs # don't build static libraries
6
7Summary: Crypto library written in C++
8Name: botan
6f955439 9Version: 1.8.14
7f5657d3
ER
10Release: 1
11License: BSD
12Group: Libraries
13URL: http://botan.randombit.net/
14# tarfile is stripped using repack.sh. original tarfile to be found
15# here: http://files.randombit.net/botan/Botan-%%{version}.tbz
6f955439
AM
16Source0: http://pkgs.fedoraproject.org/repo/pkgs/botan/Botan-%{version}.stripped.tbz/4b5ce78b1cfc0735eb7ec4f6903068ca/Botan-%{version}.stripped.tbz
17# Source0-md5: 4b5ce78b1cfc0735eb7ec4f6903068ca
7f5657d3
ER
18Source1: README.fedora
19# soname was changed unintentionally upstream, revert it.
20Patch0: soname.patch
21BuildRequires: bzip2-devel
22BuildRequires: gmp-devel
23BuildRequires: libstdc++-devel
24BuildRequires: openssl-devel
25BuildRequires: python
26BuildRequires: zlib-devel
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30Botan is a BSD-licensed crypto library written in C++. It provides a
31wide variety of basic cryptographic algorithms, X.509 certificates and
32CRLs, PKCS \#10 certificate requests, a filter/pipe message processing
33system, and a wide variety of other features, all written in portable
34C++. The API reference, tutorial, and examples may help impart the
35flavor of the library.
36
37%package devel
38Summary: Development files for botan
39Group: Development/Libraries
40Requires: %{name} = %{version}-%{release}
41Requires: bzip2-devel
42Requires: gmp-devel
43Requires: openssl-devel
44Requires: pkgconfig
45Requires: zlib-devel
46
47%description devel
48This package contains libraries and header files for developing
49applications that use botan.
50
51%package static
52Summary: Static botan library
53Summary(pl.UTF-8): Statyczna biblioteka botan
54Group: Development/Libraries
55Requires: %{name}-devel = %{version}-%{release}
56
57%description static
58Static botan library.
59
60%description static -l pl.UTF-8
61Statyczna biblioteka botan.
62
63%package apidocs
64Summary: botan API documentation
65Summary(pl.UTF-8): Dokumentacja API biblioteki botan
66Group: Documentation
67
68%description apidocs
69API and internal documentation for botan library.
70
71%description apidocs -l pl.UTF-8
72Dokumentacja API biblioteki botan.
73
74%prep
75%setup -q -n Botan-%{version}
76%patch0 -p0
77cp -p %{SOURCE1} .
78
79%build
80# we have the necessary prerequisites, so enable optional modules
81%define enable_modules gnump,bzip2,zlib,openssl
82
83# fixme: maybe disable unix_procs, very slow.
84%define disable_modules %{nil}
85
86./configure.py \
87 --prefix=%{_prefix} \
88 --libdir=%{_lib} \
89 --cc=gcc \
90 --os=linux \
91 --cpu=%{_arch} \
92 --enable-modules=%{enable_modules} \
93 --disable-modules=%{disable_modules}
94
95# (ab)using CXX as an easy way to inject our CXXFLAGS
96%{__make} \
97 CXX="%{__cxx} %{rpmcxxflags}"
98
99%if %{with tests}
100%{__make} \
101 CXX="%{__cxx} %{rpmcxxflags}" check
102
103# these checks would fail
104mv checks/validate.dat{,.orig}
105awk '/\[.*\]/{f=0} /\[(RC5.*|RC6|IDEA)\]/{f=1} (f && !/^#/){sub(/^/,"#")} {print}' \
106 checks/validate.dat.orig > checks/validate.dat
107LD_LIBRARY_PATH=. ./check --validate
108%endif
109
110%install
111rm -rf $RPM_BUILD_ROOT
112%{__make} install \
113 INSTALL_CMD_EXEC="install -p -m 755" \
114 INSTALL_CMD_DATA="install -p -m 644" \
115 DOCDIR=_doc \
116 DESTDIR=$RPM_BUILD_ROOT%{_prefix}
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
923e0086
ER
121# NOTE: only update ld.so cache, there are no symlinks
122%post -p /sbin/postshell
123/sbin/ldconfig -X
124%postun -p /sbin/postshell
125/sbin/ldconfig -X
7f5657d3
ER
126
127%files
128%defattr(644,root,root,755)
129%doc _doc/readme.txt _doc/log.txt _doc/thanks.txt _doc/credits.txt
130%doc _doc/license.txt _doc/fips140.tex _doc/pgpkeys.asc
131%doc README.fedora
132%attr(755,root,root) %{_libdir}/libbotan-1.8.*.so
133
134%files devel
135%defattr(644,root,root,755)
136%attr(755,root,root) %{_bindir}/botan-config
137%{_includedir}/botan
138%{_libdir}/libbotan.so
139%{_pkgconfigdir}/botan-1.8.pc
140
141%if %{with static_libs}
142%files static
143%defattr(644,root,root,755)
144%{_libdir}/libbotan.a
145%endif
146
147%if %{with apidocs}
148%files apidocs
149%defattr(644,root,root,755)
150%doc doc/examples
151%doc _doc/api* _doc/tutorial*
152%endif
This page took 0.088251 seconds and 4 git commands to generate.