]> git.pld-linux.org Git - packages/bootsplash.git/blob - bootsplash.spec
- x32 rebuild
[packages/bootsplash.git] / bootsplash.spec
1 # TODO:
2 # - place somewhere info that distkernel support only 16bit splashes (thnx Tomasz Grobelny)
3 #
4 Summary:        Bootsplash - graphical boot process for Linux
5 Summary(de.UTF-8):      Bootsplash - graphischer System Start
6 Summary(pl.UTF-8):      Bootsplash - graficzny proces startu systemu dla Linuksa
7 Name:           bootsplash
8 Version:        3.2
9 Release:        7
10 License:        GPL v2
11 Group:          Applications/System
12 Source0:        http://www.bootsplash.de/files/splashutils/%{name}-%{version}.tar.bz2
13 # Source0-md5:  b74c104372fd182d0442b3ed63210e29
14 Source1:        %{name}.script
15 Source2:        %{name}-bootanim.script
16 Source3:        %{name}.sysconfig
17 Source4:        %{name}.init
18 Patch0:         %{name}-3.2_makefile_libmng.patch
19 URL:            http://www.bootsplash.org/
20 BuildRequires:  freetype-devel >= 2.1
21 BuildRequires:  libmng-devel
22 BuildRequires:  rpmbuild(macros) >= 1.268
23 Requires(post,preun):   /sbin/chkconfig
24 Suggests:       bootsplash-theme
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _bindir /bin
28
29 %description
30 When you have a kernel with bootsplash capability you can use the
31 bootsplash and control its behaviour with this set of userspace
32 utilities.
33
34 %description -l de.UTF-8
35 Wenn du einen Kernel mit der bootsplash Option hast, kannst du diese
36 mit diesen Programmen steuern.
37
38 %description -l pl.UTF-8
39 Mając jądro z opcją bootsplash można uzyskać graficzny ekran podczas
40 startu systemu i sterować jego zachowaniem przy użyciu tego zbioru
41 narzędzi przestrzeni użytkownika.
42
43 %prep
44 %setup -q
45 %patch0 -p1
46 rm -f Utilities/splash.o
47
48 %build
49 %{__make} -C Utilities \
50         CC="%{__cc}" \
51         CFLAGS="%{rpmcflags} -Wall -I/usr/include/freetype2 -DDEFAULT_FONTNAME=\\\"%{_datadir}/%{name}/luxisri.ttf\\\"" \
52         STRIP=true
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{name},%{_sysconfdir}/bootsplash/themes} \
57          $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
58
59 install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/splash
60 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/bootanim
61 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/bootsplash
62 install %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/bootsplash
63 install Scripts/* $RPM_BUILD_ROOT%{_datadir}/%{name}
64 install Utilities/splash $RPM_BUILD_ROOT%{_bindir}/splash.bin
65 install Utilities/{fbmngplay,fbresolution,fbtruetype} $RPM_BUILD_ROOT%{_bindir}
66 install Utilities/*.ttf $RPM_BUILD_ROOT%{_datadir}/%{name}
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post
72 /sbin/chkconfig --add bootsplash
73
74 %preun
75 if [ "$1" = "0" ]; then
76         %service bootsplash stop
77         /sbin/chkconfig --del bootsplash
78 fi
79
80 %files
81 %defattr(644,root,root,755)
82 %doc {Documentation,Utilities}/README.*
83 %attr(755,root,root) %{_bindir}/*
84 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bootsplash
85 %attr(754,root,root) /etc/rc.d/init.d/bootsplash
86 %{_datadir}/%{name}
87 %dir %{_sysconfdir}/bootsplash
88 %dir %{_sysconfdir}/bootsplash/themes
This page took 0.100138 seconds and 3 git commands to generate.