]> git.pld-linux.org Git - packages/boolstuff.git/blob - boolstuff.spec
- unified preamble in %changelog
[packages/boolstuff.git] / boolstuff.spec
1 Summary:        BoolStuff is a C++ library that supports a few operations on boolean expression binary trees
2 Name:           boolstuff
3 Version:        0.1.13
4 Release:        1
5 License:        GPL
6 Group:          Libraries
7 Source0:        http://perso.b2b2c.ca/sarrazip/dev/%{name}-%{version}.tar.gz
8 # Source0-md5:  084a834f8b4c59f690f1dcf2f385d404
9 URL:            http://perso.b2b2c.ca/sarrazip/dev/boolstuff.html
10 BuildRequires:  autoconf
11 BuildRequires:  automake
12 BuildRequires:  libstdc++-devel
13 BuildRequires:  libtool
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 BoolStuff is a C++ library that supports a few operations on boolean
18 expression binary trees. The main features are:
19
20 a simple boolean expression parser (supports operators AND, OR and
21 NOT, as well as parentheses); an algorithm to convert a boolean
22 expression binary tree into its Disjunctive Normal Form (this
23 algorithm supports the NOT operator); a function that determines if an
24 expression tree is in DNF.
25
26 %package devel
27 Summary:        Header files for boolstuff library
28 Group:          Development/Libraries
29 Requires:       %{name} = %{version}-%{release}
30
31 %description devel
32 Header files for boolstuff library.
33
34 %package tools
35 Summary:        Commandline boolstuff tools
36 Group:          Applications
37
38 %description tools
39 Commandline boolstuff tools.
40
41 %prep
42 %setup -q
43 echo "AC_CONFIG_MACRO_DIR([macros])" >> configure.ac
44
45 %build
46 %{__libtoolize}
47 %{__aclocal} -I macros
48 %{__autoconf}
49 %{__automake}
50 %configure
51 %{__make}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}
60 install examples/{*.cpp,*.pl} $RPM_BUILD_ROOT%{_examplesdir}/%{name}
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post   -p /sbin/ldconfig
66 %postun -p /sbin/ldconfig
67
68 %files
69 %defattr(644,root,root,755)
70 %doc AUTHORS ChangeLog NEWS README THANKS TODO
71 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
72 %attr(755,root,root) %ghost %{_libdir}/lib*.so.?
73 %{_libdir}/lib*.la
74 %{_mandir}/man3/boolstuff.3*
75 %{_examplesdir}/%{name}
76
77 %files devel
78 %defattr(644,root,root,755)
79 %{_libdir}/lib*.so
80 %{_includedir}/boolstuff-0.1
81 %{_pkgconfigdir}/*.pc
82
83 %files tools
84 %defattr(644,root,root,755)
85 %attr(755,root,root) %{_bindir}/*
86 %{_mandir}/man1/booldnf.1*
This page took 0.110422 seconds and 4 git commands to generate.