]> git.pld-linux.org Git - packages/bogofilter.git/blob - bogofilter.spec
Release 3 (by relup.sh)
[packages/bogofilter.git] / bogofilter.spec
1 # TODO:
2 # - make separate package linked with sqlite
3 # - make milter subpackage
4 # - maybe make some separate package with contrib perl scripts?
5 # - remove bogus banner
6 #
7 Summary:        Bayesian Spam Filter
8 Summary(pl.UTF-8):      Bayesowski Filtr Antyspamowy
9 Name:           bogofilter
10 Version:        1.2.4
11 Release:        3
12 License:        GPL v2
13 Group:          Applications/Mail
14 Source0:        http://downloads.sourceforge.net/bogofilter/%{name}-%{version}.tar.bz2
15 # Source0-md5:  d0a5eebb3274b23ceabe766a6443a1c5
16 Patch0:         %{name}-home_etc.patch
17 URL:            http://bogofilter.sourceforge.net/
18 BuildRequires:  autoconf >= 2.53
19 BuildRequires:  automake
20 BuildRequires:  db-devel
21 BuildRequires:  flex
22 BuildRequires:  gettext-tools
23 BuildRequires:  gsl-devel >= 1.4
24 Requires:       gsl >= 1.4
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         specflags_ia32  -fomit-frame-pointer
28
29 %description
30 Bogofilter is a Bayesian spam filter. In its normal mode of operation,
31 it takes an email message or other text on standard input, does a
32 statistical check against lists of "good" and "bad" words, and returns
33 a status code indicating whether or not the message is spam.
34 Bogofilter is designed with fast algorithms (including Berkeley DB
35 system), coded directly in C, and tuned for speed, so it can be used
36 for production by sites that process a lot of mail.
37
38 %description -l pl.UTF-8
39 Bogofilter jest bayesowski filtrem antyspamowym. W podstawowym trybie
40 działania na emailu lub innym tekście odczytanym na wejściu wykonuje
41 statystyczne testy na występowanie "dobrych" i "złych" słów i zwraca
42 kod powrotu wskazujący czy wiadomość jest spamem, czy też nie.
43 Bogofilter jest zaprojektowany z użyciem szybkich algorytmów
44 (włączając w to Berkeley DB), napisany w czystym C i "podkręcony" pod
45 kątem szybkości, a więc może być używany na systemach "produkcyjnych",
46 które przetwarzają duże ilości poczty.
47
48 %prep
49 %setup -q
50 %patch0 -p1
51
52 %build
53 %{__aclocal}
54 %{__autoconf}
55 %{__autoheader}
56 %{__automake}
57 %configure
58 %{__make}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 cp $RPM_BUILD_ROOT%{_sysconfdir}/bogofilter.cf.example $RPM_BUILD_ROOT%{_sysconfdir}/bogofilter.cf
67
68 install bogogrep $RPM_BUILD_ROOT%{_bindir}
69 # Some apps from contrib:
70 install contrib/bfproxy.pl $RPM_BUILD_ROOT%{_bindir}
71 install contrib/bogominitrain.pl $RPM_BUILD_ROOT%{_bindir}
72 install contrib/mime.get.rfc822.pl $RPM_BUILD_ROOT%{_bindir}
73 install contrib/printmaildir.pl $RPM_BUILD_ROOT%{_bindir}
74 install contrib/spamitarium.pl $RPM_BUILD_ROOT%{_bindir}
75 install contrib/stripsearch.pl $RPM_BUILD_ROOT%{_bindir}
76 install contrib/trainbogo.sh $RPM_BUILD_ROOT%{_bindir}
77
78 # Some final cleanups:
79 rm -f $RPM_BUILD_ROOT%{_bindir}/lexertest
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 # That banner is bogus - no sense to have it _while_ upgrading...
85 # It should be some trigger...
86 # It makes at least sense that someone will read this file
87 # before running bogofilter after upgrade and corrupt his db as
88 # it happened before. Bogofilter is not service/daemon by default
89 # so its not run automaticaly after upgrade. One can still backup
90 # his db.
91 %pre
92 %banner %{name} -e <<'EOF'
93
94 WARNING WARNING WARNING WARNING WARNING WARNING WARNING WARNING WARNING
95 ------------------------------------------------------------------------
96 POTENTIAL FOR DATA CORRUPTION DURING UPDATES
97
98 If you plan to upgrade your database library, if only as a side effect
99 of an operating system upgrade, DO HEED the relevant documentation, for
100 instance, the %{_docdir}/%{name}-%{version}/README.db file.
101 You may need to prepare the upgrade with the old version of the software.
102
103 Otherwise, you may cause irrecoverable damage to your databases.
104
105 DO backup your databases before making the upgrade.
106 ------------------------------------------------------------------------
107 WARNING WARNING WARNING WARNING WARNING WARNING WARNING WARNING WARNING
108
109 EOF
110
111 %files
112 %defattr(644,root,root,755)
113 %doc AUTHORS GETTING.STARTED NEWS* README RELEASE.NOTES TODO doc/{README.*,bogofilter-SA*,bogofilter-faq.html,bogofilter-tuning.HOWTO.html,bogotune-faq.html,integrating*}
114 %lang(bg) %doc doc/bogofilter-faq-bg.xhtml
115 %lang(fr) %doc doc/bogofilter-faq-fr.html
116 %lang(it) %doc doc/bogofilter-faq-it.html
117 %doc contrib/{README.*,bogo.R,bogofilter-qfe.sh,bogofilter-milter.pl,dot-qmail-bogofilter-default,*.example,parmtest.sh,procmailrc.example,randomtrain.sh,scramble.sh,vm-bogofilter.el}
118 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/bogofilter.cf
119 %attr(755,root,root) %{_bindir}/bf_compact
120 %attr(755,root,root) %{_bindir}/bf_copy
121 %attr(755,root,root) %{_bindir}/bf_tar
122 %attr(755,root,root) %{_bindir}/bfproxy.pl
123 %attr(755,root,root) %{_bindir}/bogofilter
124 %attr(755,root,root) %{_bindir}/bogogrep
125 %attr(755,root,root) %{_bindir}/bogolexer
126 %attr(755,root,root) %{_bindir}/bogominitrain.pl
127 %attr(755,root,root) %{_bindir}/bogotune
128 %attr(755,root,root) %{_bindir}/bogoupgrade
129 %attr(755,root,root) %{_bindir}/bogoutil
130 %attr(755,root,root) %{_bindir}/mime.get.rfc822.pl
131 %attr(755,root,root) %{_bindir}/printmaildir.pl
132 %attr(755,root,root) %{_bindir}/spamitarium.pl
133 %attr(755,root,root) %{_bindir}/stripsearch.pl
134 %attr(755,root,root) %{_bindir}/trainbogo.sh
135 %{_mandir}/man1/bf_compact.1*
136 %{_mandir}/man1/bf_copy.1*
137 %{_mandir}/man1/bf_tar.1*
138 %{_mandir}/man1/bogofilter.1*
139 %{_mandir}/man1/bogolexer.1*
140 %{_mandir}/man1/bogotune.1*
141 %{_mandir}/man1/bogoupgrade.1*
142 %{_mandir}/man1/bogoutil.1*
This page took 0.062015 seconds and 4 git commands to generate.