]> git.pld-linux.org Git - packages/bogl.git/blob - bogl.spec
- release 11 (by relup.sh)
[packages/bogl.git] / bogl.spec
1 # TODO
2 # - optflags
3 Summary:        A terminal program for displaying Unicode on the console
4 Summary(pl.UTF-8):      Program terminalowy do wyświetlania Unikodu na konsoli
5 Name:           bogl
6 Version:        0.1.18
7 Release:        11
8 Epoch:          0
9 License:        GPL
10 Group:          Libraries
11 Source0:        %{name}_%{version}-1.tar.gz
12 # Source0-md5:  9658700ed196eb1789c12aca0a095cb5
13 Source1:        wlite-0.8.1.tar.gz
14 # Source1-md5:  03a2faa33978e88ea2b9ff4679b8f2df
15 Source2:        http://www.cl.cam.ac.uk/~mgk25/download/ucs-fonts.tar.gz
16 # Source2-md5:  cca6a3cb6cfbde5f3ebb24278a9022a4
17 Source3:        http://www.cl.cam.ac.uk/~mgk25/download/ucs-fonts-asian.tar.gz
18 # Source3-md5:  d3184f182c6eebfcf156d08a65696496
19 Source4:        14x14cjk.bdf.gz
20 # Source4-md5:  c08ab351a43a91632127f509aadc6797
21 Patch0:         %{name}-0.1.18-rh.patch
22 Patch1:         %{name}-0.1.9-fpic.patch
23 Patch3:         %{name}-0.1.9-2.6fbdev.patch
24 Patch4:         %{name}-0.1.18-gcc.patch
25 Patch5:         %{name}-0.1.18-noexecstack.patch
26 Patch6:         %{name}-page_mask.patch
27 Patch7:         %{name}-shared.patch
28 Patch8:         format-security.patch
29 URL:            http://www.stanford.edu/~blp/projects.html
30 BuildRequires:  gd-devel
31 BuildRequires:  libpng-devel
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 BOGL stands for Ben's Own Graphics Library. It is a small graphics
36 library for Linux kernel framebuffers. It supports only very simple
37 graphics.
38
39 %description -l pl.UTF-8
40 BOGL oznacza Ben's Own Graphics Library (bibliotekę graficzną Bena).
41 Jest to mała biblioteka dla framebufferów jądra Linuksa. Obsługuje
42 tylko bardzo prostą grafikę.
43
44 %package devel
45 Summary:        Development files required to build BOGL applications
46 Summary(pl.UTF-8):      Pliki programistyczne potrzebne do budowania aplikacji BOGL
47 Group:          Development/Libraries
48 Requires:       %{name} = %{epoch}:%{version}-%{release}
49
50 %description devel
51 The bogl-devel package contains the header files for writing BOGL
52 applications.
53
54 %description devel -l pl.UTF-8
55 Ten pakiet zawiera pliki nagłówkowe do pisania aplikacji BOGL.
56
57 %package static
58 Summary:        Static BOGL libraries
59 Summary(pl.UTF-8):      Statyczne biblioteki BOGL
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
62
63 %description static
64 Static BOGL libraries.
65
66 %description static -l pl.UTF-8
67 Statyczne biblioteki BOGL.
68
69 %package bterm
70 Summary:        A Unicode capable terminal program for the Linux framebuffer
71 Summary(pl.UTF-8):      Obsługujący Unikod program terminalowy dla linuksowego framebuffera
72 Group:          Applications/System
73 Requires:       %{name} = %{epoch}:%{version}-%{release}
74
75 %description bterm
76 The bterm application is a terminal emulator that displays to a Linux
77 framebuffer. It is able to display Unicode text on the console.
78
79 %description bterm -l pl.UTF-8
80 Aplikacja bterm to emulator terminala wyświetlający obraz na
81 linuksowym framebufferze. Potrafi wyświetlać tekst unikodowy na
82 konsoli.
83
84 %prep
85 %setup -q -n %{name} -a 1
86 %patch0 -p1
87 %patch1 -p1
88 %patch3 -p1
89 %patch4 -p1
90 %patch5 -p1
91 %patch6 -p1
92 %patch7 -p1
93 %patch8 -p1
94
95 mkdir -p fonts
96 cd fonts
97 tar zxf %{SOURCE2}
98 tar zxf %{SOURCE3}
99
100 %build
101 %{__make} -j1 \
102         CFLAGS="%{rpmcflags} -fPIC"
103 #./mergebdf fonts/9x18.bdf fonts/18x18ja.bdf > font.bdf
104 gunzip -c %{SOURCE4} > font.bdf
105 ./bdftobogl -b font.bdf > font.bgf
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT \
112         libdir=%{_libdir}
113
114 %{__make} -C wlite install \
115         prefix=$RPM_BUILD_ROOT%{_prefix} \
116         libdir=$RPM_BUILD_ROOT%{_libdir}
117
118 if [ -f wlite/libwlitediet.a ]; then
119         install -m 644 wlite/libwlitediet.a $RPM_BUILD_ROOT%{_libdir}
120 fi
121 install -d $RPM_BUILD_ROOT%{_libdir}/bogl
122 install font.bgf $RPM_BUILD_ROOT%{_libdir}/bogl
123 install font.bdf $RPM_BUILD_ROOT%{_libdir}/bogl
124 gzip -9n $RPM_BUILD_ROOT%{_libdir}/bogl/font.bdf
125 gzip -9n $RPM_BUILD_ROOT%{_libdir}/bogl/font.bgf
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %files
134 %defattr(644,root,root,755)
135 %doc README
136 %attr(755,root,root) %{_libdir}/libbogl.so.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libbogl.so.0
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_bindir}/bdftobogl
142 %attr(755,root,root) %{_bindir}/mergebdf
143 %attr(755,root,root) %{_bindir}/pngtobogl
144 %attr(755,root,root) %{_bindir}/reduce-font
145 %attr(755,root,root) %{_libdir}/libbogl.so
146 %{_libdir}/libbterm.a
147 %{_libdir}/libwlite.a
148 %{_includedir}/bogl
149 %{_includedir}/wlite*.h
150
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/libbogl.a
154
155 %files bterm
156 %defattr(644,root,root,755)
157 %doc README.BOGL-bterm
158 %attr(755,root,root) %{_bindir}/bterm
159 %{_datadir}/terminfo/b/bterm
160 %{_libdir}/bogl
This page took 0.078107 seconds and 3 git commands to generate.