]> git.pld-linux.org Git - packages/binutils.git/blob - binutils.spec
up to 2.42
[packages/binutils.git] / binutils.spec
1 # TODO: PR/26302 <https://sourceware.org/bugzilla/show_bug.cgi?id=26302> (breaks kernel-tools build)
2 #
3 # Conditional build:
4 %bcond_with     allarchs        # enable all targets
5 # define addtargets x,y,z       # build with additional targets x,y,z (e.g. x86_64-linux)
6                                 # http://sourceware.org/ml/binutils/2008-03/msg00162.html
7 %bcond_with     pax             # without PaX flags (for upstream bugreports)
8 %bcond_without  gold            # don't build gold (no C++ dependencies)
9 %bcond_without  default_bfd     # default ld.bfd instead of gold
10 %bcond_without  debuginfod      # debuginfo lokups with debuginfod
11 %bcond_without  gprofng         # gprofng
12 %bcond_without  jansson         # Package Metadata embedding support
13 %bcond_without  msgpack         # msgpack support
14 %bcond_with     tests           # check target
15
16 %ifnarch %{ix86} %{x8664} x32 aarch64 %{arm}
17 %undefine       with_gold
18 %endif
19 %ifnarch %{ix86} %{x8664} aarch64
20 %undefine       with_gprofng    1
21 %endif
22
23 Summary:        GNU Binary Utility Development Utilities
24 Summary(de.UTF-8):      GNU Binary Utility Development Utilities
25 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU
26 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU
27 Summary(pl.UTF-8):      Narzędzia GNU dla programistów
28 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU
29 Summary(ru.UTF-8):      Набор инструментов GNU для построения исполняемых программ
30 Summary(tr.UTF-8):      GNU geliştirme araçları
31 Summary(uk.UTF-8):      Набір інструментів GNU для побудови виконуваних програм
32 Name:           binutils
33 Version:        2.42
34 Release:        1
35 Epoch:          4
36 License:        GPL v3+
37 Group:          Development/Tools
38 Source0:        https://ftp.gnu.org/gnu/binutils/%{name}-%{version}.tar.lz
39 # Source0-md5:  c1526faed7197b4e79dfe04eded7fc11
40 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
41 # Source1-md5:  a717d9707ec77d82acb6ec9078c472d6
42 Patch1:         %{name}-info.patch
43 Patch2:         %{name}-libtool-relink.patch
44 Patch3:         %{name}-pt_pax_flags.patch
45
46 Patch6:         %{name}-absolute-gnu_debuglink-path.patch
47 Patch7:         %{name}-libtool-m.patch
48 Patch9:         %{name}-tooldir.patch
49 Patch10:        %{name}-sanity-check.patch
50 URL:            http://www.sourceware.org/binutils/
51 BuildRequires:  autoconf >= 2.69
52 BuildRequires:  automake >= 1:1.11
53 BuildRequires:  bison
54 %{?with_debuginfod:BuildRequires:       elfutils-debuginfod-devel >= 0.179}
55 BuildRequires:  flex
56 BuildRequires:  gettext-tools
57 %{?with_jansson:BuildRequires:  jansson-devel}
58 %{?with_gold:BuildRequires:     libstdc++-devel >= 6:4.8.1}
59 %{?with_tests:BuildRequires:    libstdc++-static >= 6:4.8.1}
60 BuildRequires:  lzip
61 %{?with_msgpack:BuildRequires:  msgpack-devel}
62 BuildRequires:  perl-tools-pod
63 BuildRequires:  pkgconfig
64 BuildRequires:  rpmbuild(macros) >= 1.527
65 %ifarch sparc sparc32
66 BuildRequires:  sparc32
67 %endif
68 BuildRequires:  tar >= 1:1.22
69 BuildRequires:  texinfo >= 6.3
70 BuildRequires:  zlib-devel
71 %{?with_tests:BuildRequires:    zlib-static}
72 BuildRequires:  zstd-devel
73 %{?with_debuginfod:Requires:    elfutils-debuginfod-libs >= 0.179}
74 Conflicts:      gcc-c++ < 5:3.3
75 Conflicts:      modutils < 2.4.17
76 Conflicts:      rpmbuild(macros) < 1.660
77 Obsoletes:      binutils-gold < 3:2.21.51.0.7-2
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %description
81 Binutils is a collection of binary utilities, including:
82 - ar - create, modify and extract from archives,
83 - nm - lists symbols from object files,
84 - objcopy - copy and translate object files,
85 - objdump - display information from object files,
86 - ranlib - generate an index for the contents of an archive,
87 - size - list the section sizes of an object or archive file,
88 - strings - list printable strings from files,
89 - strip - discard symbols,
90 - addr2line - convert addresses to file and line.
91
92 %description -l es.UTF-8
93 Binutils es una colección de utilitarios necesarios para compilar
94 programas. Incluye assembler y linker, así como varios otros programas
95 para trabajar con formatos que se puedan ejecutar.
96
97 %description -l pl.UTF-8
98 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
99 programów. Znajdują się tutaj między innymi assembler, konsolidator
100 (linker), a także inne narzędzia do manipulowania binarnymi plikami
101 programów i bibliotek.
102
103 %description -l pt_BR.UTF-8
104 binutils é uma coletânea de utilitários necessários para compilar
105 programas. Inclui assembler e linker, assim como vários outros
106 programas para trabalhar com formatos executáveis.
107
108 %description -l ru.UTF-8
109 binutils - это набор инструментов, необходимых для компилляции
110 программ. Включает ассемблер, компоновщик и набор других программ для
111 работы с исполняемыми файлами разнообразных форматов.
112
113 %description -l uk.UTF-8
114 binutils - це набір інструментів, необхідних для компіляції програм.
115 Містить асемблер, компоновщик та інші програми, необхідні для роботи з
116 виконуваними файлами різних форматів.
117
118 %package libs
119 Summary:        GNU binutils shared libraries
120 Summary(pl.UTF-8):      Biblioteki współdzielone GNU binutils
121 Group:          Libraries
122 Conflicts:      binutils < 3:2.17.50.0.8-3
123
124 %description libs
125 GNU binutils shared libraries (libbfd, libopcodes).
126
127 %description libs -l pl.UTF-8
128 Biblioteki współdzielone GNU binutils (libbfd, libopcodes).
129
130 %package devel
131 Summary:        Development files for GNU binutils libraries
132 Summary(pl.UTF-8):      Pliki programistyczne bibliotek GNU binutils
133 Group:          Development/Libraries
134 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
135
136 %description devel
137 Development files for GNU binutils libraries (libbfd, libopcodes) and
138 static libiberty library.
139
140 %description devel -l pl.UTF-8
141 Pliki programistyczne bibliotek GNU binutils (libbfd, libopcodes) oraz
142 statyczna biblioteka libiberty.
143
144 %package static
145 Summary:        GNU binutils static libraries
146 Summary(pl.UTF-8):      Biblioteki statyczne do GNU binutils
147 Group:          Development/Libraries
148 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
149 #Requires:      zlib-static
150
151 %description static
152 Static GNU binutils libraries (libbfd, libopcodes).
153
154 %description static -l pl.UTF-8
155 Biblioteki statyczne GNU binutils (libbfd, libopcodes).
156
157 %package gprofng
158 Summary:        GNU Next Generation profiler
159 Summary(pl.UTF-8):      Narzędzie profilujące GNU Next Generation
160 Group:          Development/Tools
161 Requires:       %{name} = %{epoch}:%{version}-%{release}
162 Requires:       %{name}-gprofng-libs = %{epoch}:%{version}-%{release}
163 Requires:       coreutils
164 Requires:       hostname
165 Requires:       perl-base >= 1:5.10.0
166 Requires:       which
167
168 %description gprofng
169 Gprofng is the GNU Next Generation profiler for analyzing the
170 performance of Linux applications. Gprofng allows you to:
171 - Profile C / C++ / Java / Scala applications without needing to
172   recompile
173 - Profile multi-threaded applications
174 - Analyze and compare multiple experiments
175 - Use time-based sampling and / or hardware event counters
176
177 %description gprofng -l pl.UTF-8
178 Gprofng jest narzędziem profilującym GNU Next Generation do analizy
179 wydajności aplikacji w systemie Linux. Gprofng pozwala na:
180 - Profilowanie aplikacji C / C++ / Java / Scala bez potrzeby ponownej
181   kompilacji
182 - Profilowanie aplikacji wielowątkowych
183 - Analizę i porównanie wielu eksperymentów
184 - Użycie próbkowania w dziedzinie czasu i/lub sprzętowych liczników
185   zdarzeń
186
187 %package gprofng-libs
188 Summary:        GNU Next Generation profiler shared libraries
189 Summary(pl.UTF-8):      Biblioteki narzędzia profilującego GNU Next Generation
190 Group:          Libraries
191
192 %description gprofng-libs
193 GNU Next Generation profiler shared libraries.
194
195 %description gprofng-libs -l pl.UTF-8
196 Biblioteki narzędzia profilującego GNU Next Generation.
197
198 %package gprofng-devel
199 Summary:        Development files for GNU Next Generation profiler
200 Summary(pl.UTF-8):      Pliki programistyczne bibliotek narzędzia profilującego GNU Next Generation
201 Group:          Development/Libraries
202 Requires:       %{name}-gprofng-libs = %{epoch}:%{version}-%{release}
203
204 %description gprofng-devel
205 Development files for GNU Next Generation profiler.
206
207 %description gprofng-devel -l pl.UTF-8
208 Pliki programistyczne bibliotek narzędzia profilującego GNU Next Generation.
209
210 %package gprofng-static
211 Summary:        GNU Next Generation profiler static libraries
212 Summary(pl.UTF-8):      Biblioteki statyczne narzędzia profilującego GNU Next Generation
213 Group:          Development/Libraries
214 Requires:       %{name}-gprofng-devel = %{epoch}:%{version}-%{release}
215
216 %description gprofng-static
217 GNU Next Generation profiler static libraries.
218
219 %description gprofng-static -l pl.UTF-8
220 Biblioteki statyczne narzędzia profilującego GNU Next Generation.
221
222 %prep
223 %setup -q
224 %patch1 -p1
225 %patch2 -p1
226 %{?with_pax:%patch3 -p1}
227
228 %patch6 -p1
229 %patch7 -p1
230 %patch9 -p1
231 %patch10 -p1
232
233 %{__sed} -i -e '1s,.*env perl,#!%{__perl},' gprofng/gp-display-html/gp-display-html.in
234
235 # file contains hacks for ac 2.69 only
236 %{__rm} config/override.m4
237
238 %build
239 %{__aclocal}
240 %{__autoconf}
241
242 # non-standard regeneration
243 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
244 for dir in gas bfd; do
245         cd $dir || exit 1
246         %{__aclocal} -I .. -I ../config -I ../bfd
247         %{__automake} Makefile
248         test -f doc/Makefile.am && %{__automake} doc/Makefile
249         %{__autoconf}
250         cd ..
251 done
252 cd libctf
253 %{__aclocal} -I.. -I../config -I../bfd
254 %{__autoconf}
255 %{__autoheader}
256 %{__automake}
257 cd ..
258
259 # More targets
260 TARGETS=
261 %ifarch ia64
262 TARGETS=i686-linux
263 %endif
264 # uhm?
265 %ifarch %{ix86}
266 TARGETS=x86_64-linux
267 %endif
268 %ifarch sparc
269 TARGETS=sparc64-linux
270 %endif
271 %ifarch %{x8664}
272 TARGETS="x86_64-pep"
273 %endif
274 %ifarch x32
275 TARGETS="x86_64-linux,x86_64-pep"
276 %endif
277 %{?addtargets:TARGETS="%{addtargets}"}
278
279 cp -f /usr/share/automake/config.* .
280 CFLAGS="%{rpmcflags}"; export CFLAGS
281 CXXFLAGS="%{rpmcxxflags}"; export CXXFLAGS
282 CC="%{__cc}"; export CC
283 CXX="%{__cxx}"; export CXX
284 %ifarch sparc
285 sparc32 \
286 %endif
287 ./configure %{_target_platform} \
288         --prefix=%{_prefix} \
289         --libdir=%{_libdir} \
290         --infodir=%{_infodir} \
291         --mandir=%{_mandir} \
292         --sysconfdir=%{_sysconfdir} \
293         --disable-debug \
294         --disable-silent-rules \
295         --disable-werror \
296 %ifarch sparc
297         --enable-64-bit-bfd \
298 %else
299         %{?with_allarchs:--enable-64-bit-bfd} \
300 %endif
301         --enable-build-warnings=,-Wno-missing-prototypes \
302         --enable-install-libiberty \
303         --enable-lto \
304         --enable-plugins \
305         --enable-shared \
306         %{?with_allarchs:--enable-targets=alpha-linux,arm-linux,cris-linux,hppa-linux,i386-linux,ia64-linux,x86_64-linux,x86_64-linux-gnux32,m68k-linux,mips-linux,mips64-linux,mips64el-linux,mipsel-linux,ppc-linux,s390-linux,s390x-linux,sh-linux,sparc-linux,sparc64-linux,i386-linuxaout,x86_64-pep} \
307         %{!?with_allarchs:`[ -n "${TARGETS}" ] && echo "--enable-targets=${TARGETS}"`} \
308         --with-tooldir=%{_prefix} \
309         --with-system-zlib \
310 %if %{with gold}
311         --enable-gold%{!?with_default_bfd:=default} --enable-ld%{?with_default_bfd:=default} \
312 %endif
313         %{__with_without msgpack} \
314         %{__enable_disable jansson} \
315         %{__with_without debuginfod}
316
317 %{__make}
318
319 %{?with_tests:%{__make} -j1 check}
320
321 %install
322 rm -rf $RPM_BUILD_ROOT
323 install -d $RPM_BUILD_ROOT%{_libdir}/bfd-plugins
324
325 %{__make} -j1 install \
326         DESTDIR=$RPM_BUILD_ROOT
327
328 # remove these man pages unless we cross-build for win*/netware platforms.
329 # however, this should be done in Makefiles.
330 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dlltool,windmc,windres}.1
331
332 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
333
334 # overwrite libiberty.a with PIC version
335 cp -pf libiberty/pic/libiberty.a $RPM_BUILD_ROOT%{_libdir}
336
337 # remove evil -L pointing inside builder's home
338 perl -pi -e 's@-L[^ ]*/pic @@g' $RPM_BUILD_ROOT%{_libdir}/libbfd.la
339
340 [ -x $RPM_BUILD_ROOT%{_bindir}/ld.bfd ] || ln $RPM_BUILD_ROOT%{_bindir}/ld{,.bfd}
341
342 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
343
344 %if %{with gprofng}
345 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gprofng/libgp-collectorAPI.{a,la}
346 %endif
347
348 %if %{with gold}
349 install -d gold-doc
350 cp -p gold/{README,ChangeLog,TODO} gold-doc
351 %endif
352
353 %find_lang bfd
354 %find_lang binutils
355 %find_lang gas
356 %find_lang gprof
357 touch ld.lang gold.lang
358 %find_lang ld
359 %if %{with gold}
360 %find_lang gold
361 %endif
362 %find_lang opcodes
363 cat bfd.lang opcodes.lang > %{name}-libs.lang
364 cat gas.lang gprof.lang ld.lang gold.lang >> %{name}.lang
365
366 %clean
367 rm -rf $RPM_BUILD_ROOT
368
369 %post   -p /sbin/postshell
370 -/usr/sbin/fix-info-dir -c %{_infodir}
371
372 %postun -p /sbin/postshell
373 -/usr/sbin/fix-info-dir -c %{_infodir}
374
375 %post   libs -p /sbin/ldconfig
376 %postun libs -p /sbin/ldconfig
377
378 %post   devel -p /sbin/postshell
379 -/usr/sbin/fix-info-dir -c %{_infodir}
380
381 %postun devel -p /sbin/postshell
382 -/usr/sbin/fix-info-dir -c %{_infodir}
383
384 %post   gprofng -p /sbin/postshell
385 -/usr/sbin/fix-info-dir -c %{_infodir}
386
387 %postun gprofng -p /sbin/postshell
388 -/usr/sbin/fix-info-dir -c %{_infodir}
389
390 %post   gprofng-libs -p /sbin/ldconfig
391 %postun gprofng-libs -p /sbin/ldconfig
392
393 %files -f %{name}.lang
394 %defattr(644,root,root,755)
395 %doc README
396 %{?with_gold:%doc gold-doc}
397 %attr(755,root,root) %{_bindir}/addr2line
398 %attr(755,root,root) %{_bindir}/ar
399 %attr(755,root,root) %{_bindir}/as
400 %attr(755,root,root) %{_bindir}/c++filt
401 %attr(755,root,root) %{_bindir}/elfedit
402 %attr(755,root,root) %{_bindir}/gprof
403 %attr(755,root,root) %{_bindir}/ld
404 %attr(755,root,root) %{_bindir}/ld.bfd
405 %if %{with gold}
406 %attr(755,root,root) %{_bindir}/ld.gold
407 %attr(755,root,root) %{_bindir}/dwp
408 %endif
409 %attr(755,root,root) %{_bindir}/nm
410 %attr(755,root,root) %{_bindir}/objcopy
411 %attr(755,root,root) %{_bindir}/objdump
412 %attr(755,root,root) %{_bindir}/ranlib
413 %attr(755,root,root) %{_bindir}/readelf
414 %attr(755,root,root) %{_bindir}/size
415 %attr(755,root,root) %{_bindir}/strings
416 %attr(755,root,root) %{_bindir}/strip
417 %{_prefix}/lib/ldscripts
418 %{_infodir}/as.info*
419 %{_infodir}/binutils.info*
420 %{_infodir}/ctf-spec.info*
421 %{_infodir}/gprof.info*
422 %{_infodir}/ld.info*
423 %{_infodir}/ldint.info*
424 %{_infodir}/sframe-spec.info*
425 %{_mandir}/man1/addr2line.1*
426 %{_mandir}/man1/ar.1*
427 %{_mandir}/man1/as.1*
428 %{_mandir}/man1/c++filt.1*
429 %{_mandir}/man1/elfedit.1*
430 %{_mandir}/man1/gprof.1*
431 %{_mandir}/man1/ld.1*
432 %{_mandir}/man1/nm.1*
433 %{_mandir}/man1/objcopy.1*
434 %{_mandir}/man1/objdump.1*
435 %{_mandir}/man1/ranlib.1*
436 %{_mandir}/man1/readelf.1*
437 %{_mandir}/man1/size.1*
438 %{_mandir}/man1/strings.1*
439 %{_mandir}/man1/strip.1*
440 %lang(cs) %{_mandir}/cs/man1/*
441 %lang(de) %{_mandir}/de/man1/*
442 %lang(es) %{_mandir}/es/man1/*
443 %lang(fi) %{_mandir}/fi/man1/*
444 %lang(fr) %{_mandir}/fr/man1/*
445 %lang(hu) %{_mandir}/hu/man1/*
446 %lang(ja) %{_mandir}/ja/man1/*
447 %lang(pl) %{_mandir}/pl/man1/*
448
449 %files libs -f %{name}-libs.lang
450 %defattr(644,root,root,755)
451 %attr(755,root,root) %{_libdir}/libbfd-%{version}.so
452 %attr(755,root,root) %{_libdir}/libctf.so.*.*
453 %attr(755,root,root) %ghost %{_libdir}/libctf.so.0
454 %attr(755,root,root) %{_libdir}/libctf-nobfd.so.*.*
455 %attr(755,root,root) %ghost %{_libdir}/libctf-nobfd.so.0
456 %attr(755,root,root) %{_libdir}/libopcodes-%{version}.so
457 %attr(755,root,root) %{_libdir}/libsframe.so.*.*
458 %attr(755,root,root) %ghost %{_libdir}/libsframe.so.1
459 %dir %{_libdir}/bfd-plugins
460 %attr(755,root,root) %{_libdir}/bfd-plugins/libdep.so
461
462 %files devel
463 %defattr(644,root,root,755)
464 %attr(755,root,root) %{_libdir}/libbfd.so
465 %attr(755,root,root) %{_libdir}/libctf.so
466 %attr(755,root,root) %{_libdir}/libctf-nobfd.so
467 %attr(755,root,root) %{_libdir}/libopcodes.so
468 %attr(755,root,root) %{_libdir}/libsframe.so
469 %{_libdir}/libbfd.la
470 %{_libdir}/libctf.la
471 %{_libdir}/libctf-nobfd.la
472 %{_libdir}/libopcodes.la
473 %{_libdir}/libiberty.a
474 %{_libdir}/libsframe.la
475 %{_includedir}/ansidecl.h
476 %{_includedir}/bfd.h
477 %{_includedir}/bfdlink.h
478 %{_includedir}/ctf-api.h
479 %{_includedir}/ctf.h
480 %{_includedir}/diagnostics.h
481 %{_includedir}/dis-asm.h
482 %{_includedir}/plugin-api.h
483 %{_includedir}/sframe-api.h
484 %{_includedir}/sframe.h
485 %{_includedir}/symcat.h
486 %{_includedir}/libiberty
487 %{_infodir}/bfd.info*
488
489 %files static
490 %defattr(644,root,root,755)
491 %{_libdir}/libbfd.a
492 %{_libdir}/libctf.a
493 %{_libdir}/libctf-nobfd.a
494 %{_libdir}/libopcodes.a
495 %{_libdir}/libsframe.a
496
497 %if %{with gprofng}
498 %files gprofng
499 %defattr(644,root,root,755)
500 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gprofng.rc
501 %attr(755,root,root) %{_bindir}/gp-archive
502 %attr(755,root,root) %{_bindir}/gp-collect-app
503 %attr(755,root,root) %{_bindir}/gp-display-html
504 %attr(755,root,root) %{_bindir}/gp-display-src
505 %attr(755,root,root) %{_bindir}/gp-display-text
506 %attr(755,root,root) %{_bindir}/gprofng
507 %{_infodir}/gprofng.info*
508 %{_mandir}/man1/gp-archive.*
509 %{_mandir}/man1/gp-collect-app.*
510 %{_mandir}/man1/gp-display-html.*
511 %{_mandir}/man1/gp-display-src.*
512 %{_mandir}/man1/gp-display-text.*
513 %{_mandir}/man1/gprofng.1*
514
515 %files gprofng-libs
516 %defattr(644,root,root,755)
517 %attr(755,root,root) %{_libdir}/libgprofng.so.*.*.*
518 %attr(755,root,root) %ghost %{_libdir}/libgprofng.so.0
519 %dir %{_libdir}/gprofng
520 %attr(755,root,root) %{_libdir}/gprofng/libgp-collector.so
521 %attr(755,root,root) %{_libdir}/gprofng/libgp-collectorAPI.so
522 %attr(755,root,root) %{_libdir}/gprofng/libgp-heap.so
523 %attr(755,root,root) %{_libdir}/gprofng/libgp-iotrace.so
524 %attr(755,root,root) %{_libdir}/gprofng/libgp-sync.so
525
526 %files gprofng-devel
527 %defattr(644,root,root,755)
528 %attr(755,root,root) %{_libdir}/libgprofng.so
529 %{_libdir}/libgprofng.la
530 %{_includedir}/collectorAPI.h
531 %{_includedir}/libcollector.h
532 %{_includedir}/libfcollector.h
533
534 %files gprofng-static
535 %defattr(644,root,root,755)
536 %attr(755,root,root) %{_libdir}/libgprofng.a
537 %endif
This page took 0.112601 seconds and 4 git commands to generate.