]> git.pld-linux.org Git - packages/beignet.git/blob - beignet.spec
- added dirty llvm11-support patch, now at least builds with llvm 11
[packages/beignet.git] / beignet.spec
1 Summary:        Open source implementation of the OpenCL specification for Intel GPUs
2 Summary(pl.UTF-8):      Mająca otwarte źródła implementacja specyfikacji OpenCL dla GPU formy Intel
3 Name:           beignet
4 Version:        1.3.2
5 Release:        0.1
6 License:        LGPL v2+
7 Group:          Libraries
8 #Source0Download: https://www.freedesktop.org/wiki/Software/Beignet/NEWS/
9 Source0:        https://01.org/sites/default/files/beignet-%{version}-source.tar.gz
10 # Source0-md5:  a577ab18d67a891c8767b8ea62253543
11 Patch0:         cflags.patch
12 Patch1:         static_llvm.patch
13 Patch2:         %{name}-llvm11-support.patch
14 # Debian patches
15 Patch10:        %{name}-reduce-notfound-output.patch
16 Patch11:        %{name}-update-docs.patch
17 Patch12:        %{name}-docs-broken-links.patch
18 Patch13:        %{name}-cl_accelerator_intel.patch
19 Patch14:        %{name}-grammar.patch
20 Patch15:        %{name}-clearer-type-errors.patch
21 Patch16:        %{name}-debian-885423.patch
22 Patch17:        %{name}-disable-wayland-warning.patch
23 Patch18:        %{name}-eventchain-memory-leak.patch
24 Patch19:        %{name}-llvm6-support.patch
25 Patch20:        %{name}-llvm7-support.patch
26 Patch21:        %{name}-accept-old-create-queue.patch
27 Patch22:        %{name}-reduce-notfound-output2.patch
28 Patch23:        %{name}-coffeelake.patch
29 Patch24:        %{name}-in-order-queue.patch
30 Patch25:        %{name}-accept-ignore--g.patch
31 Patch26:        %{name}-llvm8-support.patch
32 Patch27:        %{name}-llvm9-support.patch
33 Patch28:        %{name}-cometlake.patch
34 # modified
35 Patch29:        %{name}-llvm10-support.patch
36 URL:            https://www.freedesktop.org/wiki/Software/Beignet/
37 BuildRequires:  EGL-devel
38 BuildRequires:  Mesa-libgbm-devel
39 BuildRequires:  OpenGL-devel
40 BuildRequires:  clang-devel >= 3.9
41 BuildRequires:  cmake >= 2.6.0
42 BuildRequires:  libdrm-devel >= 2.4.66
43 BuildRequires:  libedit-devel
44 BuildRequires:  libstdc++-devel
45 BuildRequires:  llvm >= 3.9
46 BuildRequires:  llvm-devel >= 3.9
47 BuildRequires:  ncurses-devel
48 BuildRequires:  ocl-icd-devel
49 BuildRequires:  pkgconfig
50 BuildRequires:  pkgconfig(egl) >= 13.0.0
51 BuildRequires:  pkgconfig(gl) >= 13.0.0
52 BuildRequires:  python
53 BuildRequires:  sed >= 4.0
54 BuildRequires:  xorg-lib-libX11-devel
55 BuildRequires:  xorg-lib-libXext-devel
56 BuildRequires:  xorg-lib-libXfixes-devel
57 BuildRequires:  zlib-devel
58 Provides:       ocl-icd(beignet)
59 Provides:       ocl-icd-driver
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 Beignet is an open source implementation of the OpenCL specification -
64 a generic compute oriented API. This code base contains the code to
65 run OpenCL programs on Intel GPUs which basically defines and
66 implements the OpenCL host functions required to initialize the
67 device, create the command queues, the kernels and the programs and
68 run them on the GPU.
69
70 %description -l pl.UTF-8
71 Beignet to mająca otwarte źródła implementacja specyfikacji OpenCL -
72 ogólnego API przeznaczonego do obliczeń. Ten pakiet zawiera kod do
73 uruchamiania programów OpenCL na procesorach graficznych (GPU) firmy
74 Intel; kod ten zasadniczo definiuje i implementuje funkcje hosta
75 OpenCL wymagane do zainicjowania urządzenia, tworzenia kolejek
76 poleceń, jądra i programów oraz uruchamia je na GPU.
77
78 %prep
79 %setup -qn Beignet-%{version}-Source
80 %patch0 -p1
81 %patch1 -p1
82 %patch10 -p1
83 %patch11 -p1
84 %patch12 -p1
85 %patch13 -p1
86 %patch14 -p1
87 %patch15 -p1
88 %patch16 -p1
89 %patch17 -p1
90 %patch18 -p1
91 %patch19 -p1
92 %patch20 -p1
93 %patch21 -p1
94 %patch22 -p1
95 %patch23 -p1
96 %patch24 -p1
97 %patch25 -p1
98 %patch26 -p1
99 %patch27 -p1
100 %patch28 -p1
101 %patch29 -p1
102 %patch2 -p1
103
104 # don't lower default -std= on g++ 5+ (recent llvm requires C++14)
105 %if "%{_ver_ge '%{cxx_version}' '5.0'}" == "1"
106 %{__sed} -i -e 's/ -std=c++0x / /' CMakeLists.txt
107 %endif
108
109 %build
110 install -d build
111 cd build
112 %cmake \
113         -DLIB_INSTALL_DIR=%{_libdir} \
114         -DCMAKE_CXX_FLAGS_PLD="%{rpmcxxflags} -DNDEBUG -DGBE_DEBUG=0" \
115         -DCMAKE_C_FLAGS_PLD="%{rpmcxxflags} -DNDEBUG -DGBE_DEBUG=0" \
116         ../
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} -C build install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %files
131 %defattr(644,root,root,755)
132 %doc docs/*
133 %dir %{_libdir}/%{name}
134 %{_libdir}/%{name}/beignet.bc
135 %attr(755,root,root) %{_libdir}/%{name}/libcl.so
136 %attr(755,root,root) %{_libdir}/%{name}/libgbe.so
137 %attr(755,root,root) %{_libdir}/%{name}/libgbeinterp.so
138 %{_libdir}/%{name}/beignet.pch
139 %ifarch %{x8664}
140 %{_libdir}/%{name}/beignet_20.bc
141 %{_libdir}/%{name}/beignet_20.pch
142 %endif
143 %{_libdir}/%{name}/include
144 /etc/OpenCL/vendors/intel-beignet.icd
This page took 0.134176 seconds and 4 git commands to generate.