]> git.pld-linux.org Git - packages/banshee.git/blob - banshee.spec
- rel. 3
[packages/banshee.git] / banshee.spec
1 %include /usr/lib/rpm/macros.mono
2 #
3
4 Summary:        A Mono/GStreamer Based Music Player
5 Summary(pl.UTF-8):      Oparty na Mono/GStreamerze odtwarzacz muzyki
6 Name:           banshee
7 Version:        0.13.2
8 Release:        3
9 License:        GPL
10 Group:          Applications/Multimedia
11 Source0:        http://banshee-project.org/files/banshee/%{name}-%{version}.tar.gz
12 # Source0-md5:  e75b322963c7ec1a40f59421a30764ef
13 URL:            http://banshee-project.org/
14 BuildRequires:  GConf2-devel
15 BuildRequires:  autoconf >= 2.13
16 BuildRequires:  automake
17 BuildRequires:  dbus-devel >= 0.93
18 BuildRequires:  dbus-glib-devel >= 0.71
19 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
20 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10.0
21 BuildRequires:  dotnet-ipod-sharp >= 0.8.0
22 BuildRequires:  dotnet-libgphoto2-sharp-devel
23 BuildRequires:  dotnet-mono-zeroconf-devel
24 BuildRequires:  dotnet-njb-sharp
25 BuildRequires:  gnome-desktop-devel >= 2.16.0
26 BuildRequires:  gstreamer-GConf >= 0.10.3
27 BuildRequires:  gstreamer-cdparanoia
28 BuildRequires:  gstreamer-devel >= 0.10.3
29 BuildRequires:  gstreamer-gnomevfs
30 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.3
31 BuildRequires:  gtk+2-devel >= 2:2.10.3
32 BuildRequires:  hal-devel >= 0.5.2
33 BuildRequires:  intltool >= 0.35
34 BuildRequires:  libmusicbrainz-devel >= 2.1.1
35 BuildRequires:  libtool
36 BuildRequires:  mono-csharp >= 1.1.13
37 BuildRequires:  monodoc
38 BuildRequires:  nautilus-cd-burner-devel >= 2.16.0
39 BuildRequires:  pkgconfig
40 BuildRequires:  sqlite3-devel
41 Requires:       gstreamer-cdparanoia >= 0.10.3
42 Requires:       gstreamer-GConf >= 0.10.3
43 Requires:       gstreamer-gnomevfs >= 0.10.3
44 Obsoletes:      banshee-official-plugins <= 0.11.3
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Banshee is a brand spankin' new audio player based on the GStreamer
49 media library and is developed on the Open Source Mono .NET Platform,
50 written in C#.
51
52 %description -l pl.UTF-8
53 Banshee to nowy odtwarzacz dźwięku oparty na bibliotece odtwarzacza
54 multimediów GStreamer, rozwijany na platformie .NET Mono, napisany w
55 C#.
56
57 %prep
58 %setup -q
59
60 %build
61 %{__intltoolize}
62 %{__aclocal} -I build/m4/banshee -I build/m4/shamrock
63 %{__libtoolize}
64 %{__automake}
65 %{__autoconf}
66 %configure \
67         --disable-dev-tests \
68         --disable-helix \
69         --enable-ipod \
70         --enable-njb \
71         --disable-vlc \
72         --enable-gstreamer \
73         --enable-avahi \
74         --disable-schemas-install \
75         --disable-docs
76 %{__make}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT%{_libdir}/monodoc/sources
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 #mv $RPM_BUILD_ROOT%{_docdir}/%{name}/* $RPM_BUILD_ROOT%{_libdir}/monodoc/sources
86
87 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{la,a}
88
89 %find_lang %{name}
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post
95 %update_desktop_database_post
96 SCHEMAS="banshee-core.schemas banshee-interface.schemas banshee-plugin-audioscrobbler.schemas banshee-plugin-daap.schemas banshee-plugin-metadatasearcher.schemas banshee-plugin-minimode.schemas banshee-plugin-mmkeys.schemas banshee-plugin-notificationarea.schemas banshee-plugin-podcast.schemas banshee-plugin-radio.schemas banshee-plugin-recommendation.schemas"
97 for S in $SCHEMAS; do
98         %gconf_schema_install $S
99 done
100 %update_icon_cache hicolor
101
102 %preun
103 SCHEMAS="banshee-core.schemas banshee-interface.schemas banshee-plugin-audioscrobbler.schemas banshee-plugin-daap.schemas banshee-plugin-metadatasearcher.schemas banshee-plugin-minimode.schemas banshee-plugin-mmkeys.schemas banshee-plugin-notificationarea.schemas banshee-plugin-podcast.schemas banshee-plugin-radio.schemas banshee-plugin-recommendation.schemas"
104 for S in $SCHEMAS; do
105         %gconf_schema_uninstall $S
106 done
107
108 %postun
109 %update_desktop_database_postun
110 %update_icon_cache hicolor
111
112 %files -f %{name}.lang
113 %defattr(644,root,root,755)
114 %doc AUTHORS COPYING ChangeLog NEWS README
115 %{_sysconfdir}/gconf/schemas/*.schemas
116 %attr(755,root,root) %{_bindir}/banshee
117 %{_datadir}/banshee
118 %{_pkgconfigdir}/banshee.pc
119 %dir %{_libdir}/banshee
120 %{_libdir}/banshee/*.dll
121 %attr(755,root,root) %{_libdir}/banshee/*.so
122 %{_libdir}/banshee/*.exe
123 %{_libdir}/banshee/*.mdb
124 %{_libdir}/banshee/*.config
125 %{_libdir}/banshee/Banshee.Dap
126 %{_libdir}/banshee/Banshee.MediaEngine
127 %{_libdir}/banshee/Banshee.Plugins
128 #%{_libdir}/monodoc/sources/*
129 %{_desktopdir}/banshee.desktop
130 %{_iconsdir}/hicolor/*/*/*
131 %{_datadir}/dbus-1/services/org.gnome.Banshee.service
This page took 0.086258 seconds and 4 git commands to generate.