]> git.pld-linux.org Git - packages/banshee.git/blob - banshee.spec
- 1.6.0
[packages/banshee.git] / banshee.spec
1 #
2 %include /usr/lib/rpm/macros.mono
3 #
4 Summary:        A Mono/GStreamer Based Music Player
5 Summary(pl.UTF-8):      Oparty na Mono/GStreamerze odtwarzacz muzyki
6 Name:           banshee
7 Version:        1.6.0
8 Release:        1
9 License:        GPL
10 Group:          X11/Applications/Multimedia
11 Source0:        http://download.banshee-project.org/banshee/%{name}-1-%{version}.tar.bz2
12 # Source0-md5:  4ab6f48198627ed7a9a10b13c2656cd2
13 URL:            http://banshee-project.org/
14 BuildRequires:  GConf2-devel
15 BuildRequires:  autoconf >= 2.52
16 BuildRequires:  automake >= 1:1.9
17 BuildRequires:  brasero-devel >= 2.28.0
18 BuildRequires:  clutter-devel >= 1.0.1
19 BuildRequires:  dbus-devel >= 0.93
20 BuildRequires:  dbus-glib-devel >= 0.71
21 BuildRequires:  dotnet-gdata-sharp-devel
22 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
23 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.12.0
24 BuildRequires:  dotnet-ipod-sharp-devel >= 0.8.5
25 BuildRequires:  dotnet-libgphoto2-sharp-devel
26 BuildRequires:  dotnet-mono-zeroconf-devel >= 0.7.3
27 BuildRequires:  dotnet-ndesk-dbus-glib-sharp-devel >= 0.3
28 BuildRequires:  dotnet-njb-sharp
29 BuildRequires:  dotnet-notify-sharp-devel
30 BuildRequires:  dotnet-taglib-sharp-devel >= 2.0.3.7
31 BuildRequires:  dotnet-webkit-sharp-devel
32 BuildRequires:  gettext-devel
33 BuildRequires:  gnome-desktop-devel >= 2.16.0
34 BuildRequires:  gstreamer-GConf >= 0.10.3
35 BuildRequires:  gstreamer-cdparanoia
36 BuildRequires:  gstreamer-devel >= 0.10.12
37 BuildRequires:  gstreamer-gnomevfs
38 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.25.2
39 BuildRequires:  gtk+2-devel >= 2:2.10.3
40 BuildRequires:  hal-devel >= 0.5.2
41 BuildRequires:  intltool >= 0.35.0
42 BuildRequires:  libmtp-devel >= 0.2.0
43 BuildRequires:  libmusicbrainz-devel >= 2.1.1
44 BuildRequires:  libtool
45 BuildRequires:  mono-addins-devel >= 0.3.1-2
46 BuildRequires:  mono-csharp >= 2.4.3
47 BuildRequires:  monodoc
48 BuildRequires:  pkgconfig
49 BuildRequires:  sqlite3-devel >= 3.4.0
50 Requires:       dotnet-ipod-sharp >= 0.8.5
51 Requires:       gstreamer-GConf >= 0.10.3
52 Requires:       gstreamer-cdparanoia >= 0.10.3
53 Requires:       gstreamer-gnomevfs >= 0.10.3
54 Requires:       mono-addins >= 0.3.1-2
55 Obsoletes:      banshee-official-plugins <= 0.11.3
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 Banshee is a brand spankin' new audio player based on the GStreamer
60 media library and is developed on the Open Source Mono .NET Platform,
61 written in C#.
62
63 %description -l pl.UTF-8
64 Banshee to nowy odtwarzacz dźwięku oparty na bibliotece odtwarzacza
65 multimediów GStreamer, rozwijany na platformie .NET Mono, napisany w
66 C#.
67
68 %prep
69 %setup -q -n %{name}-1-%{version}
70
71 %build
72 %{__libtoolize}
73 %{__intltoolize}
74 %{__aclocal} -I build/m4/banshee -I build/m4/shave -I build/m4/shamrock
75 %{__automake}
76 %{__autoconf}
77
78 bash %configure \
79         --disable-boo \
80         --enable-ipod \
81         --disable-docs \
82         --with-vendor-build-id="%{distribution}"
83 %{__make} -j1 \
84         SHELL=/bin/bash
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT%{_libdir}/monodoc/sources
89
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 #mv $RPM_BUILD_ROOT%{_docdir}/%{name}/* $RPM_BUILD_ROOT%{_libdir}/monodoc/sources
94
95 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}-1/*.{la,a}
96 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}-1/Backends/*.{la,a}
97 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}-1/gstreamer-0.10/*.{la,a}
98
99 %find_lang %{name}-1
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post
105 %update_desktop_database_post
106 %update_icon_cache hicolor
107
108 %postun
109 %update_desktop_database_postun
110 %update_icon_cache hicolor
111
112 %files -f %{name}-1.lang
113 %defattr(644,root,root,755)
114 %doc AUTHORS COPYING ChangeLog NEWS README
115 %attr(755,root,root) %{_bindir}/banshee-1
116 %attr(755,root,root) %{_bindir}/muinshee
117 %{_datadir}/banshee-1
118 %{_pkgconfigdir}/banshee-1*.pc
119 %dir %{_libdir}/banshee-1
120 %{_libdir}/banshee-1/*.dll
121 %attr(755,root,root) %{_libdir}/banshee-1/*.so
122 %{_libdir}/banshee-1/*.exe
123 %{_libdir}/banshee-1/*.mdb
124 %{_libdir}/banshee-1/*.config
125 %dir %{_libdir}/banshee-1/Extensions
126 %{_libdir}/banshee-1/Extensions/*.dll
127 %{_libdir}/banshee-1/Extensions/*.mdb
128 %{_libdir}/banshee-1/Extensions/Banshee.NotificationArea.dll.config
129 %dir %{_libdir}/banshee-1/Backends
130 %{_libdir}/banshee-1/Backends/*.config
131 %{_libdir}/banshee-1/Backends/*.dll
132 %{_libdir}/banshee-1/Backends/*.mdb
133 %{_libdir}/banshee-1/Backends/*.so
134 %{_libdir}/banshee-1/Banshee.Services.addins
135 %dir %{_libdir}/banshee-1/gstreamer-0.10
136 %{_libdir}/banshee-1/gstreamer-0.10/*.so
137 #%{_libdir}/banshee-1/libbanshee.a
138 #%{_libdir}/banshee-1/libbanshee.la
139 #%{_libdir}/monodoc/sources/*
140 %{_desktopdir}/banshee-1-audiocd.desktop
141 %{_desktopdir}/banshee-1-media-player.desktop
142 %{_desktopdir}/banshee-1.desktop
143 %{_iconsdir}/hicolor/*/*/*
144 %{_datadir}/dbus-1/services/org.bansheeproject.Banshee.service
145 %{_datadir}/dbus-1/services/org.bansheeproject.CollectionIndexer.service
This page took 0.085093 seconds and 4 git commands to generate.