]> git.pld-linux.org Git - packages/banshee.git/blob - banshee.spec
- bash bash bash
[packages/banshee.git] / banshee.spec
1 #
2 %include /usr/lib/rpm/macros.mono
3 #
4 Summary:        A Mono/GStreamer Based Music Player
5 Summary(pl.UTF-8):      Oparty na Mono/GStreamerze odtwarzacz muzyki
6 Name:           banshee
7 Version:        1.5.5
8 Release:        1
9 License:        GPL
10 Group:          Applications/Multimedia
11 Source0:        http://download.banshee-project.org/banshee/%{name}-1-%{version}.tar.bz2
12 # Source0-md5:  0f5f2ba887cd57b2f785320ab0a44911
13 URL:            http://banshee-project.org/
14 BuildRequires:  GConf2-devel
15 BuildRequires:  autoconf >= 2.13
16 BuildRequires:  automake
17 BuildRequires:  brasero-devel >= 2.28.0
18 BuildRequires:  clutter-devel >= 1.0.1
19 BuildRequires:  dbus-devel >= 0.93
20 BuildRequires:  dbus-glib-devel >= 0.71
21 BuildRequires:  dotnet-gdata-sharp-devel
22 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
23 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10.0
24 BuildRequires:  dotnet-ipod-sharp-devel >= 0.8.5
25 BuildRequires:  dotnet-libgphoto2-sharp-devel
26 BuildRequires:  dotnet-mono-zeroconf-devel
27 BuildRequires:  dotnet-ndesk-dbus-glib-sharp-devel >= 0.3
28 BuildRequires:  dotnet-njb-sharp
29 BuildRequires:  dotnet-notify-sharp-devel
30 BuildRequires:  dotnet-webkit-sharp-devel
31 BuildRequires:  gnome-desktop-devel >= 2.16.0
32 BuildRequires:  gstreamer-GConf >= 0.10.3
33 BuildRequires:  gstreamer-cdparanoia
34 BuildRequires:  gstreamer-devel >= 0.10.3
35 BuildRequires:  gstreamer-gnomevfs
36 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.3
37 BuildRequires:  gtk+2-devel >= 2:2.10.3
38 BuildRequires:  hal-devel >= 0.5.2
39 BuildRequires:  intltool >= 0.35
40 BuildRequires:  libmtp-devel >= 0.2.0
41 BuildRequires:  libmusicbrainz-devel >= 2.1.1
42 BuildRequires:  libtool
43 BuildRequires:  mono-addins-devel >= 0.3.1-2
44 BuildRequires:  mono-csharp >= 1.1.13
45 BuildRequires:  monodoc
46 BuildRequires:  pkgconfig
47 BuildRequires:  sqlite3-devel
48 BuildRequires:  taglib-sharp-devel >= 2.0.3.5
49 Requires:       dotnet-ipod-sharp >= 0.8.0
50 Requires:       gstreamer-GConf >= 0.10.3
51 Requires:       gstreamer-cdparanoia >= 0.10.3
52 Requires:       gstreamer-gnomevfs >= 0.10.3
53 Requires:       mono-addins >= 0.3.1-2
54 Obsoletes:      banshee-official-plugins <= 0.11.3
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 Banshee is a brand spankin' new audio player based on the GStreamer
59 media library and is developed on the Open Source Mono .NET Platform,
60 written in C#.
61
62 %description -l pl.UTF-8
63 Banshee to nowy odtwarzacz dźwięku oparty na bibliotece odtwarzacza
64 multimediów GStreamer, rozwijany na platformie .NET Mono, napisany w
65 C#.
66
67 %prep
68 %setup -q -n %{name}-1-%{version}
69
70 %build
71 %{__libtoolize}
72 %{__intltoolize}
73 %{__aclocal} -I build/m4/banshee -I build/m4/shave -I build/m4/shamrock
74 %{__automake}
75 %{__autoconf}
76
77 bash %configure \
78         --disable-boo \
79         --disable-dev-tests \
80         --disable-helix \
81         --enable-ipod \
82         --enable-njb \
83         --disable-vlc \
84         --enable-gstreamer \
85         --enable-avahi \
86         --disable-docs \
87         --with-vendor-build-id="%{distribution}"
88 %{__make} \
89         SHELL=/bin/bash
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d $RPM_BUILD_ROOT%{_libdir}/monodoc/sources
94
95 %{__make} install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 #mv $RPM_BUILD_ROOT%{_docdir}/%{name}/* $RPM_BUILD_ROOT%{_libdir}/monodoc/sources
99
100 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}-1/*.{la,a}
101 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}-1/Backends/*.{la,a}
102 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}-1/gstreamer-0.10/*.{la,a}
103
104 %find_lang %{name}-1
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post
110 %update_desktop_database_post
111 %update_icon_cache hicolor
112
113 %postun
114 %update_desktop_database_postun
115 %update_icon_cache hicolor
116
117 %files -f %{name}-1.lang
118 %defattr(644,root,root,755)
119 %doc AUTHORS COPYING ChangeLog NEWS README
120 %attr(755,root,root) %{_bindir}/banshee-1
121 %attr(755,root,root) %{_bindir}/muinshee
122 %{_datadir}/banshee-1
123 %{_pkgconfigdir}/banshee-1*.pc
124 %dir %{_libdir}/banshee-1
125 %{_libdir}/banshee-1/*.dll
126 %attr(755,root,root) %{_libdir}/banshee-1/*.so
127 %{_libdir}/banshee-1/*.exe
128 %{_libdir}/banshee-1/*.mdb
129 %{_libdir}/banshee-1/*.config
130 %dir %{_libdir}/banshee-1/Extensions
131 %{_libdir}/banshee-1/Extensions/*.dll
132 %{_libdir}/banshee-1/Extensions/*.mdb
133 %{_libdir}/banshee-1/Extensions/Banshee.NotificationArea.dll.config
134 %dir %{_libdir}/banshee-1/Backends
135 %{_libdir}/banshee-1/Backends/*.config
136 %{_libdir}/banshee-1/Backends/*.dll
137 %{_libdir}/banshee-1/Backends/*.mdb
138 %{_libdir}/banshee-1/Backends/*.so
139 %{_libdir}/banshee-1/Banshee.Services.addins
140 %dir %{_libdir}/banshee-1/gstreamer-0.10
141 %{_libdir}/banshee-1/gstreamer-0.10/*.so
142 #%{_libdir}/banshee-1/libbanshee.a
143 #%{_libdir}/banshee-1/libbanshee.la
144 #%{_libdir}/monodoc/sources/*
145 %{_desktopdir}/banshee-1-audiocd.desktop
146 %{_desktopdir}/banshee-1-media-player.desktop
147 %{_desktopdir}/banshee-1.desktop
148 %{_iconsdir}/hicolor/*/*/*
149 %{_datadir}/dbus-1/services/org.bansheeproject.Banshee.service
150 %{_datadir}/dbus-1/services/org.bansheeproject.CollectionIndexer.service
This page took 0.035172 seconds and 4 git commands to generate.