]> git.pld-linux.org Git - packages/awesome.git/commitdiff
- merged DEVEL auto/th/awesome-3_4-1
authorpawelz <pawelz@pld-linux.org>
Tue, 20 Oct 2009 19:23:34 +0000 (19:23 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- up to 3.4
- rel 1

Changed files:
    awesome-client-bashizm.patch -> 1.3
    awesome-magnifier.patch -> 1.2
    awesome.spec -> 1.78

awesome-client-bashizm.patch [deleted file]
awesome-magnifier.patch [new file with mode: 0644]
awesome.spec

diff --git a/awesome-client-bashizm.patch b/awesome-client-bashizm.patch
deleted file mode 100644 (file)
index 68e4995..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-diff --git a/utils/awesome-client b/utils/awesome-client
-index a125869..e99faf3 100755
---- a/utils/awesome-client
-+++ b/utils/awesome-client
-@@ -1,7 +1,8 @@
- #!/bin/sh
- # rlwrap provides readline to stuff which doesn't know readline by itself
--RLWRAP=`which rlwrap 2>/dev/null`
-+RLWRAP=$(which rlwrap 2>/dev/null)
-+READ_OPTIONS="-r"
- if [ "$RLWRAP" != "" ]
- then
-@@ -10,7 +11,15 @@ then
-         A_RERUN="no" exec $RLWRAP $0
-     fi
- else
--    USE_READLINE="-e"
-+    if [ "$BASH" ]
-+    then
-+        READ_PARAMETERS=" -e"
-+    fi
-+fi
-+
-+if [ $BASH ]
-+then
-+    READ_OPTIONS="$READ_OPTIONS -p awesome# "
- fi
- DBUS_SEND=dbus-send
-@@ -32,7 +41,7 @@ a_dbus_send()
-         $DBUS_METHOD string:"$1" | tail -n +2
- }
--while read ${USE_READLINE} -r -p "awesome# " line
-+while read ${USE_READLINE} ${READ_OPTIONS} line
- do
-     a_dbus_send "$line"
- done
diff --git a/awesome-magnifier.patch b/awesome-magnifier.patch
new file mode 100644 (file)
index 0000000..9ada12a
--- /dev/null
@@ -0,0 +1,36 @@
+diff --git a/lib/awful/layout/suit/magnifier.lua.in b/lib/awful/layout/suit/magnifier.lua.in
+index 2d4a526..74a2398 100644
+--- a/lib/awful/layout/suit/magnifier.lua.in
++++ b/lib/awful/layout/suit/magnifier.lua.in
+@@ -34,6 +34,11 @@ function arrange(p)
+         fidx = 1
+     end
++    -- If focused window is floating, value of focus will change. We want to
++    -- save original value of focus and raise() it after seting geometry of
++    -- other clients.
++    local originalfocus = focus
++
+     -- If focused window is not tiled, take the first one which is tiled.
+     if client.floating.get(focus) then
+         focus = cls[1]
+@@ -56,7 +61,6 @@ function arrange(p)
+         geometry.height = area.height
+     end
+     focus:geometry(geometry)
+-    focus:raise()
+     if #cls > 1 then
+         geometry.x = area.x
+@@ -87,6 +91,11 @@ function arrange(p)
+             geometry.y = geometry.y + geometry.height
+         end
+     end
++
++    -- Raise primary tiled window and then the originally focused window. If
++    -- there was no floating window it is the same window.
++    focus:raise()
++    originalfocus:raise()
+ end
+ name = "magnifier"
index eae91711710c8ac4d262f6fbdbf7aa86b69d5b4a..3597aad0aa61a649284507c5889f134e6d03d475 100644 (file)
@@ -1,17 +1,18 @@
+
 Summary:       awesome window manager
 Summary(hu.UTF-8):     awesome ablakkezelő
 Summary(pl.UTF-8):     Zarządca okien X - Awesome
 Name:          awesome
-Version:       3.3.4
+Version:       3.4
 Release:       1
 License:       GPL v2
 Group:         X11/Window Managers
 Source0:       http://awesome.naquadah.org/download/%{name}-%{version}.tar.bz2
-# Source0-md5: a8e20a5af2cb07191416c2b8198b450c
+# Source0-md5: 2c4cba2fb7a791c77d17506e51067155
 Source1:       %{name}-xsession.desktop
 Patch0:                %{name}-3.0-lua-files.patch
-Patch1:                %{name}-client-bashizm.patch
-Patch2:                %{name}-xmlto.patch
+Patch1:                %{name}-xmlto.patch
+Patch2:                %{name}-magnifier.patch
 URL:           http://awesome.naquadah.org/
 BuildRequires: ImageMagick-coder-png
 BuildRequires: asciidoc
@@ -24,6 +25,7 @@ BuildRequires:        glib2-devel
 BuildRequires: gperf
 BuildRequires: imlib2-devel
 BuildRequires: libev-devel
+BuildRequires: libxcb-devel >= 1.4
 BuildRequires: libxdg-basedir-devel >= 1.0.1
 BuildRequires: lua-doc
 BuildRequires: lua51-devel
@@ -40,9 +42,13 @@ BuildRequires:       xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXft-devel
 BuildRequires: xorg-lib-libXinerama-devel
 BuildRequires: xorg-lib-libXrandr-devel
-Requires:      %{name}-client = %{version}-%{release}
+BuildRequires: xorg-proto-xproto-devel >= 7.0.15
 Requires:      startup-notification >= 0.10
 Requires:      xcb-util >= 0.3.6
+Provides:      awesome-plugin-awful
+Provides:      awesome-plugin-beautiful
+Obsoletes:     awesome-plugin-awful
+Obsoletes:     awesome-plugin-beautiful
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/X11
@@ -112,9 +118,6 @@ Summary(hu.UTF-8):  Egy alap/példa konfig az awesome ablakkezelőhöz
 Summary(pl.UTF-8):     Przykładowy plik konfiguracyjny dla zarządcy okien awesome
 Group:         Documentation
 Requires:      %{name} = %{version}-%{release}
-Requires:      %{name}-plugin-awful = %{version}-%{release}
-Requires:      %{name}-plugin-beautiful = %{version}-%{release}
-Requires:      %{name}-plugin-tabulous = %{version}-%{release}
 Requires:      %{name}-themes = %{version}-%{release}
 
 %description example-config
@@ -131,71 +134,12 @@ Przykładowy plik konfiguracyjny dla zarządcy okien awesome. Ten plik
 jest dobrym punktem wyjścia dla osób nie używających wcześniej awesome
 3.x.
 
-%package plugin-awful
-Summary:       awful plugin for awesome window manager
-Summary(hu.UTF-8):     awful plugin az awesome ablakkezelőhöz
-Summary(pl.UTF-8):     Wtyczka awful dla zarządcy okien awesome
-Group:         X11/Window Managers/Tools
-Requires:      %{name} = %{version}-%{release}
-
-%description plugin-awful
-AWesome Functions very UsefuL: awful plugin for awesome window
-manager.
-
-%description plugin-awful -l hu.UTF-8
-AWesome Functions very UsefuL: awful plugin az awesome ablakkezelőhöz.
-
-%description plugin-awful -l pl.UTF-8
-AWesome Functions very UsefuL: wtyczka awful dla zarządcy okien
-awesome.
-
-%package plugin-beautiful
-Summary:       Theme library for awesome window manager
-Summary(hu.UTF-8):     Theme könyvtár az awesome ablakkezelőhöz
-Summary(pl.UTF-8):     Biblioteka styli dla zarządcy okien awesome
-Group:         X11/Window Managers/Tools
-Requires:      %{name} = %{version}-%{release}
-Suggests:      WallpaperChanger
-
-%description plugin-beautiful
-Theme library for awesome window manager.
-
-%description plugin-beautiful -l hu.UTF-8
-Theme könyvtár az awesome ablakkezelőhöz.
-
-%description plugin-beautiful -l pl.UTF-8
-Biblioteka styli dla zarządcy okien awesome.
-
-%package plugin-invaders
-Summary:       Awesome Invaders game
-Summary(hu.UTF-8):     Awesome Invaders játék
-Summary(pl.UTF-8):     Gra Awesome Invaders
-Group:         X11/Window Managers/Tools
-Requires:      %{name} = %{version}-%{release}
-Requires:      %{name}-plugin-awful = %{version}-%{release}
-Requires:      %{name}-plugin-beautiful = %{version}-%{release}
-Requires:      ImageMagick
-
-%description plugin-invaders
-Awesome Invaders is, as the name says, an implementation of Space
-Invaders using awesome 3's Lua interface.
-
-%description plugin-invaders -l hu.UTF-8
-Awesome Invaders, ahogy a neve is mutatja, a Space Invaders
-megvalósítása az awesome 3 lua interfészét használva.
-
-%description plugin-invaders -l pl.UTF-8
-Awesome Invaders jest grą Space Invaders zaimplementowaną w intefejsie
-Lua zarządcy okien awesome 3.
-
 %package plugin-naughty
 Summary:       Naughty is a lua library that implements popup notifications for awesome 3
 Summary(hu.UTF-8):     Naughty egy lua-könyvtár, amely felugró értesítéseket tesz lehetővé awesome3-ban
 Summary(pl.UTF-8):     Powiadomienia w postaci wyskakujących okienek dla awesome 3
 Group:         X11/Window Managers/Tools
 Requires:      %{name} = %{version}-%{release}
-Requires:      %{name}-plugin-awful = %{version}-%{release}
-Requires:      %{name}-plugin-beautiful = %{version}-%{release}
 Provides:      dbus(org.freedesktop.Notifications)
 
 %description plugin-naughty
@@ -210,57 +154,60 @@ awesome3-ban.
 Biblioteka lua dla zarządcy okien awesome 3 implementująca
 powiadomienia w formie wyskakujących okienek.
 
-%package plugin-tabulous
-Summary:       Fabulous tabs for awesome window manager
-Summary(hu.UTF-8):     Tab-ok awesome-hoz
-Summary(pl.UTF-8):     Zakładki dla zarządcy okien awesome
+%package themes
+Summary:       Themes for awesome window manager (metapackage)
+Summary(hu.UTF-8):     Témák az awesome ablakkezelőhöz (metacsomag)
+Summary(pl.UTF-8):     Tematy dla zarządcy okien awesome
 Group:         X11/Window Managers/Tools
 Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-themes-default = %{version}-%{release}
+Requires:      %{name}-themes-sky = %{version}-%{release}
+Requires:      %{name}-themes-zenburn = %{version}-%{release}
 
-%description plugin-tabulous
-Fabulous tabs for awesome.
+%description themes
+Themes for awesome window manager (metapackage).
 
-%description plugin-tabulous -l hu.UTF-8
-Tab-ok awesome-hoz.
+%description themes -l hu.UTF-8
+Témák az awesome ablakkezelőhöz (metacsomag).
 
-%description plugin-tabulous -l pl.UTF-8
-Zakładki dla zarządcy okien awesome.
+%description themes -l pl.UTF-8
+Dodatkowe "tematy" (definicje wyglądu) zarządcy okien awesome.
 
-%package plugin-telak
-Summary:       Root window image display library
-Summary(hu.UTF-8):     Root ablak kezeléséhez könyvtár
-Summary(pl.UTF-8):     Biblioteka pozwlająca ustawić tapetę w głównym oknie
+%package themes-default
+Summary:       Default theme for awesome window manager
+Summary(hu.UTF-8):     Alapértelmezett téma az awesome ablakkezelőhöz
 Group:         X11/Window Managers/Tools
-Requires:      %{name} = %{version}-%{release}
-Requires:      lua-socket
-
-%description plugin-telak
-Root window image display library.
 
-%description plugin-telak -l hu.UTF-8
-Root ablak kezeléséhez könyvtár.
+%description themes-default
+Default theme for awesome window manager.
 
-%description plugin-telak -l pl.UTF-8
-Biblioteka pozwalająca ustawić tapetę wyświetlaną na głównym oknie.
+%description themes-default -l hu.UTF-8
+Alapértelmezett téma az awesome ablakkezelőhöz.
 
-%package themes
-Summary:       Themes for awesome window manager
-Summary(hu.UTF-8):     Témák az awesome ablakkezelőhöz
-Summary(pl.UTF-8):     Tematy dla zarządcy okien awesome
+%package themes-sky
+Summary:       Sky theme for awesome window manager
+Summary(hu.UTF-8):     Sky téma az awesome ablakkezelőhöz
 Group:         X11/Window Managers/Tools
-Requires:      %{name} = %{version}-%{release}
 
-%description themes
-Themes for awesome window manager.
+%description themes-sky
+Sky theme for awesome window manager.
 
-%description themes -l hu.UTF-8
-Témák az awesome ablakkezelőhöz.
+%description themes-sky -l hu.UTF-8
+Sky téma az awesome ablakkezelőhöz.
 
-%description themes -l pl.UTF-8
-Dodatkowe "tematy" (definicje wyglądu) zarządcy okien awesome.
+%package themes-zenburn
+Summary:       Zenburn theme for awesome window manager
+Summary(hu.UTF-8):     Zenburn téma az awesome ablakkezelőhöz
+Group:         X11/Window Managers/Tools
+
+%description themes-zenburn
+Zenburn theme for awesome window manager.
+
+%description themes-zenburn -l hu.UTF-8
+Zenburn téma az awesome ablakkezelőhöz.
 
 %prep
-%setup -q
+%setup -q -n %{name}-%{version}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -298,13 +245,23 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/awsetbg
 %dir %{_datadir}/%{name}
 %dir %{_datadir}/%{name}/lib
-%{_datadir}/%{name}/lib/capi.lua
 %{_datadir}/%{name}/icons
 %{_datadir}/xsessions/%{name}.desktop
 %{_mandir}/man1/%{name}.1*
 %{_mandir}/man1/awsetbg.1*
 %{_mandir}/man5/awesomerc.5*
 
+# plugin-awful
+%dir %{_datadir}/awesome/lib/awful
+%{_datadir}/awesome/lib/awful/*.lua
+%{_datadir}/awesome/lib/awful/layout
+%{_datadir}/awesome/lib/awful/mouse
+%{_datadir}/awesome/lib/awful/widget
+
+# plugin-beautiful
+%dir %{_datadir}/awesome/themes
+%{_datadir}/awesome/lib/beautiful.lua
+
 %files client
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/%{name}-client
@@ -320,38 +277,21 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_sysconfdir}/xdg/awesome
 %{_sysconfdir}/xdg/awesome/*
 
-%files plugin-awful
+%files themes
 %defattr(644,root,root,755)
-%dir %{_datadir}/awesome/lib/awful
-%{_datadir}/awesome/lib/awful/*.lua
-%{_datadir}/awesome/lib/awful/layout
-%{_datadir}/awesome/lib/awful/widget
 
-%files plugin-beautiful
+%files themes-default
 %defattr(644,root,root,755)
-%{_datadir}/awesome/lib/beautiful.lua
-%{_datadir}/awesome/themes
+%{_datadir}/awesome/themes/default
 
-%files themes
+%files themes-sky
 %defattr(644,root,root,755)
-%dir %{_datadir}/awesome/themes
-%{_datadir}/awesome/themes/default
 %{_datadir}/awesome/themes/sky
 
-%files plugin-invaders
+%files themes-zenburn
 %defattr(644,root,root,755)
-%{_datadir}/awesome/lib/invaders.lua
-%dir %{_datadir}/awesome/icons/invaders
-%{_datadir}/awesome/icons/invaders/*.png
+%{_datadir}/awesome/themes/zenburn
 
 %files plugin-naughty
 %defattr(644,root,root,755)
 %{_datadir}/awesome/lib/naughty.lua
-
-%files plugin-tabulous
-%defattr(644,root,root,755)
-%{_datadir}/awesome/lib/tabulous.lua
-
-%files plugin-telak
-%defattr(644,root,root,755)
-%{_datadir}/awesome/lib/telak.lua
This page took 0.051504 seconds and 4 git commands to generate.