]> git.pld-linux.org Git - packages/awesome.git/commitdiff
- initial
authorZsolt Udvari <uzsolt@pld-linux.org>
Tue, 1 Mar 2011 11:27:34 +0000 (11:27 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- taken from Arch

Changed files:
    normalize-icon-path-names.patch -> 1.1

normalize-icon-path-names.patch [new file with mode: 0644]

diff --git a/normalize-icon-path-names.patch b/normalize-icon-path-names.patch
new file mode 100644 (file)
index 0000000..a47f19c
--- /dev/null
@@ -0,0 +1,28 @@
+---
+ CMakeLists.txt |    3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 64be9b9..472bec2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -244,14 +244,15 @@ endif()
+ # {{{ Theme icons
+ file(GLOB icon_sources RELATIVE ${SOURCE_DIR} ${SOURCE_DIR}/themes/*/titlebar/*.png)
+-set(ALL_ICONS ${icon_sources})
+ foreach(icon ${icon_sources})
+     # Copy all icons to the build dir to simplify the following code.
+     # Source paths are interpreted relative to ${SOURCE_DIR}, target paths
+     # relative to ${BUILD_DIR}.
+     get_filename_component(icon_path ${icon} PATH)
++    get_filename_component(icon_name ${icon} NAME)
+     file(COPY ${icon} DESTINATION ${icon_path})
++    set(ALL_ICONS ${ALL_ICONS} "${icon_path}/${icon_name}")
+ endforeach()
+ macro(a_icon_convert match replacement input)
+-- 
+1.7.3.4
+
This page took 0.029039 seconds and 4 git commands to generate.