]> git.pld-linux.org Git - packages/autopano-sift-C.git/blob - autopano-sift-C.spec
- release 2 (by relup.sh)
[packages/autopano-sift-C.git] / autopano-sift-C.spec
1 Summary:        SIFT Feature Detection implementation
2 Summary(pl.UTF-8):      Implementacja algorytmu SIFT do wykrywania cech obrazu
3 Name:           autopano-sift-C
4 Version:        2.5.1
5 Release:        2
6 License:        GPL v2, but SIFT algorithm may require license in some countries
7 Group:          Applications/Graphics
8 Source0:        http://downloads.sourceforge.net/hugin/%{name}-%{version}.tar.gz
9 # Source0-md5:  b9bade07e8c4f2ea383c22a082c260e0
10 Patch0:         link.patch
11 URL:            http://wiki.panotools.org/Autopano-sift-C
12 BuildRequires:  cmake >= 2.4
13 BuildRequires:  libjpeg-devel
14 BuildRequires:  libpano13-devel
15 BuildRequires:  libpng-devel
16 BuildRequires:  libtiff-devel
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  libxml2-devel >= 2.0
19 BuildRequires:  pkgconfig
20 BuildRequires:  rpmbuild(macros) >= 1.471
21 BuildRequires:  sed >= 4.0
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The SIFT algorithm provides the capability to identify key feature
26 points within arbitrary images. It further extracts highly distinct
27 information for each such point and allows to characterize the point
28 invariant to a number of modifications to the image. It is invariant
29 to contrast/brightness changes, to rotation, scaling and partially
30 invariant to other kinds of transformations. The algorithm can be
31 flexibly used to create input data for image matching, object
32 identification and other computer vision related algorithms.
33
34 autopano-sift-C is a C port of the C# software autopano-sift. It is
35 somewhat faster and doesn't require a C# runtime. Additionally,
36 autopano-sift-C has experimental modifications to perform feature
37 identification in conformal image space, this helps with wide angle or
38 fisheye Projection photographs.
39
40 %description -l pl.UTF-8
41 Algorytm SIFT daje możliwość określenia kluczowych punktów
42 charakterystycznych na dowolnych zdjęciach. Następnie wydobywa
43 informacje wyodrębniające dla każdego takiego punktu i pozwala
44 scharakteryzować ten punkt niezależnie od liczby modyfikacji obrazu.
45 Jest niezależny od zmian kontrastu/jasności, obrotów, skalowania i
46 częściowo niezależny od innych rodzajów przekształceń. Algorytm może
47 być elastycznie używany do tworzenia danych wejściowych do
48 dopasowywania obrazów, identyfikowania obiektów i innych algorytmów
49 związanych z grafiką komputerową.
50
51 autopano-sift-C to port C programu autopano-sift napisanego w C#.
52 Jest nieco szybszy i nie wymaga środowiska uruchomieniowego C#.
53 Ponadto zawiera nieco eksperymentalnych modyfikacji w celu
54 przeprowadzania identyfikacji punktów w wiernokątnej przestrzeni
55 obrazu, co pomaga przy zdjęciach obiektywami szerokokątnymi lub
56 "rybim okiem".
57
58 %prep
59 %setup -q 
60 %patch0 -p1
61
62 %build
63 install -d build
64 cd build
65 # CMAKE_AR is a hack, cmake is unable to find it otherwise :/
66 %cmake .. \
67         -DCMAKE_AR=/usr/bin/ar \
68         -DCMAKE_BUILD_TYPE=%{?debug:Debug}%{!?debug:Release} \
69         -DCMAKE_C_FLAGS_RELEASE="-DNDEBUG" \
70         -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
71         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
72         -DCMAKE_VERBOSE_MAKEFILE=ON \
73 %if "%{_lib}" == "lib64"
74         -DLIB_SUFFIX=64
75 %endif
76
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} -C build install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 # resolve conflict with autopano-sift
86 mv $RPM_BUILD_ROOT%{_mandir}/man1/autopano{,-c}.1
87 mv $RPM_BUILD_ROOT%{_mandir}/man1/generatekeys{,-c}.1
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc ChangeLog README README.1ST
95 %attr(755,root,root) %{_bindir}/autopano
96 %attr(755,root,root) %{_bindir}/autopano-c-complete.sh
97 %attr(755,root,root) %{_bindir}/autopano-sift-c
98 %attr(755,root,root) %{_bindir}/generatekeys
99 %{_mandir}/man1/autopano-c.1*
100 %{_mandir}/man1/autopano-c-complete.1*
101 %{_mandir}/man1/generatekeys-c.1*
102 %{_mandir}/man7/autopano-sift-c.7*
This page took 0.082361 seconds and 4 git commands to generate.