]> git.pld-linux.org Git - packages/autofs.git/blob - autofs.spec
- fixed requires (PR#28)
[packages/autofs.git] / autofs.spec
1 Summary:        autofs daemon
2 Summary(de):    autofs daemon 
3 Summary(fr):    démon autofs
4 Summary(pl):    Demon autofs 
5 Summary(tr):    autofs sunucu süreci
6 Name:           autofs
7 Version:        3.1.3
8 Release:        6
9 Copyright:      GPL
10 Group:          Daemons
11 Group(pl):      Serwery
12 Source0:        ftp://ftp.kernel.org/pub/linux/daemons/autofs/%{name}-%{version}.tar.bz2
13 Source1:        autofs.init
14 Patch:          autofs.patch
15 Buildroot:      /tmp/%{name}-%{version}-root
16 Prereq:         /sbin/chkconfig
17 Requires:       mktemp
18 Requires:       rc-scripts
19
20 %define         _sysconfdir     /etc/autofs
21
22 %description
23 autofs is a daemon which automatically mounts filesystems when you use
24 them, and unmounts them later when you are not using them.  This can
25 include network filesystems, CD-ROMs, floppies, and so forth.
26
27 %description -l de
28 autofs ist ein Dämon, der Dateisysteme automatisch montiert, wenn sie 
29 benutzt werden, und sie später bei Nichtbenutzung wieder demontiert. 
30 Dies kann Netz-Dateisysteme, CD-ROMs, Disketten und ähnliches einschließen. 
31
32 %description -l fr
33 autofs est un démon qui monte automatiquement les systèmes de fichiers
34 lorsqu'on les utilise et les démonte lorsqu'on ne les utilise plus. Cela
35 inclus les systèmes de fichiers réseau, les CD-ROMs, les disquettes, etc.
36
37 %description -l pl
38 Autofs jest demonem, który montuje automatycznie systemy plików je¿eli
39 je u¿ywasz i odmontowuje pó¼niej, je¿eli ich nie u¿ywasz. Mo¿e montowaæ
40 sieciowy system plików, CD-romy, stacje dyskietek i inne.
41
42 %description -l tr
43 autofs, kullanýlan dosya sistemlerini gerek olunca kendiliðinden baðlar
44 ve kullanýmlarý sona erince yine kendiliðinden çözer. Bu iþlem, að dosya
45 sistemleri, CD-ROM'lar ve disketler üzerinde yapýlabilir.
46
47 %prep
48 %setup -q
49 %patch -p1 
50
51 %build
52 LDFLAGS="-s"; export LDFLAGS
53 %configure
54  
55 make 
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 install -d $RPM_BUILD_ROOT/{misc,%{_sbindir},%{_libdir}/autofs,%{_mandir}/man{5,8}} \
61         $RPM_BUILD_ROOT/etc/{rc.d/init.d,autofs}
62
63 make install \
64         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
65         mandir=$RPM_BUILD_ROOT%{_mandir} \
66         autofslibdir=$RPM_BUILD_ROOT%{_libdir}/autofs
67
68 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/autofs
69 install samples/auto.* $RPM_BUILD_ROOT/etc/autofs
70
71 touch $RPM_BUILD_ROOT/etc/autofs/auto.{home,misc,var,tmp}
72
73 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/autofs/*
74
75 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man[58]/* \
76         NEWS README 
77
78 %post
79 /sbin/chkconfig --add autofs
80 if test -r /var/lock/subsys/automount; then
81         /etc/rc.d/init.d/autofs restart 1>&2
82 else
83         echo "Run \"/etc/rc.d/init.d/autofs start\" to start autofs daemon."
84 fi
85
86 %preun
87 if [ "$1" = "0" ]; then
88         /sbin/chkconfig --del autofs
89         if [ -f /var/lock/subsys/automount ]; then
90                 /etc/rc.d/init.d/autofs stop 1>&2
91         fi
92 fi
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files
98 %defattr(644,root,root,755)
99 %doc {NEWS,README}.gz 
100
101 %attr(754,root,root) %config /etc/rc.d/init.d/autofs
102 %dir %{_sysconfdir}
103 %attr(644,root,root) %config %verify(not size mtime md5) %{_sysconfdir}/*
104 %attr(755,root,root) %{_sbindir}/automount
105
106 %dir /misc
107
108 %dir %{_libdir}/autofs
109 %attr(755,root,root) %{_libdir}/autofs/*
110
111 %{_mandir}/man[58]/*
This page took 0.047521 seconds and 4 git commands to generate.