]> git.pld-linux.org Git - packages/autofs.git/blob - autofs.spec
- back to old group(pl).
[packages/autofs.git] / autofs.spec
1 Summary:        autofs daemon
2 Summary(de):    autofs daemon 
3 Summary(fr):    démon autofs
4 Summary(pl):    Demon autofs 
5 Summary(tr):    autofs sunucu süreci
6 Name:           autofs
7 Version:        3.1.3
8 Release:        3
9 Copyright:      GPL
10 Group:          Daemons
11 Group(pl):      Serwery
12 Source0:        ftp://ftp.kernel.org/pub/linux/daemons/autofs/%{name}-%{version}.tar.bz2
13 Source1:        autofs.init
14 Patch:          autofs.patch
15 Buildroot:      /tmp/%{name}-%{version}-root
16 Prereq:         /sbin/chkconfig
17 Requires:       mktemp
18
19 %description
20 autofs is a daemon which automatically mounts filesystems when you use
21 them, and unmounts them later when you are not using them.  This can
22 include network filesystems, CD-ROMs, floppies, and so forth.
23
24 %description -l pl
25 Autofs jest demonem, który montuje automatycznie systemy plików je¿eli
26 je u¿ywasz i odmontowuje pó¼niej, je¿eli ich nie u¿ywasz. Mo¿e montowaæ
27 sieciowy system plików, CD-romy, stacje dyskietek i inne.
28
29 %description -l de
30 autofs ist ein Dämon, der Dateisysteme automatisch montiert, wenn sie 
31 benutzt werden, und sie später bei Nichtbenutzung wieder demontiert. 
32 Dies kann Netz-Dateisysteme, CD-ROMs, Disketten und ähnliches einschließen. 
33
34 %description -l fr
35 autofs est un démon qui monte automatiquement les systèmes de fichiers
36 lorsqu'on les utilise et les démonte lorsqu'on ne les utilise plus. Cela
37 inclus les systèmes de fichiers réseau, les CD-ROMs, les disquettes, etc.
38
39 %description -l tr
40 autofs, kullanýlan dosya sistemlerini gerek olunca kendiliðinden baðlar
41 ve kullanýmlarý sona erince yine kendiliðinden çözer. Bu iþlem, að dosya
42 sistemleri, CD-ROM'lar ve disketler üzerinde yapýlabilir.
43
44 %prep
45 %setup -q
46 %patch -p1 
47
48 %build
49 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
50 ./configure \
51         --prefix=/usr \
52         --sysconfdir=/etc/autofs
53
54 make 
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 install -d $RPM_BUILD_ROOT/{misc,usr/{sbin,lib/autofs,man/{man5,man8}}} \
60         $RPM_BUILD_ROOT/etc/{rc.d/init.d,autofs}
61
62 make install \
63         sbindir=$RPM_BUILD_ROOT/usr/sbin \
64         mandir=$RPM_BUILD_ROOT/usr/man \
65         autofslibdir=$RPM_BUILD_ROOT/usr/lib/autofs
66
67 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/autofs
68 install samples/auto.* $RPM_BUILD_ROOT/etc/autofs
69
70 touch $RPM_BUILD_ROOT/etc/autofs/auto.{home,misc,var,tmp}
71
72 strip --strip-unneeded $RPM_BUILD_ROOT/usr/lib/autofs/*
73
74 gzip -9nf $RPM_BUILD_ROOT/usr/man/man[58]/* \
75         NEWS README 
76
77 %post -n autofs
78 /sbin/chkconfig --add autofs
79 if test -r /var/run/autofs.pid; then
80         /etc/rc.d/init.d/autofs stop >&2
81         /etc/rc.d/init.d/autofs start >&2
82 else
83         echo "Run \"/etc/rc.d/init.d/autofs start\" to start autofs daemon."
84 fi
85
86 %preun -n autofs
87 if [ "$1" = "0" ]; then
88         /sbin/chkconfig --del autofs
89         /etc/rc.d/init.d/autofs stop >&2
90 fi
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files
96 %defattr(644,root,root,755)
97 %doc {NEWS,README}.gz 
98
99 %attr(754,root,root) %config /etc/rc.d/init.d/autofs
100 %dir /etc/autofs
101 %attr(644,root,root) %config %verify(not size mtime md5) /etc/autofs/*
102 %attr(755,root,root) /usr/sbin/automount
103
104 %dir /misc
105
106 %dir /usr/lib/autofs
107 %attr(755,root,root) /usr/lib/autofs/*
108 /usr/man/man[58]/*
109
110 %changelog
111 * Tue Apr  6 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
112   [3.1.3-3]
113 - stripping autofs modules,
114 - modifications %post, %preun for standarizing this sections; this allow stop
115   service on uninstall and automatic restart on upgrade.
116
117 * Mon Apr  5 1999 Piotr Czerwiñski <pius@pld.org.pl>
118 - changed Group(pl) to Demony,
119 - gzipping documentation,
120 - added -nf to gzip parameters,
121 - removed man group from man pages,
122 - fixed dir permissions,
123 - cosmetic changes for common l&f.
124
125 * Sat Oct 10 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
126   [3.1.3-1d]
127 - fixed pl translation,
128 - fixed invalid modules/Makefile;
129 - fixed files permissions,
130 - moved sysconfdir to /etc/autofs,
131 - fixed rc.autofs to work wiht bash-2.02.1 and higher,
132 - added some samples auto.* config files.
133
134 * Fri Jun 12 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
135   [3.1.1-4d]
136 - build against glibc-2.1,
137 - translation modified for pl,
138 - added %defattr support,
139 - build from non root's account,
140 - moved %changelog at the end of spec.
141
142 * Thu May 07 1998 Prospector System <bugs@redhat.com>
143 - translations modified for de, fr, tr
144
145 * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
146 - updated to 3.1.1
147
148 * Wed Apr 22 1998 Michael K. Johnson <johnsonm@redhat.com>
149 - enhanced initscripts
150
151 * Fri Dec 05 1997 Michael K. Johnson <johnsonm@redhat.com>
152 - Link with -lnsl for glibc compliance.
153
154 * Thu Oct 23 1997 Michael K. Johnson <johnsonm@redhat.com>
155 - exclusivearch for i386 for now, since our kernel packages on
156   other platforms don't include autofs yet.
157 - improvements to initscripts.
158
159 * Thu Oct 16 1997 Michael K. Johnson <johnsonm@redhat.com>
160 - Built package from 0.3.14 for 5.0
This page took 0.050537 seconds and 4 git commands to generate.