]> git.pld-linux.org Git - packages/autofs.git/blob - autofs.spec
- masive changes:
[packages/autofs.git] / autofs.spec
1 Summary:        autofs daemon
2 Summary(de):    autofs daemon 
3 Summary(fr):    démon autofs
4 Summary(pl):    Demon autofs 
5 Summary(tr):    autofs sunucu süreci
6 Name:           autofs
7 Version:        3.1.3
8 Release:        4
9 Copyright:      GPL
10 Group:          Daemons
11 Group(pl):      Serwery
12 Source0:        ftp://ftp.kernel.org/pub/linux/daemons/autofs/%{name}-%{version}.tar.bz2
13 Source1:        autofs.init
14 Patch:          autofs.patch
15 Buildroot:      /tmp/%{name}-%{version}-root
16 Prereq:         /sbin/chkconfig
17 Requires:       mktemp
18
19 %description
20 autofs is a daemon which automatically mounts filesystems when you use
21 them, and unmounts them later when you are not using them.  This can
22 include network filesystems, CD-ROMs, floppies, and so forth.
23
24 %description -l pl
25 Autofs jest demonem, który montuje automatycznie systemy plików je¿eli
26 je u¿ywasz i odmontowuje pó¼niej, je¿eli ich nie u¿ywasz. Mo¿e montowaæ
27 sieciowy system plików, CD-romy, stacje dyskietek i inne.
28
29 %description -l de
30 autofs ist ein Dämon, der Dateisysteme automatisch montiert, wenn sie 
31 benutzt werden, und sie später bei Nichtbenutzung wieder demontiert. 
32 Dies kann Netz-Dateisysteme, CD-ROMs, Disketten und ähnliches einschließen. 
33
34 %description -l fr
35 autofs est un démon qui monte automatiquement les systèmes de fichiers
36 lorsqu'on les utilise et les démonte lorsqu'on ne les utilise plus. Cela
37 inclus les systèmes de fichiers réseau, les CD-ROMs, les disquettes, etc.
38
39 %description -l tr
40 autofs, kullanýlan dosya sistemlerini gerek olunca kendiliðinden baðlar
41 ve kullanýmlarý sona erince yine kendiliðinden çözer. Bu iþlem, að dosya
42 sistemleri, CD-ROM'lar ve disketler üzerinde yapýlabilir.
43
44 %prep
45 %setup -q
46 %patch -p1 
47
48 %build
49 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
50 ./configure %{_target} \
51         --prefix=/usr \
52         --sysconfdir=/etc/autofs
53  
54 make 
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 install -d $RPM_BUILD_ROOT/{misc,usr/{sbin,lib/autofs,man/{man5,man8}}} \
60         $RPM_BUILD_ROOT/etc/{rc.d/init.d,autofs}
61
62 make install \
63         sbindir=$RPM_BUILD_ROOT/usr/sbin \
64         mandir=$RPM_BUILD_ROOT%{_mandir} \
65         autofslibdir=$RPM_BUILD_ROOT/usr/lib/autofs
66
67 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/autofs
68 install samples/auto.* $RPM_BUILD_ROOT/etc/autofs
69
70 touch $RPM_BUILD_ROOT/etc/autofs/auto.{home,misc,var,tmp}
71
72 strip --strip-unneeded $RPM_BUILD_ROOT/usr/lib/autofs/*
73
74 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man[58]/* \
75         NEWS README 
76
77 %post -n autofs
78 /sbin/chkconfig --add autofs
79 if test -r /var/run/autofs.pid; then
80         /etc/rc.d/init.d/autofs stop >&2
81         /etc/rc.d/init.d/autofs start >&2
82 else
83         echo "Run \"/etc/rc.d/init.d/autofs start\" to start autofs daemon."
84 fi
85
86 %preun -n autofs
87 if [ "$1" = "0" ]; then
88         /sbin/chkconfig --del autofs
89         /etc/rc.d/init.d/autofs stop >&2
90 fi
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files
96 %defattr(644,root,root,755)
97 %doc {NEWS,README}.gz 
98
99 %attr(754,root,root) %config /etc/rc.d/init.d/autofs
100 %dir /etc/autofs
101 %attr(644,root,root) %config %verify(not size mtime md5) /etc/autofs/*
102 %attr(755,root,root) /usr/sbin/automount
103
104 %dir /misc
105 %dir /usr/lib/autofs
106
107 %attr(755,root,root) /usr/lib/autofs/*
108 %{_mandir}/man[58]/*
109
110 %changelog
111 * Tue Apr 20 1999 Piotr Czerwiñski <pius@pld.org.pl>
112   [3.1.3-4]
113 - recompiled on rpm 3.
114
115 * Tue Apr  6 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
116   [3.1.3-3]
117 - stripping autofs modules,
118 - modifications %post, %preun for standarizing this sections; this allow stop
119   service on uninstall and automatic restart on upgrade.
120
121 * Mon Apr  5 1999 Piotr Czerwiñski <pius@pld.org.pl>
122 - changed Group(pl) to Demony,
123 - gzipping documentation,
124 - added -nf to gzip parameters,
125 - removed man group from man pages,
126 - fixed dir permissions,
127 - cosmetic changes for common l&f.
128
129 * Sat Oct 10 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
130   [3.1.3-1d]
131 - fixed pl translation,
132 - fixed invalid modules/Makefile;
133 - fixed files permissions,
134 - moved sysconfdir to /etc/autofs,
135 - fixed rc.autofs to work wiht bash-2.02.1 and higher,
136 - added some samples auto.* config files.
137
138 * Fri Jun 12 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
139   [3.1.1-4d]
140 - build against glibc-2.1,
141 - translation modified for pl,
142 - added %defattr support,
143 - build from non root's account,
144 - moved %changelog at the end of spec.
145
146 * Thu May 07 1998 Prospector System <bugs@redhat.com>
147 - translations modified for de, fr, tr
148
149 * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
150 - updated to 3.1.1
151
152 * Wed Apr 22 1998 Michael K. Johnson <johnsonm@redhat.com>
153 - enhanced initscripts
154
155 * Fri Dec 05 1997 Michael K. Johnson <johnsonm@redhat.com>
156 - Link with -lnsl for glibc compliance.
157
158 * Thu Oct 23 1997 Michael K. Johnson <johnsonm@redhat.com>
159 - exclusivearch for i386 for now, since our kernel packages on
160   other platforms don't include autofs yet.
161 - improvements to initscripts.
162
163 * Thu Oct 16 1997 Michael K. Johnson <johnsonm@redhat.com>
164 - Built package from 0.3.14 for 5.0
This page took 0.096521 seconds and 4 git commands to generate.