]> git.pld-linux.org Git - packages/armadillo.git/blob - armadillo.spec
- updated to 10.8.2
[packages/armadillo.git] / armadillo.spec
1 Summary:        C++ linear algebra library
2 Summary(pl.UTF-8):      Biblioteka C++ do algebry liniowej
3 Name:           armadillo
4 Version:        10.8.2
5 Release:        1
6 License:        MPL v2.0
7 Group:          Libraries
8 Source0:        https://downloads.sourceforge.net/arma/%{name}-%{version}.tar.xz
9 # Source0-md5:  ecf2ed979c7f950d6dfaf17b0a3d02cf
10 URL:            https://arma.sourceforge.net/
11 BuildRequires:  SuperLU-devel >= 5
12 BuildRequires:  arpack-devel
13 BuildRequires:  blas-devel
14 BuildRequires:  cmake >= 2.8.12
15 BuildRequires:  hdf5-devel
16 BuildRequires:  lapack-devel
17 BuildRequires:  libstdc++-devel >= 6:4.8.3
18 BuildRequires:  pkgconfig
19 BuildRequires:  rpm-build >= 4.6
20 BuildRequires:  rpmbuild(macros) >= 1.752
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Armadillo is a C++ linear algebra library (matrix maths) aiming
27 towards a good balance between speed and ease of use. The syntax is
28 deliberately similar to Matlab.
29
30 %description -l pl.UTF-8
31 Armadillo to biblioteka C++ do algebry liniowej (obliczeń na
32 macierzach), której celem jest dobry kompromis między szybkością a
33 łatwością użycia. Składnia jest celowo podobna do Matlaba.
34
35 %package devel
36 Summary:        Header files for Armadillo library
37 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Armadillo
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40 Requires:       SuperLU-devel >= 5
41 Requires:       arpack-devel
42 Requires:       blas-devel
43 Requires:       hdf5-devel
44 Requires:       lapack-devel
45 Requires:       libstdc++-devel >= 6:4.8.3
46 Obsoletes:      armadillo-static < 6
47
48 %description devel
49 Header files for Armadillo library.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki Armadillo.
53
54 %package apidocs
55 Summary:        Armadillo API documentation
56 Summary(pl.UTF-8):      Dokumentacja API biblioteki Armadillo
57 Group:          Documentation
58 BuildArch:      noarch
59
60 %description apidocs
61 API and internal documentation for Armadillo library.
62
63 %description apidocs -l pl.UTF-8
64 Dokumentacja API biblioteki Armadillo.
65
66 %prep
67 %setup -q
68
69 %build
70 install -d build
71 cd build
72 %cmake .. \
73         -DDETECT_HDF5=ON \
74         -DINSTALL_LIB_DIR=%{_libdir}
75
76 %{__make}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %{__make} -C build install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc LICENSE.txt README.md docs.html
93 %attr(755,root,root) %{_libdir}/libarmadillo.so.*.*.*
94 %attr(755,root,root) %ghost %{_libdir}/libarmadillo.so.10
95
96 %files devel
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_libdir}/libarmadillo.so
99 %{_includedir}/armadillo
100 %{_includedir}/armadillo_bits
101 %{_pkgconfigdir}/armadillo.pc
102 %dir %{_datadir}/Armadillo
103 %{_datadir}/Armadillo/CMake
104
105 %files apidocs
106 %defattr(644,root,root,755)
107 %doc docs.html armadillo_icon.png armadillo_nicta_2010.pdf rcpp_armadillo_csda_2014.pdf
This page took 0.083358 seconds and 4 git commands to generate.