]> git.pld-linux.org Git - packages/aribb24.git/blob - aribb24.spec
debian patch to link -lm (for sqrt/log2)
[packages/aribb24.git] / aribb24.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        ARIB STD-B24 library
6 Summary(pl.UTF-8):      Biblioteka ARIB STD-B24
7 Name:           aribb24
8 Version:        1.0.3
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Libraries
12 #Source0Download: https://github.com/nkoriyama/aribb24/releases
13 Source0:        https://github.com/nkoriyama/aribb24/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  5ef0a6d1d72f294666ee1489b7ebb8c5
15 Patch0:         %{name}-pc.patch
16 Patch1:         link-libm.patch
17 URL:            https://github.com/nkoriyama/aribb24
18 BuildRequires:  autoconf >= 2.69
19 BuildRequires:  automake
20 BuildRequires:  libpng-devel
21 BuildRequires:  libtool >= 2:2
22 BuildRequires:  pkgconfig
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 A library for ARIB STD-B24, decoding JIS 8-bit characters and parsing
27 MPEG-TS stream.
28
29 %description -l pl.UTF-8
30 Biblioteka ARIB STD-B24, służąca do dekodowania 8-bitowych znaków JIS
31 oraz analizy strumieni MPEG-TS.
32
33 %package devel
34 Summary:        Header files for ARIB STD-B24 library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ARIB STD-B24
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       libpng-devel
39
40 %description devel
41 Header files for ARIB STD-B24 library.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe biblioteki ARIB STD-B24.
45
46 %package static
47 Summary:        Static ARIB STD-B24 library
48 Summary(pl.UTF-8):      Statyczna biblioteka ARIB STD-B24
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 Static ARIB STD-B24 library.
54
55 %description static -l pl.UTF-8
56 Statyczna biblioteka ARIB STD-B24.
57
58 %prep
59 %setup -q
60 %patch0 -p1
61 %patch1 -p1
62
63 %build
64 %{__libtoolize}
65 %{__aclocal} -I m4
66 %{__autoconf}
67 %{__automake}
68 %configure \
69         %{?with_static_libs:--enable-static}
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 # obsoleted by pkg-config
79 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libaribb24.la
80 # COPYING is just GPL text, the rest packaged as %doc
81 %{__rm} $RPM_BUILD_ROOT%{_docdir}/aribb24/{COPYING,README.md}
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc README.md
92 %attr(755,root,root) %{_libdir}/libaribb24.so.*.*.*
93 %attr(755,root,root) %ghost %{_libdir}/libaribb24.so.0
94
95 %files devel
96 %defattr(644,root,root,755)
97 %attr(755,root,root) %{_libdir}/libaribb24.so
98 %{_includedir}/aribb24
99 %{_pkgconfigdir}/aribb24.pc
100
101 %if %{with static_libs}
102 %files static
103 %defattr(644,root,root,755)
104 %{_libdir}/libaribb24.a
105 %endif
This page took 0.107666 seconds and 4 git commands to generate.