]> git.pld-linux.org Git - packages/aria2.git/blob - aria2.spec
- unconditional noarch subpackages
[packages/aria2.git] / aria2.spec
1 #
2 # Conditional build:
3 %bcond_with     openssl # OpenSSL instead of GnuTLS
4 %bcond_with     libuv   # libuv usage
5
6 Summary:        Aria2 is a download utility with resuming and segmented downloading
7 Summary(pl.UTF-8):      Narzędzie do pobierania plików z obsługą wznawiania i pobierania segmentowego
8 Name:           aria2
9 Version:        1.35.0
10 Release:        2
11 License:        GPL v2+ with OpenSSL exception
12 Group:          Applications/Networking
13 #Source0Download: https://github.com/aria2/aria2/releases
14 Source0:        https://github.com/aria2/aria2/releases/download/release-1.35.0/%{name}-%{version}.tar.gz
15 # Source0-md5:  6057c91559a3e82e44a89689944b5d0c
16 URL:            https://aria2.github.io/
17 BuildRequires:  c-ares-devel >= 1.7.0
18 BuildRequires:  cppunit-devel >= 1.10.2
19 %{!?with_openssl:BuildRequires: gmp-devel}
20 %{!?with_openssl:BuildRequires: gnutls-devel >= 2.2.0}
21 BuildRequires:  libssh2-devel
22 BuildRequires:  libstdc++-devel >= 6:4.8.3
23 %{?with_libuv:BuildRequires:    libuv-devel >= 1.13}
24 BuildRequires:  libxml2-devel >= 1:2.6.24
25 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.8}
26 %{!?with_openssl:BuildRequires: nettle-devel}
27 BuildRequires:  pkgconfig >= 1:0.20
28 BuildRequires:  rpmbuild(macros) >= 1.673
29 BuildRequires:  sqlite3-devel >= 3
30 BuildRequires:  zlib-devel >= 1.2.3
31 Requires:       c-ares >= 1.7.0
32 %{!?with_openssl:Requires:      gnutls >= 2.2.0}
33 %{?with_libuv:Requires: libuv >= 1.13}
34 Requires:       libxml2 >= 1:2.6.24
35 %{?with_openssl:Requires:       openssl >= 0.9.8}
36 Requires:       zlib >= 1.2.3
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Aria2 has segmented downloading engine in its core. It can download
41 one file from multiple URLs or multiple connections from one URL. This
42 results in very high speed downloading, very much faster than ordinary
43 browsers. It can also download BitTorrent files. We implemented this
44 engine in single-thread model. The architecture is very clean and easy
45 to extend. It also supports Metalink version 3.0.
46
47 %description -l pl.UTF-8
48 Aria2 wykorzystuje silnik pobierania segmentowego. Może pobierać jeden
49 plik z kilku adresów lub użyć wielu połączeń do jednego serwera. W
50 rezultacie pobieranie jest bardzo szybkie, znacznie szybsze niż w
51 przypadku standardowej przeglądarki WWW. Silnik ten zaimplementowany
52 jest w modelu jednowątkowym. Aria2 charakteryzuje się bardzo prostą i
53 rozszerzalną architekturą, która obsługuje także pliki BitTorrent oraz
54 MetaLink w wersji 3.0.
55
56 %package -n bash-completion-aria2
57 Summary:        Bash completion for aria2c command
58 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów programu aria2c
59 Group:          Applications/Shells
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       bash-completion >= 2.0
62 BuildArch:      noarch
63
64 %description -n bash-completion-aria2
65 Bash completion for aria2 commands.
66
67 %description -n bash-completion-aria2 -l pl.UTF-8
68 Bashowe dopełnianie parametrów poleceń aria2.
69
70 %prep
71 %setup -q
72
73 %build
74 %configure \
75         --disable-silent-rules \
76         %{?with_openssl:--without-gnutls} \
77         %{?with_libuv:--with-libuv}
78
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 install -d $RPM_BUILD_ROOT%{bash_compdir}
88 cp -p doc/bash_completion/aria2c $RPM_BUILD_ROOT%{bash_compdir}
89
90 # packaged as %doc
91 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/aria2
92
93 %find_lang aria2
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %files -f aria2.lang
99 %defattr(644,root,root,755)
100 %doc AUTHORS ChangeLog LICENSE.OpenSSL NEWS README.rst doc/xmlrpc
101 %attr(755,root,root) %{_bindir}/aria2c
102 %{_mandir}/man1/aria2c.1*
103 %lang(pt) %{_mandir}/pt/man1/aria2c.1*
104 %lang(ru) %{_mandir}/ru/man1/aria2c.1*
105
106 %files -n bash-completion-aria2
107 %defattr(644,root,root,755)
108 %{bash_compdir}/aria2c
This page took 0.082971 seconds and 4 git commands to generate.