]> git.pld-linux.org Git - packages/ardour.git/commitdiff
Version: 5.4.0, not finished yet
authorJacek Konieczny <jajcus@jajcus.net>
Tue, 11 Oct 2016 19:08:03 +0000 (21:08 +0200)
committerJacek Konieczny <jajcus@jajcus.net>
Tue, 11 Oct 2016 19:08:03 +0000 (21:08 +0200)
ardour-c++.patch [deleted file]
ardour-opt.patch [deleted file]
ardour-stdint.patch [deleted file]
ardour.spec

diff --git a/ardour-c++.patch b/ardour-c++.patch
deleted file mode 100644 (file)
index 7e82295..0000000
+++ /dev/null
@@ -1,87 +0,0 @@
---- ardour-2.0.3/gtk2_ardour/automation_selectable.h.orig      2007-05-10 13:30:27.000000000 +0200
-+++ ardour-2.0.3/gtk2_ardour/automation_selectable.h   2007-07-15 00:19:56.345439649 +0200
-@@ -31,17 +31,17 @@ struct AutomationSelectable : public Sel
-     nframes_t end;
-     double low_fract;
-     double high_fract;
--    TimeAxisView& track;
-+    TimeAxisView *track;
-     AutomationSelectable (nframes_t s, nframes_t e, double l, double h, TimeAxisView& atv)
--          : start (s), end (e), low_fract (l), high_fract (h), track (atv) {}
-+          : start (s), end (e), low_fract (l), high_fract (h), track (&atv) {}
-     bool operator== (const AutomationSelectable& other) {
-           return start == other.start &&
-                   end == other.end &&
-                   low_fract == other.low_fract &&
-                   high_fract == other.high_fract &&
--                  &track == &other.track;
-+                  track == other.track;
-     }
- };
---- ardour-2.0.3/gtk2_ardour/automation_time_axis.cc.orig      2007-05-10 13:30:27.000000000 +0200
-+++ ardour-2.0.3/gtk2_ardour/automation_time_axis.cc   2007-07-15 00:33:26.261213756 +0200
-@@ -554,7 +554,7 @@ AutomationTimeAxisView::reset_objects_on
-       for (PointSelection::iterator i = selection.begin(); i != selection.end(); ++i) {
--              if (&(*i).track != this) {
-+              if ((*i).track != this) {
-                       continue;
-               }
-               
-@@ -585,7 +585,7 @@ AutomationTimeAxisView::cut_copy_clear_o
-       for (PointSelection::iterator i = selection.begin(); i != selection.end(); ++i) {
--              if (&(*i).track != this) {
-+              if ((*i).track != this) {
-                       continue;
-               }
---- ardour-2.0.3/gtk2_ardour/automation_line.cc.orig   2007-05-10 13:30:27.000000000 +0200
-+++ ardour-2.0.3/gtk2_ardour/automation_line.cc        2007-07-15 00:36:48.307644484 +0200
-@@ -1102,7 +1102,7 @@ AutomationLine::set_selected_points (Poi
-       
-       for (PointSelection::iterator r = points.begin(); r != points.end(); ++r) {
-               
--              if (&(*r).track != &trackview) {
-+              if ((*r).track != &trackview) {
-                       continue;
-               }
---- ardour-2.0.3/gtk2_ardour/editor_ops.cc.orig        2007-05-10 13:30:27.000000000 +0200
-+++ ardour-2.0.3/gtk2_ardour/editor_ops.cc     2007-07-16 18:04:44.325467660 +0200
-@@ -2715,7 +2715,7 @@ Editor::cut_copy_points (CutCopyOp op)
- {
-       for (PointSelection::iterator i = selection->points.begin(); i != selection->points.end(); ++i) {
--              AutomationTimeAxisView* atv = dynamic_cast<AutomationTimeAxisView*>(&(*i).track);
-+              AutomationTimeAxisView* atv = dynamic_cast<AutomationTimeAxisView*>((*i).track);
-               if (atv) {
-                       atv->cut_copy_clear_objects (selection->points, op);
-@@ -3082,7 +3082,7 @@ Editor::reset_point_selection ()
-       for (PointSelection::iterator i = selection->points.begin(); i != selection->points.end(); ++i) {
-               
--              AutomationTimeAxisView* atv = dynamic_cast<AutomationTimeAxisView*>(&(*i).track);
-+              AutomationTimeAxisView* atv = dynamic_cast<AutomationTimeAxisView*>((*i).track);
-               
-               if (atv) {
-                       atv->reset_objects (selection->points);
---- ardour-2.0.3/gtk2_ardour/imageframe_view.cc.orig   2007-05-10 13:30:27.000000000 +0200
-+++ ardour-2.0.3/gtk2_ardour/imageframe_view.cc        2007-07-16 19:37:00.088932841 +0200
-@@ -20,6 +20,10 @@
- #include <algorithm>
- #include <cmath>
-+extern "C" {
-+#include <libart_lgpl/art_misc.h>
-+}
-+
- #include <gtkmm.h>
- #include <gtkmm2ext/gtk_ui.h>
diff --git a/ardour-opt.patch b/ardour-opt.patch
deleted file mode 100644 (file)
index 4636fbe..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
---- ardour-0.9beta18/libs/pbd/aclocal.m4.orig  2004-07-06 00:29:18.000000000 +0200
-+++ ardour-0.9beta18/libs/pbd/aclocal.m4       2004-07-09 00:08:45.500025552 +0200
-@@ -866,49 +866,16 @@
- if test "$target_cpu" = "powerpc"; then
-   AC_DEFINE(POWERPC, 1, "Are we running a ppc CPU?")
--  altivecLinux=
--  if test "$?" = "0"; then
--    AC_DEFINE(HAVE_ALTIVEC_LINUX, 1, "Is there Altivec Support ?")
--    if test "$gcc_major_version" = "3"; then
--dnl -mcpu=7450 does not reliably work with gcc 3.*
--      OPT_FLAGS="-D_REENTRANT -O2 -mcpu=7400 -maltivec -mabi=altivec"
--    else
--      OPT_FLAGS="-D_REENTRANT -O3 -mcpu=7400"
--    fi
--  else
--    OPT_FLAGS="-D_REENTRANT -O3 -mcpu=750 -mmultiple"
--  fi
--  OPT_FLAGS="$OPTIM_FLAGS -mhard-float -mpowerpc-gfxopt"
-+  OPT_FLAGS="$CXXFLAGS -D_REENTRANT"
- elif echo $target_cpu | grep "i*86" >/dev/null; then
--  cat /proc/cpuinfo | grep mmx >/dev/null
--  if test $? = 0; then
--    mmx="-mmmx"
--  fi
--  cat /proc/cpuinfo | grep sse >/dev/null
--  if test $? = 0; then
--    sse="-msse -mfpmath=sse"
--  fi
--  cat /proc/cpuinfo | grep 3dnow >/dev/null
--  if test $? = 0; then
--    dreidnow="-m3dnow"
--  fi
-   AC_DEFINE(x86, 1, "Nope its intel")
--  if test "$target_cpu" = "i586"; then
--    OPT_FLAGS="-DREENTRANT -O3 -march=i586 -fomit-frame-pointer -ffast-math -fstrength-reduce -fmove-all-movables"
--  elif test "$target_cpu" = "i686"; then
--    OPT_FLAGS="-D_REENTRANT -O3 -march=i686 -fomit-frame-pointer -ffast-math -fstrength-reduce -fmove-all-movables"
--    if test "$gcc_major_version" = "3"; then
--      OPT_FLAGS="$OPTIM_FLAGS $mmx $sse $dreidnow"
--    fi
--  else
--    OPT_FLAGS="-D_REENTRANT -O3 -fomit-frame-pointer -ffast-math -fstrength-reduce -fmove-all-movables"
--  fi
-+  OPT_FLAGS="$CXXFLAGS -D_REENTRANT -ffast-math -fstrength-reduce -fmove-all-movables"
- fi
- # LARGEFILE_FLAGS="`getconf LFS_CFLAGS`"
- LARGEFILE_FLAGS="-D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE"
--CXXFLAGS="-g -D_REENTRANT $LARGEFILE_FLAGS"
-+CXXFLAGS="$CXXFLAGS -D_REENTRANT $LARGEFILE_FLAGS"
- if test x"$GXX" = xyes ; then
-    CXXFLAGS="$CXXFLAGS -Wall"
- fi
diff --git a/ardour-stdint.patch b/ardour-stdint.patch
deleted file mode 100644 (file)
index 16f99c5..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- ardour-2.1/libs/pbd/shortpath.cc~  2007-10-06 14:07:02.000000000 +0300
-+++ ardour-2.1/libs/pbd/shortpath.cc   2007-10-06 14:07:04.000000000 +0300
-@@ -18,6 +18,7 @@
- */
- #include <pbd/shortpath.h>
-+#include <stdint.h>
- using namespace Glib;
- using namespace std;
index ca4abdf0a3a1288418c23993edcc1362aa025d2b..3ff78624407dc7428c5e46eaa3d2613861a4a9b7 100644 (file)
@@ -3,49 +3,50 @@
 Summary:       Multitrack hard disk recorder
 Summary(pl.UTF-8):     Wielościeżkowy magnetofon nagrywający na twardym dysku
 Name:          ardour
-Version:       2.1
-Release:       0.2
+Version:       5.4.0
+Release:       0.1
 License:       GPL
 Group:         X11/Applications/Sound
-Source0:       http://ardour.org/files/releases/%{name}-%{version}.tar.bz2
-# Source0-md5: 18be414a37b832aae23c068ba9fcf8ab
+Source0:       https://community.ardour.org/srctar/Ardour-%{version}.tar.bz2
+# Source0-md5: ca71c6aa7f804a81539a0c25ea2427a5
 Source1:       %{name}.desktop
-Patch0:                %{name}-c++.patch
-Patch1:                %{name}-opt.patch
-Patch2:                %{name}-stdint.patch
 URL:           http://ardour.org/
 BuildRequires: alsa-lib-devel >= 0.9.0
+BuildRequires: aubio-devel >= 0.4.0
 BuildRequires: boost-devel
-BuildRequires: cairomm-devel
-BuildRequires: fftw3-single-devel >= 3
-BuildRequires: flac-devel
-BuildRequires: gettext-tools
-BuildRequires: glib2-devel >= 1:2.10.1
-BuildRequires: gtk+2-devel >= 2:2.8.1
-BuildRequires: gtkmm-devel >= 2.8.0
-BuildRequires: jack-audio-connection-kit-devel >= 0.103
-BuildRequires: libart_lgpl >= 2.3.16
-BuildRequires: libgnomecanvas-devel >= 2.0
-BuildRequires: libgnomecanvasmm-devel >= 2.12.0
-BuildRequires: liblo-devel
+BuildRequires: cairo-devel >= 1.12.0
+BuildRequires: cairomm-devel >= 1.8.4
+BuildRequires: curl-devel >= 7.0.0
+BuildRequires: dbus-devel
+BuildRequires: fftw3-single-devel
+BuildRequires: flac-devel >= 1.2.1
+BuildRequires: fontconfig-devel
+BuildRequires: glib2-devel >= 1:2.28
+BuildRequires: gtk+2-devel >= 2:2.12.1
+BuildRequires: gtkmm-devel >= 2.8
+BuildRequires: gtkmm-devel >= 2.8
+BuildRequires: jack-audio-connection-kit-devel >= 0.121
+BuildRequires: libarchive-devel >= 3.0.0
+BuildRequires: liblo-devel >= 0.26
 BuildRequires: liblrdf-devel >= 0.4.0
-BuildRequires: libraptor-devel >= 1.4.2
-BuildRequires: libsamplerate-devel >= 0.1.2
+BuildRequires: libogg-devel >= 1.1.2
+BuildRequires: libsamplerate-devel >= 0.1.7
 BuildRequires: libsigc++-devel >= 2.0
-# included libsndfile needs patch (wants FLAC__seekable_stream_decoder_set_read_callback)
-# (in ardour itself only one UI option depends on HAVE_FLAC)
-# internal one used
-#BuildRequires:        libsndfile-devel >= 1.0.0
-BuildRequires: libstdc++-devel
-BuildRequires: libtool
+BuildRequires: libsndfile-devel >= 1.0.18
 BuildRequires: libusb-devel
-BuildRequires: libxml2-devel >= 1:2.6.0
-BuildRequires: libxslt-devel
-BuildRequires: pkgconfig >= 1:0.20
-BuildRequires: python >= 2.3.4
-BuildRequires: scons >= 0.96
-BuildRequires: soundtouch-devel >= 1.3.1
-Requires:      jack-audio-connection-kit-libs >= 0.103
+BuildRequires: libxml2-devel
+BuildRequires: lilv-devel >= 0.21.3
+BuildRequires: lv2-devel >= 1.0.0
+BuildRequires: lv2-devel >= 1.10.0
+BuildRequires: pangomm-devel >= 1.4
+BuildRequires: rubberband-devel
+BuildRequires: serd-devel >= 0.14.0
+BuildRequires: sratom-devel >= 0.2.0
+BuildRequires: suil-devel >= 0.6.0
+BuildRequires: taglib-devel >= 1.6
+BuildRequires: vamp-devel >= 2.1
+BuildRequires: xorg-lib-libX11-devel >= 1.1
+Requires:      jack-audio-connection-kit-libs >= 0.121
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -61,55 +62,40 @@ Obsługuje próbki do 32 bitów, 24+ kanałów do 96kHz, pełną kontrolę
 MMC, niedestruktywny, nieliniowy edytor oraz wtyczki LADSPA.
 
 %prep
-%setup -q
-%patch0 -p1
-# NEEDS UPDATE for scons
-#%patch1 -p1
-%patch2 -p1
+%setup -q -n Ardour-%{version}
 
 %build
-# Make sure we have /proc mounted - it searches for flags from there
-if [ ! -f /proc/cpuinfo ]; then
-       echo "You need to have /proc mounted in order to build this package!"
-       exit 1
-fi
+export CC="%{__cc}"
+export CXX="%{__cxx}"
+export CFLAGS="%{rpmcflags}"
+export CXXFLAGS="%{rpmcxxflags}"
+export LDFLAGS="%{rpmldflags}"
 
-CXX="%{__cxx}" \
-CC="%{__cc}" \
-%scons \
-       PREFIX=%{_prefix} \
-       SYSLIBS=1 \
-%ifarch %{x8664}
-       DIST_TARGET=x86_64
-%else
-%ifarch %{ix86}
-       DIST_TARGET=i386
-%else
-       DIST_TARGET=none
-%endif
-%endif
+./waf configure \
+       --prefix=%{_prefix} \
+       --bindir=%{_bindir} \
+       --configdir=%{_sysconfdir}/etc \
+       --includedir=%{_datadir} \
+       --datadir=%{_datadir} \
+       --libdir=%{_libdir} \
+       --mandir=%{_mandir} \
+       --lv2 \
+       --lv2dir=%{_libdir}/lv2 \
+       --cxx11
 
-%install
-# Make sure we have /proc mounted - it searches for flags from there
-if [ ! -f /proc/cpuinfo ]; then
-       echo "You need to have /proc mounted in order to build this package!"
-       exit 1
-fi
+./waf build -v
 
+%install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
 
-%scons install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       PREFIX=%{_prefix} \
-       GTK=yes
-#      KSI=yes
+#FIXME
 
-install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
-cp -a gtk2_ardour/icons/ardour_icon_48px.png $RPM_BUILD_ROOT%{_pixmapsdir}/ardour.png
+#install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
+#cp -a gtk2_ardour/icons/ardour_icon_48px.png $RPM_BUILD_ROOT%{_pixmapsdir}/ardour.png
 
-# it shouldn't be there
-rm -f $RPM_BUILD_ROOT%{_datadir}/ardour/libardour.{la,a}
+## it shouldn't be there
+#rm -f $RPM_BUILD_ROOT%{_datadir}/ardour/libardour.{la,a}
 
 %find_lang %{name} --all-name
 
This page took 0.14048 seconds and 4 git commands to generate.