]> git.pld-linux.org Git - packages/ardour.git/commitdiff
- updated for 0.9beta9.1
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 11 Feb 2004 07:42:20 +0000 (07:42 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    ardour-opt.patch -> 1.3
    ardour-system-libs.patch -> 1.4

ardour-opt.patch
ardour-system-libs.patch

index 01781c5615eb6d02009b154441cab247e431d167..6ac1d54a5498f91df35591a88c0ef4b02c20004e 100644 (file)
@@ -1,16 +1,27 @@
---- ardour-0.9beta7/gtk_ardour/configure.ac.orig       2003-06-24 05:11:35.000000000 +0200
-+++ ardour-0.9beta7/gtk_ardour/configure.ac    2003-07-15 01:30:51.000000000 +0200
-@@ -37,8 +37,8 @@
-    AC_MSG_ERROR([*** Ardour is written in C++. You don't appear to have a C++ compiler])
+--- ardour-0.9beta9.1/gtk_ardour/configure.ac.orig     2003-11-14 04:08:50.000000000 +0100
++++ ardour-0.9beta9.1/gtk_ardour/configure.ac  2004-02-11 00:56:11.989904752 +0100
+@@ -84,15 +84,18 @@
  fi
  
 -CXXFLAGS="-g -D_REENTRANT"
--OPT_CXXFLAGS="-D_REENTRANT -O3 -march=$target_cpu -fomit-frame-pointer -ffast-math -fstrength-reduce -funroll-loops -fmove-all-movables"
+-CFLAGS="-g -D_REENTRANT"
++# eeh, /proc/cpuinfo is evil in distro builds
++OPT_FLAGS="-D_REENTRANT -fomit-frame-pointer -ffast-math"
 +CXXFLAGS="$CXXFLAGS -D_REENTRANT"
-+OPT_CXXFLAGS="$CXXFLAGS -fomit-frame-pointer -ffast-math -fstrength-reduce -fmove-all-movables"
++CFLAGS="$CFLAGS -D_REENTRANT"
  if test x"$GXX" = xyes ; then
     CXXFLAGS="$CXXFLAGS -Wall"
+    CFLAGS="$CFLAGS -Wall"
  fi
+ if test x"$GXX" = xyes ; then
+-   OPT_CXXFLAGS="$OPT_FLAGS -Wall"
++   OPT_CXXFLAGS="$CXXFLAGS $OPT_FLAGS -Wall"
+ fi
++OPT_FLAGS="$CFLAGS $OPT_FLAGS"
+ AC_ARG_ENABLE(optimize,
+      [  --disable-optimize       avoid optimizations to allow gdb debugging.],
 --- ardour-0.9beta2/ksi_ardour/configure.ac.orig       2003-06-24 05:11:36.000000000 +0200
 +++ ardour-0.9beta2/ksi_ardour/configure.ac    2003-07-15 01:30:39.000000000 +0200
 @@ -32,8 +32,7 @@
  if test x"$GXX" = xyes ; then
     CXXFLAGS="$CXXFLAGS -Wall"
  fi
---- ardour-0.9beta7/libs/ardour/configure.ac.orig      2003-06-27 03:21:32.000000000 +0200
-+++ ardour-0.9beta7/libs/ardour/configure.ac   2003-07-15 01:31:29.000000000 +0200
-@@ -37,8 +37,8 @@
-    AC_MSG_ERROR([*** Ardour is written in C++. You don't appear to have a C++ compiler])
+--- ardour-0.9beta9.1/libs/ardour/configure.ac.orig    2004-01-16 01:47:46.000000000 +0100
++++ ardour-0.9beta9.1/libs/ardour/configure.ac 2004-02-11 00:57:49.568070616 +0100
+@@ -84,12 +84,14 @@
  fi
  
 -CXXFLAGS="-g -D_REENTRANT"
--OPT_CXXFLAGS="-D_REENTRANT -O3 -march=$target_cpu -fomit-frame-pointer -ffast-math -fstrength-reduce -fmove-all-movables"
++# eeh, /proc/cpuinfo is evil in distro builds
++OPT_FLAGS="-D_REENTRANT -fomit-frame-pointer -ffast-math"
 +CXXFLAGS="$CXXFLAGS -D_REENTRANT"
-+OPT_CXXFLAGS="$CXXFLAGS -fomit-frame-pointer -ffast-math -fstrength-reduce -fmove-all-movables"
  if test x"$GXX" = xyes ; then
     CXXFLAGS="$CXXFLAGS -Wall"
  fi
+ if test x"$GXX" = xyes ; then
+-   OPT_CXXFLAGS="$OPT_FLAGS -Wall"
++   OPT_CXXFLAGS="$CXXFLAGS $OPT_FLAGS -Wall"
+ fi
+ AC_ARG_ENABLE(optimize,
 --- ardour-0.9beta2/libs/gtkmmext/configure.ac.orig    2003-06-24 05:11:38.000000000 +0200
 +++ ardour-0.9beta2/libs/gtkmmext/configure.ac 2003-07-15 01:33:24.000000000 +0200
 @@ -37,10 +37,10 @@
index a5dde3a8d3b089a1244f59176dffa12640d2730a..6a855084e36522b576ed2e71a98864511a4fdfe5 100644 (file)
  if test x$WITH_VST_WIN != x ; then
 --- ardour-0.9beta2/gtk_ardour/editor_audiotrack.cc.orig       2003-06-24 05:11:35.000000000 +0200
 +++ ardour-0.9beta2/gtk_ardour/editor_audiotrack.cc    2003-07-15 00:57:21.000000000 +0200
-@@ -1,11 +1,12 @@
+@@ -1,12 +1,13 @@
 -#include <ardour/location.h>
 -#include <ardour/diskstream.h>
 -
  #include "editor.h"
+ #include "editing.h"
  #include "audio_time_axis.h"
  #include "regionview.h"
  #include "selection.h"
This page took 0.080361 seconds and 4 git commands to generate.