]> git.pld-linux.org Git - packages/aravis.git/blob - aravis.spec
- new
[packages/aravis.git] / aravis.spec
1 #
2 # Conditional build:
3 %bcond_without  gui             # Viewer application
4 %bcond_without  gstreamer       # alias to disable both GStreamer plugins
5 %bcond_without  gstreamer1      # GStreamer 1 plugin
6 %bcond_without  gstreamer0_10   # GStreamer 0.10 plugin
7 #
8 %if %{without gstreamer}
9 %undefine       with_gstreamer1
10 %undefine       with_gstreamer0_10
11 %endif
12 Summary:        Aravis digital video camera acquisition library
13 Summary(pl.UTF-8):      Aravis - biblioteka do pobierania obrazu z kamer cyfrowych
14 Name:           aravis
15 Version:        0.3.7
16 Release:        1
17 License:        LGPL v2+
18 Group:          Libraries
19 Source0:        http://ftp.gnome.org/pub/GNOME/sources/aravis/0.3/%{name}-%{version}.tar.xz
20 # Source0-md5:  80b46bbdf270d05f6e3a9cfa5a63f904
21 URL:            https://wiki.gnome.org/Projects/Aravis
22 BuildRequires:  appstream-glib-devel
23 BuildRequires:  gettext-tools
24 BuildRequires:  glib2-devel >= 1:2.26
25 BuildRequires:  gobject-introspection-devel >= 0.10.0
26 %if %{with gstreamer1} || %{with gui}
27 BuildRequires:  gstreamer-devel >= 1.0
28 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
29 %endif
30 %if %{with gstreamer0_10}
31 BuildRequires:  gstreamer0.10-devel >= 0.10
32 BuildRequires:  gstreamer0.10-plugins-base-devel >= 0.10
33 %endif
34 %{?with_gui:BuildRequires:      gtk+3-devel >= 3.14.0}
35 BuildRequires:  gtk-doc >= 1.14
36 BuildRequires:  intltool >= 0.31.2
37 %{?with_gui:BuildRequires:      libnotify-devel}
38 BuildRequires:  libxml2-devel >= 2.0
39 BuildRequires:  pkgconfig >= 1:0.14
40 BuildRequires:  rpmbuild(macros) >= 1.592
41 BuildRequires:  tar >= 1:1.22
42 BuildRequires:  xz
43 BuildRequires:  zlib-devel
44 Requires:       glib2 >= 1:2.32.0
45 Requires:       gtk+3 >= 3.14.0
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Aravis is a GLib/GObject based library for video acquisition using
50 Genicam cameras. It currently only implements an Ethernet camera
51 protocol used for industrial cameras.
52
53 %description -l pl.UTF-8
54 Aravis to oparta na GLib/GObject biblioteka do pobierania obrazu przy
55 użyciu kamer Genicam. Obecnie ma zaimplementowany tylko protokół
56 kamer ethernetowych używany przez kamery przemysłowe.
57
58 %package viewer
59 Summary:        Simple viewer of video stream acquired using Aravis
60 Summary(pl.UTF-8):      Prosta przeglądarka strumienia obrazu pobranego przy użyciu biblioteki Aravis
61 Group:          X11/Applications/Graphics
62 Requires:       %{name} = %{version}-%{release}
63 Requires(post,postun):  gtk-update-icon-cache
64 Requires:       hicolor-icon-theme
65
66 %description viewer
67 Aravis Viewer is a simple viewer used to display video streams from
68 GENICAM-based Ethernet industrial cameras.
69
70 %description viewer -l pl.UTF-8
71 Aravis Viewer to prosta przeglądarka do wyświetlania strumieni obrazu
72 pobranych z ethernetowych kamer przemysłowych opartych na GENICAM.
73
74 %package devel
75 Summary:        Header files for Aravis library
76 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Aravis
77 Group:          Development/Libraries
78 Requires:       %{name} = %{version}-%{release}
79 Requires:       glib2-devel >= 4.0
80 Requires:       libxml2-devel >= 2.0
81 Requires:       zlib-devel
82
83 %description devel
84 Header files for Aravis library.
85
86 %description devel -l pl.UTF-8
87 Pliki nagłówkowe biblioteki Aravis.
88
89 %package static
90 Summary:        Static Aravis library
91 Summary(pl.UTF-8):      Statyczna biblioteka Aravis
92 Group:          Development/Libraries
93 Requires:       %{name}-devel = %{version}-%{release}
94
95 %description static
96 Static Aravis library.
97
98 %description static -l pl.UTF-8
99 Statyczna biblioteka Aravis.
100
101 %package apidocs
102 Summary:        API documentation for Aravis library
103 Summary(pl.UTF-8):      Dokumentacja API biblioteki Aravis
104 Group:          Documentation
105 Requires:       gtk-doc-common
106
107 %description apidocs
108 API documentation for Aravis library.
109
110 %description apidocs -l pl.UTF-8
111 Dokumentacja API biblioteki Aravis.
112
113 %package -n gstreamer0.10-aravis
114 Summary:        GStreamer 0.10 plugin for Aravis digital video camera acquisition library
115 Summary(pl.UTF-8):      Wtyczka GStreamera 0.10 do biblioteki pobierania obrazu z kamer cyfrowych Aravis
116 Group:          Libraries
117 Requires:       %{name} = %{version}-%{release}
118 Requires:       gstreamer0.10 >= 0.10
119 Requires:       gstreamer0.10-plugins-base >= 0.10
120
121 %description -n gstreamer0.10-aravis
122 GStreamer 0.10 plugin for Aravis digital video camera acquisition
123 library.
124
125 %description -n gstreamer0.10-aravis -l pl.UTF-8
126 Wtyczka GStreamera 0.10 do biblioteki pobierania obrazu z kamer
127 cyfrowych Aravis.
128
129 %package -n gstreamer-aravis
130 Summary:        GStreamer 1 plugin for Aravis digital video camera acquisition library
131 Summary(pl.UTF-8):      Wtyczka GStreamera 1 do biblioteki pobierania obrazu z kamer cyfrowych Aravis
132 Group:          Libraries
133 Requires:       %{name} = %{version}-%{release}
134 Requires:       gstreamer >= 1.0
135 Requires:       gstreamer-plugins-base >= 1.0
136
137 %description -n gstreamer-aravis
138 GStreamer 1 plugin for Aravis digital video camera acquisition
139 library.
140
141 %description -n gstreamer-aravis -l pl.UTF-8
142 Wtyczka GStreamera 1 do biblioteki pobierania obrazu z kamer cyfrowych
143 Aravis.
144
145 %prep
146 %setup -q
147
148 %build
149 %configure \
150         --disable-silent-rules \
151         %{!?with_gstreamer1:--disable-gst-plugin} \
152         %{!?with_gstreamer0_10:--disable-gst-0.10-plugin} \
153         %{!?with_gui:--disable-viewer} \
154         --with-html-dir=%{_gtkdocdir}
155
156 %{__make}
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160
161 %{__make} install \
162         DESTDIR=$RPM_BUILD_ROOT
163
164 # loadable modules
165 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-*/libgstaravis-0.4.la
166 # obsoleted by pkg-config
167 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libaravis-0.4.la
168 # packaged as %doc
169 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
170
171 %find_lang %{name}-0.4
172
173 %clean
174 rm -rf $RPM_BUILD_ROOT
175
176 %post   viewer
177 %update_icon_cache hicolor
178
179 %postun viewer
180 %update_icon_cache hicolor
181
182 %files -f %{name}-0.4.lang
183 %defattr(644,root,root,755)
184 %doc AUTHORS NEWS README TODO
185 %attr(755,root,root) %{_bindir}/arv-fake-gv-camera-0.4
186 %attr(755,root,root) %{_bindir}/arv-tool-0.4
187 %attr(755,root,root) %{_libdir}/libaravis-0.4.so.*.*.*
188 %attr(755,root,root) %ghost %{_libdir}/libaravis-0.4.so.0
189 %{_libdir}/girepository-1.0/Aravis-0.4.typelib
190
191 %if %{with gui}
192 %files viewer
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_bindir}/arv-viewer
195 %{_datadir}/aravis-0.4
196 %{_datadir}/appdata/arv-viewer.appdata.xml
197 %{_desktopdir}/arv-viewer.desktop
198 %{_iconsdir}/hicolor/*/apps/aravis.png
199 %endif
200
201 %files devel
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_libdir}/libaravis-0.4.so
204 %{_includedir}/aravis-0.4
205 %{_datadir}/gir-1.0/Aravis-0.4.gir
206 %{_pkgconfigdir}/aravis-0.4.pc
207
208 %files static
209 %defattr(644,root,root,755)
210 %{_libdir}/libaravis-0.4.a
211
212 %files apidocs
213 %defattr(644,root,root,755)
214 %{_gtkdocdir}/aravis-0.4
215
216 %if %{with gstreamer0_10}
217 %files -n gstreamer0.10-aravis
218 %defattr(644,root,root,755)
219 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libgstaravis-0.4.so
220 %endif
221
222 %if %{with gstreamer1}
223 %files -n gstreamer-aravis
224 %defattr(644,root,root,755)
225 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libgstaravis-0.4.so
226 %endif
This page took 0.07867 seconds and 4 git commands to generate.