]> git.pld-linux.org Git - packages/aravis.git/blob - aravis.spec
- updated to 0.8.4
[packages/aravis.git] / aravis.spec
1 #
2 # Conditional build:
3 %bcond_without  gui             # Viewer application
4 %bcond_without  gstreamer       # GStreamer plugin
5
6 Summary:        Aravis digital video camera acquisition library
7 Summary(pl.UTF-8):      Aravis - biblioteka do pobierania obrazu z kamer cyfrowych
8 Name:           aravis
9 Version:        0.8.4
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        https://download.gnome.org/sources/aravis/0.8/%{name}-%{version}.tar.xz
14 # Source0-md5:  41bcb4839529e8e9a471a28809914688
15 URL:            https://wiki.gnome.org/Projects/Aravis
16 BuildRequires:  appstream-glib
17 BuildRequires:  audit-libs-devel
18 BuildRequires:  gettext-tools
19 BuildRequires:  glib2-devel >= 1:2.44
20 BuildRequires:  gobject-introspection-devel >= 0.10.0
21 %if %{with gstreamer} || %{with gui}
22 BuildRequires:  gstreamer-devel >= 1.0
23 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
24 %endif
25 %{?with_gui:BuildRequires:      gtk+3-devel >= 3.14.0}
26 BuildRequires:  gtk-doc >= 1.14
27 %{?with_gui:BuildRequires:      libnotify-devel}
28 BuildRequires:  libusb-devel >= 1.0
29 BuildRequires:  libxml2-devel >= 2.0
30 BuildRequires:  libxslt-progs
31 BuildRequires:  meson >= 0.47.0
32 BuildRequires:  ninja >= 1.5
33 BuildRequires:  pkgconfig >= 1:0.14
34 BuildRequires:  rpmbuild(macros) >= 1.752
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xz
37 BuildRequires:  zlib-devel
38 Requires:       glib2 >= 1:2.44
39 Requires:       gtk+3 >= 3.14.0
40 Obsoletes:      gstreamer0.10-aravis < 0.7
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Aravis is a GLib/GObject based library for video acquisition using
45 Genicam cameras. It currently only implements an Ethernet camera
46 protocol used for industrial cameras.
47
48 %description -l pl.UTF-8
49 Aravis to oparta na GLib/GObject biblioteka do pobierania obrazu przy
50 użyciu kamer Genicam. Obecnie ma zaimplementowany tylko protokół kamer
51 ethernetowych używany przez kamery przemysłowe.
52
53 %package viewer
54 Summary:        Simple viewer of video stream acquired using Aravis
55 Summary(pl.UTF-8):      Prosta przeglądarka strumienia obrazu pobranego przy użyciu biblioteki Aravis
56 Group:          X11/Applications/Graphics
57 Requires:       %{name} = %{version}-%{release}
58 Requires(post,postun):  gtk-update-icon-cache
59 Requires:       hicolor-icon-theme
60
61 %description viewer
62 Aravis Viewer is a simple viewer used to display video streams from
63 GENICAM-based Ethernet industrial cameras.
64
65 %description viewer -l pl.UTF-8
66 Aravis Viewer to prosta przeglądarka do wyświetlania strumieni obrazu
67 pobranych z ethernetowych kamer przemysłowych opartych na GENICAM.
68
69 %package devel
70 Summary:        Header files for Aravis library
71 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Aravis
72 Group:          Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       glib2-devel >= 1:2.44
75 Requires:       libxml2-devel >= 2.0
76 Requires:       zlib-devel
77
78 %description devel
79 Header files for Aravis library.
80
81 %description devel -l pl.UTF-8
82 Pliki nagłówkowe biblioteki Aravis.
83
84 %package static
85 Summary:        Static Aravis library
86 Summary(pl.UTF-8):      Statyczna biblioteka Aravis
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89
90 %description static
91 Static Aravis library.
92
93 %description static -l pl.UTF-8
94 Statyczna biblioteka Aravis.
95
96 %package apidocs
97 Summary:        API documentation for Aravis library
98 Summary(pl.UTF-8):      Dokumentacja API biblioteki Aravis
99 Group:          Documentation
100 Requires:       gtk-doc-common
101 %{?noarchpackage}
102
103 %description apidocs
104 API documentation for Aravis library.
105
106 %description apidocs -l pl.UTF-8
107 Dokumentacja API biblioteki Aravis.
108
109 %package -n gstreamer-aravis
110 Summary:        GStreamer plugin for Aravis digital video camera acquisition library
111 Summary(pl.UTF-8):      Wtyczka GStreamera do biblioteki pobierania obrazu z kamer cyfrowych Aravis
112 Group:          Libraries
113 Requires:       %{name} = %{version}-%{release}
114 Requires:       gstreamer >= 1.0
115 Requires:       gstreamer-plugins-base >= 1.0
116
117 %description -n gstreamer-aravis
118 GStreamer plugin for Aravis digital video camera acquisition
119 library.
120
121 %description -n gstreamer-aravis -l pl.UTF-8
122 Wtyczka GStreamera do biblioteki pobierania obrazu z kamer cyfrowych
123 Aravis.
124
125 %prep
126 %setup -q
127
128 %build
129 %meson build \
130         %{!?with_gstreamer:-Dgst-plugin=disabled} \
131         %{!?with_gui:-Dviewer=disabled}
132
133 %ninja_build -C build
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 %ninja_install -C build
139
140 %find_lang %{name}-0.8
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %post   viewer
149 %update_icon_cache hicolor
150
151 %postun viewer
152 %update_icon_cache hicolor
153
154 %files -f %{name}-0.8.lang
155 %defattr(644,root,root,755)
156 %doc AUTHORS NEWS.md README.md
157 %attr(755,root,root) %{_bindir}/arv-fake-gv-camera-0.8
158 %attr(755,root,root) %{_bindir}/arv-tool-0.8
159 %attr(755,root,root) %{_libdir}/libaravis-0.8.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libaravis-0.8.so.0
161 %{_libdir}/girepository-1.0/Aravis-0.8.typelib
162 %{_mandir}/man1/arv-tool-0.8.1*
163
164 %if %{with gui}
165 %files viewer
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_bindir}/arv-viewer-0.8
168 %{_datadir}/metainfo/arv-viewer-0.8.appdata.xml
169 %{_desktopdir}/arv-viewer-0.8.desktop
170 %{_iconsdir}/hicolor/*x*/apps/aravis-0.8.png
171 %{_mandir}/man1/arv-viewer-0.8.1*
172 %endif
173
174 %files devel
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_libdir}/libaravis-0.8.so
177 %{_includedir}/aravis-0.8
178 %{_datadir}/gir-1.0/Aravis-0.8.gir
179 %{_pkgconfigdir}/aravis-0.8.pc
180
181 %files static
182 %defattr(644,root,root,755)
183 %{_libdir}/libaravis-0.8.a
184
185 %files apidocs
186 %defattr(644,root,root,755)
187 %{_gtkdocdir}/aravis-0.8
188
189 %if %{with gstreamer}
190 %files -n gstreamer-aravis
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libgstaravis.0.8.so
193 %endif
This page took 0.076523 seconds and 4 git commands to generate.