]> git.pld-linux.org Git - packages/aravis.git/blob - aravis.spec
- updated to 0.8.0
[packages/aravis.git] / aravis.spec
1 #
2 # Conditional build:
3 %bcond_without  gui             # Viewer application
4 %bcond_without  gstreamer       # GStreamer plugin
5
6 Summary:        Aravis digital video camera acquisition library
7 Summary(pl.UTF-8):      Aravis - biblioteka do pobierania obrazu z kamer cyfrowych
8 Name:           aravis
9 Version:        0.8.0
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/aravis/0.8/%{name}-%{version}.tar.xz
14 # Source0-md5:  8e2f66fbd0cc715cb5794be592063c37
15 Patch0:         %{name}-format.patch
16 URL:            https://wiki.gnome.org/Projects/Aravis
17 BuildRequires:  appstream-glib
18 BuildRequires:  audit-libs-devel
19 BuildRequires:  gettext-tools
20 BuildRequires:  glib2-devel >= 1:2.44
21 BuildRequires:  gobject-introspection-devel >= 0.10.0
22 %if %{with gstreamer} || %{with gui}
23 BuildRequires:  gstreamer-devel >= 1.0
24 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
25 %endif
26 %{?with_gui:BuildRequires:      gtk+3-devel >= 3.14.0}
27 BuildRequires:  gtk-doc >= 1.14
28 %{?with_gui:BuildRequires:      libnotify-devel}
29 BuildRequires:  libusb-devel >= 1.0
30 BuildRequires:  libxml2-devel >= 2.0
31 BuildRequires:  libxslt-progs
32 BuildRequires:  meson >= 0.47.0
33 BuildRequires:  ninja >= 1.5
34 BuildRequires:  pkgconfig >= 1:0.14
35 BuildRequires:  rpmbuild(macros) >= 1.736
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  xz
38 BuildRequires:  zlib-devel
39 Requires:       glib2 >= 1:2.44
40 Requires:       gtk+3 >= 3.14.0
41 Obsoletes:      gstreamer0.10-aravis < 0.7
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Aravis is a GLib/GObject based library for video acquisition using
46 Genicam cameras. It currently only implements an Ethernet camera
47 protocol used for industrial cameras.
48
49 %description -l pl.UTF-8
50 Aravis to oparta na GLib/GObject biblioteka do pobierania obrazu przy
51 użyciu kamer Genicam. Obecnie ma zaimplementowany tylko protokół kamer
52 ethernetowych używany przez kamery przemysłowe.
53
54 %package viewer
55 Summary:        Simple viewer of video stream acquired using Aravis
56 Summary(pl.UTF-8):      Prosta przeglądarka strumienia obrazu pobranego przy użyciu biblioteki Aravis
57 Group:          X11/Applications/Graphics
58 Requires:       %{name} = %{version}-%{release}
59 Requires(post,postun):  gtk-update-icon-cache
60 Requires:       hicolor-icon-theme
61
62 %description viewer
63 Aravis Viewer is a simple viewer used to display video streams from
64 GENICAM-based Ethernet industrial cameras.
65
66 %description viewer -l pl.UTF-8
67 Aravis Viewer to prosta przeglądarka do wyświetlania strumieni obrazu
68 pobranych z ethernetowych kamer przemysłowych opartych na GENICAM.
69
70 %package devel
71 Summary:        Header files for Aravis library
72 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Aravis
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       glib2-devel >= 1:2.44
76 Requires:       libxml2-devel >= 2.0
77 Requires:       zlib-devel
78
79 %description devel
80 Header files for Aravis library.
81
82 %description devel -l pl.UTF-8
83 Pliki nagłówkowe biblioteki Aravis.
84
85 %package static
86 Summary:        Static Aravis library
87 Summary(pl.UTF-8):      Statyczna biblioteka Aravis
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90
91 %description static
92 Static Aravis library.
93
94 %description static -l pl.UTF-8
95 Statyczna biblioteka Aravis.
96
97 %package apidocs
98 Summary:        API documentation for Aravis library
99 Summary(pl.UTF-8):      Dokumentacja API biblioteki Aravis
100 Group:          Documentation
101 Requires:       gtk-doc-common
102 %if "%{_rpmversion}" >= "4.6"
103 BuildArch:      noarch
104 %endif
105
106 %description apidocs
107 API documentation for Aravis library.
108
109 %description apidocs -l pl.UTF-8
110 Dokumentacja API biblioteki Aravis.
111
112 %package -n gstreamer-aravis
113 Summary:        GStreamer plugin for Aravis digital video camera acquisition library
114 Summary(pl.UTF-8):      Wtyczka GStreamera do biblioteki pobierania obrazu z kamer cyfrowych Aravis
115 Group:          Libraries
116 Requires:       %{name} = %{version}-%{release}
117 Requires:       gstreamer >= 1.0
118 Requires:       gstreamer-plugins-base >= 1.0
119
120 %description -n gstreamer-aravis
121 GStreamer plugin for Aravis digital video camera acquisition
122 library.
123
124 %description -n gstreamer-aravis -l pl.UTF-8
125 Wtyczka GStreamera do biblioteki pobierania obrazu z kamer cyfrowych
126 Aravis.
127
128 %prep
129 %setup -q
130 %patch0 -p1
131
132 %build
133 %meson build \
134         %{!?with_gstreamer:-Dgst-plugin=disabled} \
135         %{!?with_gui:-Dviewer=disabled}
136
137 %ninja_build -C build
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141
142 %ninja_install -C build
143
144 %find_lang %{name}-0.8
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   -p /sbin/ldconfig
150 %postun -p /sbin/ldconfig
151
152 %post   viewer
153 %update_icon_cache hicolor
154
155 %postun viewer
156 %update_icon_cache hicolor
157
158 %files -f %{name}-0.8.lang
159 %defattr(644,root,root,755)
160 %doc AUTHORS NEWS.md README.md
161 %attr(755,root,root) %{_bindir}/arv-fake-gv-camera-0.8
162 %attr(755,root,root) %{_bindir}/arv-tool-0.8
163 %attr(755,root,root) %{_libdir}/libaravis-0.8.so.*.*.*
164 %attr(755,root,root) %ghost %{_libdir}/libaravis-0.8.so.0
165 %{_libdir}/girepository-1.0/Aravis-0.8.typelib
166 %{_mandir}/man1/arv-tool-0.8.1*
167
168 %if %{with gui}
169 %files viewer
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_bindir}/arv-viewer-0.8
172 %{_datadir}/aravis-0.8
173 %{_datadir}/metainfo/arv-viewer-0.8.appdata.xml
174 %{_desktopdir}/arv-viewer-0.8.desktop
175 %{_iconsdir}/hicolor/*x*/apps/aravis-0.8.png
176 %{_mandir}/man1/arv-viewer-0.8.1*
177 %endif
178
179 %files devel
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_libdir}/libaravis-0.8.so
182 %{_includedir}/aravis-0.8
183 %{_datadir}/gir-1.0/Aravis-0.8.gir
184 %{_pkgconfigdir}/aravis-0.8.pc
185
186 %files static
187 %defattr(644,root,root,755)
188 %{_libdir}/libaravis-0.8.a
189
190 %files apidocs
191 %defattr(644,root,root,755)
192 %{_gtkdocdir}/aravis-0.8
193
194 %if %{with gstreamer}
195 %files -n gstreamer-aravis
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libgstaravis.0.8.so
198 %endif
This page took 0.076979 seconds and 4 git commands to generate.