]> git.pld-linux.org Git - packages/aravis.git/blob - aravis.spec
noarch apidocs
[packages/aravis.git] / aravis.spec
1 #
2 # Conditional build:
3 %bcond_without  gui             # Viewer application
4 %bcond_without  gstreamer       # alias to disable both GStreamer plugins
5 %bcond_without  gstreamer1      # GStreamer 1 plugin
6 %bcond_without  gstreamer0_10   # GStreamer 0.10 plugin
7
8 %if %{without gstreamer}
9 %undefine       with_gstreamer1
10 %undefine       with_gstreamer0_10
11 %endif
12 Summary:        Aravis digital video camera acquisition library
13 Summary(pl.UTF-8):      Aravis - biblioteka do pobierania obrazu z kamer cyfrowych
14 Name:           aravis
15 Version:        0.3.8
16 Release:        2
17 License:        LGPL v2+
18 Group:          Libraries
19 Source0:        http://ftp.gnome.org/pub/GNOME/sources/aravis/0.3/%{name}-%{version}.tar.xz
20 # Source0-md5:  a09325d614fa4ffa9d7227489fb89a25
21 URL:            https://wiki.gnome.org/Projects/Aravis
22 BuildRequires:  appstream-glib-devel
23 BuildRequires:  gettext-tools
24 BuildRequires:  glib2-devel >= 1:2.26
25 BuildRequires:  gobject-introspection-devel >= 0.10.0
26 %if %{with gstreamer1} || %{with gui}
27 BuildRequires:  gstreamer-devel >= 1.0
28 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
29 %endif
30 %if %{with gstreamer0_10}
31 BuildRequires:  gstreamer0.10-devel >= 0.10
32 BuildRequires:  gstreamer0.10-plugins-base-devel >= 0.10
33 %endif
34 %{?with_gui:BuildRequires:      gtk+3-devel >= 3.14.0}
35 BuildRequires:  gtk-doc >= 1.14
36 BuildRequires:  intltool >= 0.31.2
37 %{?with_gui:BuildRequires:      libnotify-devel}
38 BuildRequires:  libxml2-devel >= 2.0
39 BuildRequires:  pkgconfig >= 1:0.14
40 BuildRequires:  rpmbuild(macros) >= 1.592
41 BuildRequires:  tar >= 1:1.22
42 BuildRequires:  xz
43 BuildRequires:  zlib-devel
44 Requires:       glib2 >= 1:2.32.0
45 Requires:       gtk+3 >= 3.14.0
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Aravis is a GLib/GObject based library for video acquisition using
50 Genicam cameras. It currently only implements an Ethernet camera
51 protocol used for industrial cameras.
52
53 %description -l pl.UTF-8
54 Aravis to oparta na GLib/GObject biblioteka do pobierania obrazu przy
55 użyciu kamer Genicam. Obecnie ma zaimplementowany tylko protokół kamer
56 ethernetowych używany przez kamery przemysłowe.
57
58 %package viewer
59 Summary:        Simple viewer of video stream acquired using Aravis
60 Summary(pl.UTF-8):      Prosta przeglądarka strumienia obrazu pobranego przy użyciu biblioteki Aravis
61 Group:          X11/Applications/Graphics
62 Requires:       %{name} = %{version}-%{release}
63 Requires(post,postun):  gtk-update-icon-cache
64 Requires:       hicolor-icon-theme
65
66 %description viewer
67 Aravis Viewer is a simple viewer used to display video streams from
68 GENICAM-based Ethernet industrial cameras.
69
70 %description viewer -l pl.UTF-8
71 Aravis Viewer to prosta przeglądarka do wyświetlania strumieni obrazu
72 pobranych z ethernetowych kamer przemysłowych opartych na GENICAM.
73
74 %package devel
75 Summary:        Header files for Aravis library
76 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Aravis
77 Group:          Development/Libraries
78 Requires:       %{name} = %{version}-%{release}
79 Requires:       glib2-devel >= 4.0
80 Requires:       libxml2-devel >= 2.0
81 Requires:       zlib-devel
82
83 %description devel
84 Header files for Aravis library.
85
86 %description devel -l pl.UTF-8
87 Pliki nagłówkowe biblioteki Aravis.
88
89 %package static
90 Summary:        Static Aravis library
91 Summary(pl.UTF-8):      Statyczna biblioteka Aravis
92 Group:          Development/Libraries
93 Requires:       %{name}-devel = %{version}-%{release}
94
95 %description static
96 Static Aravis library.
97
98 %description static -l pl.UTF-8
99 Statyczna biblioteka Aravis.
100
101 %package apidocs
102 Summary:        API documentation for Aravis library
103 Summary(pl.UTF-8):      Dokumentacja API biblioteki Aravis
104 Group:          Documentation
105 Requires:       gtk-doc-common
106 %if "%{_rpmversion}" >= "5"
107 BuildArch:      noarch
108 %endif
109
110 %description apidocs
111 API documentation for Aravis library.
112
113 %description apidocs -l pl.UTF-8
114 Dokumentacja API biblioteki Aravis.
115
116 %package -n gstreamer0.10-aravis
117 Summary:        GStreamer 0.10 plugin for Aravis digital video camera acquisition library
118 Summary(pl.UTF-8):      Wtyczka GStreamera 0.10 do biblioteki pobierania obrazu z kamer cyfrowych Aravis
119 Group:          Libraries
120 Requires:       %{name} = %{version}-%{release}
121 Requires:       gstreamer0.10 >= 0.10
122 Requires:       gstreamer0.10-plugins-base >= 0.10
123
124 %description -n gstreamer0.10-aravis
125 GStreamer 0.10 plugin for Aravis digital video camera acquisition
126 library.
127
128 %description -n gstreamer0.10-aravis -l pl.UTF-8
129 Wtyczka GStreamera 0.10 do biblioteki pobierania obrazu z kamer
130 cyfrowych Aravis.
131
132 %package -n gstreamer-aravis
133 Summary:        GStreamer 1 plugin for Aravis digital video camera acquisition library
134 Summary(pl.UTF-8):      Wtyczka GStreamera 1 do biblioteki pobierania obrazu z kamer cyfrowych Aravis
135 Group:          Libraries
136 Requires:       %{name} = %{version}-%{release}
137 Requires:       gstreamer >= 1.0
138 Requires:       gstreamer-plugins-base >= 1.0
139
140 %description -n gstreamer-aravis
141 GStreamer 1 plugin for Aravis digital video camera acquisition
142 library.
143
144 %description -n gstreamer-aravis -l pl.UTF-8
145 Wtyczka GStreamera 1 do biblioteki pobierania obrazu z kamer cyfrowych
146 Aravis.
147
148 %prep
149 %setup -q
150
151 %build
152 %configure \
153         --disable-silent-rules \
154         %{!?with_gstreamer1:--disable-gst-plugin} \
155         %{!?with_gstreamer0_10:--disable-gst-0.10-plugin} \
156         %{!?with_gui:--disable-viewer} \
157         --with-html-dir=%{_gtkdocdir}
158
159 %{__make}
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163
164 %{__make} install \
165         DESTDIR=$RPM_BUILD_ROOT
166
167 # loadable modules
168 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-*/libgstaravis-0.4.la
169 # obsoleted by pkg-config
170 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libaravis-0.4.la
171 # packaged as %doc
172 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
173
174 %find_lang %{name}-0.4
175
176 %clean
177 rm -rf $RPM_BUILD_ROOT
178
179 %post   -p /sbin/ldconfig
180 %postun -p /sbin/ldconfig
181
182 %post   viewer
183 %update_icon_cache hicolor
184
185 %postun viewer
186 %update_icon_cache hicolor
187
188 %files -f %{name}-0.4.lang
189 %defattr(644,root,root,755)
190 %doc AUTHORS NEWS README TODO
191 %attr(755,root,root) %{_bindir}/arv-fake-gv-camera-0.4
192 %attr(755,root,root) %{_bindir}/arv-tool-0.4
193 %attr(755,root,root) %{_libdir}/libaravis-0.4.so.*.*.*
194 %attr(755,root,root) %ghost %{_libdir}/libaravis-0.4.so.0
195 %{_libdir}/girepository-1.0/Aravis-0.4.typelib
196
197 %if %{with gui}
198 %files viewer
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_bindir}/arv-viewer
201 %{_datadir}/aravis-0.4
202 %{_datadir}/appdata/arv-viewer.appdata.xml
203 %{_desktopdir}/arv-viewer.desktop
204 %{_iconsdir}/hicolor/*/apps/aravis.png
205 %endif
206
207 %files devel
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_libdir}/libaravis-0.4.so
210 %{_includedir}/aravis-0.4
211 %{_datadir}/gir-1.0/Aravis-0.4.gir
212 %{_pkgconfigdir}/aravis-0.4.pc
213
214 %files static
215 %defattr(644,root,root,755)
216 %{_libdir}/libaravis-0.4.a
217
218 %files apidocs
219 %defattr(644,root,root,755)
220 %{_gtkdocdir}/aravis-0.4
221
222 %if %{with gstreamer0_10}
223 %files -n gstreamer0.10-aravis
224 %defattr(644,root,root,755)
225 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libgstaravis-0.4.so
226 %endif
227
228 %if %{with gstreamer1}
229 %files -n gstreamer-aravis
230 %defattr(644,root,root,755)
231 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libgstaravis-0.4.so
232 %endif
This page took 0.081243 seconds and 3 git commands to generate.