]> git.pld-linux.org Git - packages/aravis.git/blob - aravis.spec
- updated to 0.8.9
[packages/aravis.git] / aravis.spec
1 #
2 # Conditional build:
3 %bcond_without  gui             # Viewer application
4 %bcond_without  gstreamer       # GStreamer plugin
5
6 Summary:        Aravis digital video camera acquisition library
7 Summary(pl.UTF-8):      Aravis - biblioteka do pobierania obrazu z kamer cyfrowych
8 Name:           aravis
9 Version:        0.8.9
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        https://download.gnome.org/sources/aravis/0.8/%{name}-%{version}.tar.xz
14 # Source0-md5:  7de71e6206634e92b2bfbdcfa2ff73e8
15 URL:            https://wiki.gnome.org/Projects/Aravis
16 BuildRequires:  appstream-glib
17 BuildRequires:  audit-libs-devel
18 BuildRequires:  gettext-tools
19 BuildRequires:  glib2-devel >= 1:2.44
20 BuildRequires:  gobject-introspection-devel >= 0.10.0
21 %if %{with gstreamer} || %{with gui}
22 BuildRequires:  gstreamer-devel >= 1.0
23 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
24 %endif
25 %{?with_gui:BuildRequires:      gtk+3-devel >= 3.14.0}
26 BuildRequires:  gtk-doc >= 1.14
27 %{?with_gui:BuildRequires:      libnotify-devel}
28 BuildRequires:  libusb-devel >= 1.0
29 BuildRequires:  libxml2-devel >= 2.0
30 BuildRequires:  libxslt-progs
31 BuildRequires:  meson >= 0.47.0
32 BuildRequires:  ninja >= 1.5
33 BuildRequires:  pkgconfig >= 1:0.14
34 BuildRequires:  rpm-build >= 4.6
35 BuildRequires:  rpmbuild(macros) >= 1.752
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  xz
38 BuildRequires:  zlib-devel
39 Requires:       glib2 >= 1:2.44
40 Requires:       gtk+3 >= 3.14.0
41 Obsoletes:      gstreamer0.10-aravis < 0.7
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Aravis is a GLib/GObject based library for video acquisition using
46 Genicam cameras. It currently only implements an Ethernet camera
47 protocol used for industrial cameras.
48
49 %description -l pl.UTF-8
50 Aravis to oparta na GLib/GObject biblioteka do pobierania obrazu przy
51 użyciu kamer Genicam. Obecnie ma zaimplementowany tylko protokół kamer
52 ethernetowych używany przez kamery przemysłowe.
53
54 %package viewer
55 Summary:        Simple viewer of video stream acquired using Aravis
56 Summary(pl.UTF-8):      Prosta przeglądarka strumienia obrazu pobranego przy użyciu biblioteki Aravis
57 Group:          X11/Applications/Graphics
58 Requires:       %{name} = %{version}-%{release}
59 Requires(post,postun):  gtk-update-icon-cache
60 Requires:       hicolor-icon-theme
61
62 %description viewer
63 Aravis Viewer is a simple viewer used to display video streams from
64 GENICAM-based Ethernet industrial cameras.
65
66 %description viewer -l pl.UTF-8
67 Aravis Viewer to prosta przeglądarka do wyświetlania strumieni obrazu
68 pobranych z ethernetowych kamer przemysłowych opartych na GENICAM.
69
70 %package devel
71 Summary:        Header files for Aravis library
72 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Aravis
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       glib2-devel >= 1:2.44
76 Requires:       libxml2-devel >= 2.0
77 Requires:       zlib-devel
78
79 %description devel
80 Header files for Aravis library.
81
82 %description devel -l pl.UTF-8
83 Pliki nagłówkowe biblioteki Aravis.
84
85 %package static
86 Summary:        Static Aravis library
87 Summary(pl.UTF-8):      Statyczna biblioteka Aravis
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90
91 %description static
92 Static Aravis library.
93
94 %description static -l pl.UTF-8
95 Statyczna biblioteka Aravis.
96
97 %package apidocs
98 Summary:        API documentation for Aravis library
99 Summary(pl.UTF-8):      Dokumentacja API biblioteki Aravis
100 Group:          Documentation
101 Requires:       gtk-doc-common
102 BuildArch:      noarch
103
104 %description apidocs
105 API documentation for Aravis library.
106
107 %description apidocs -l pl.UTF-8
108 Dokumentacja API biblioteki Aravis.
109
110 %package -n gstreamer-aravis
111 Summary:        GStreamer plugin for Aravis digital video camera acquisition library
112 Summary(pl.UTF-8):      Wtyczka GStreamera do biblioteki pobierania obrazu z kamer cyfrowych Aravis
113 Group:          Libraries
114 Requires:       %{name} = %{version}-%{release}
115 Requires:       gstreamer >= 1.0
116 Requires:       gstreamer-plugins-base >= 1.0
117
118 %description -n gstreamer-aravis
119 GStreamer plugin for Aravis digital video camera acquisition
120 library.
121
122 %description -n gstreamer-aravis -l pl.UTF-8
123 Wtyczka GStreamera do biblioteki pobierania obrazu z kamer cyfrowych
124 Aravis.
125
126 %prep
127 %setup -q
128
129 %build
130 %meson build \
131         %{!?with_gstreamer:-Dgst-plugin=disabled} \
132         %{!?with_gui:-Dviewer=disabled}
133
134 %ninja_build -C build
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138
139 %ninja_install -C build
140
141 %find_lang %{name}-0.8
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post   -p /sbin/ldconfig
147 %postun -p /sbin/ldconfig
148
149 %post   viewer
150 %update_icon_cache hicolor
151
152 %postun viewer
153 %update_icon_cache hicolor
154
155 %files -f %{name}-0.8.lang
156 %defattr(644,root,root,755)
157 %doc AUTHORS NEWS.md README.md
158 %attr(755,root,root) %{_bindir}/arv-camera-test-0.8
159 %attr(755,root,root) %{_bindir}/arv-fake-gv-camera-0.8
160 %attr(755,root,root) %{_bindir}/arv-tool-0.8
161 %attr(755,root,root) %{_libdir}/libaravis-0.8.so.*.*.*
162 %attr(755,root,root) %ghost %{_libdir}/libaravis-0.8.so.0
163 %{_libdir}/girepository-1.0/Aravis-0.8.typelib
164 %{_mandir}/man1/arv-tool-0.8.1*
165
166 %if %{with gui}
167 %files viewer
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_bindir}/arv-viewer-0.8
170 %{_datadir}/metainfo/arv-viewer-0.8.appdata.xml
171 %{_desktopdir}/arv-viewer-0.8.desktop
172 %{_iconsdir}/hicolor/*x*/apps/aravis-0.8.png
173 %{_mandir}/man1/arv-viewer-0.8.1*
174 %endif
175
176 %files devel
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_libdir}/libaravis-0.8.so
179 %{_includedir}/aravis-0.8
180 %{_datadir}/gir-1.0/Aravis-0.8.gir
181 %{_pkgconfigdir}/aravis-0.8.pc
182
183 %files static
184 %defattr(644,root,root,755)
185 %{_libdir}/libaravis-0.8.a
186
187 %files apidocs
188 %defattr(644,root,root,755)
189 %{_gtkdocdir}/aravis-0.8
190
191 %if %{with gstreamer}
192 %files -n gstreamer-aravis
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libgstaravis.0.8.so
195 %endif
This page took 0.0722 seconds and 3 git commands to generate.