]> git.pld-linux.org Git - packages/apache.git/commitdiff
- rel 3; in 2.2.24 the way internal dummy connection is done for SSL connection has... auto/th/apache-2.2.24-3
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 10 Apr 2013 18:36:23 +0000 (20:36 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 10 Apr 2013 18:36:23 +0000 (20:36 +0200)
apache-bug-39653.patch [new file with mode: 0644]
apache.spec

diff --git a/apache-bug-39653.patch b/apache-bug-39653.patch
new file mode 100644 (file)
index 0000000..b3aad6b
--- /dev/null
@@ -0,0 +1,66 @@
+commit baf08a26b4e3f40491ae9459ef80a7460194c064
+Author: jorton <jorton@13f79535-47bb-0310-9956-ffa450edef68>
+Date:   Fri Dec 12 16:08:16 2008 +0000
+
+    * server/mpm_common.c (dummy_connection): If possible, use a non-SSL
+      listening port to use for the dummy connection, to avoid causing
+      (confusing) error log spam by sending EOF down an SSL port.
+    
+    PR: 39653
+    
+    
+    git-svn-id: http://svn.apache.org/repos/asf/httpd/httpd/trunk@726065 13f79535-47bb-0310-9956-ffa450edef68
+
+diff --git a/server/mpm_common.c b/server/mpm_common.c
+index f5941f5..72b0e66 100644
+--- a/server/mpm_common.c
++++ b/server/mpm_common.c
+@@ -657,6 +657,7 @@ static apr_status_t dummy_connection(ap_pod_t *pod)
+     apr_socket_t *sock;
+     apr_pool_t *p;
+     apr_size_t len;
++    ap_listen_rec *lp;
+     /* create a temporary pool for the socket.  pconf stays around too long */
+     rv = apr_pool_create(&p, pod->p);
+@@ -664,8 +665,19 @@ static apr_status_t dummy_connection(ap_pod_t *pod)
+         return rv;
+     }
+-    rv = apr_socket_create(&sock, ap_listeners->bind_addr->family,
+-                           SOCK_STREAM, 0, p);
++    /* If possible, find a listener which is configured for
++     * plain-HTTP, not SSL; using an SSL port would either be
++     * expensive to do correctly (performing a complete SSL handshake)
++     * or cause log spam by doing incorrectly (simply sending EOF). */
++    lp = ap_listeners;
++    while (lp && lp->protocol && strcasecmp(lp->protocol, "http") != 0) {
++        lp = lp->next;
++    }
++    if (!lp) {
++        lp = ap_listeners;
++    }
++
++    rv = apr_socket_create(&sock, lp->bind_addr->family, SOCK_STREAM, 0, p);
+     if (rv != APR_SUCCESS) {
+         ap_log_error(APLOG_MARK, APLOG_WARNING, rv, ap_server_conf,
+                      "get socket to connect to listener");
+@@ -688,7 +700,7 @@ static apr_status_t dummy_connection(ap_pod_t *pod)
+         return rv;
+     }
+-    rv = apr_socket_connect(sock, ap_listeners->bind_addr);
++    rv = apr_socket_connect(sock, lp->bind_addr);
+     if (rv != APR_SUCCESS) {
+         int log_level = APLOG_WARNING;
+@@ -704,7 +704,7 @@ static apr_status_t dummy_connection(ap_
+         }
+         ap_log_error(APLOG_MARK, log_level, rv, ap_server_conf,
+-                     "connect to listener on %pI", ap_listeners->bind_addr);
++                     "connect to listener on %pI", lp->bind_addr);
+         apr_pool_destroy(p);
+         return rv;
+     }
+
index 1ffb291cc728ab1f5560ac678285ab677f9530b4..1db424650c85063ad38adbc1eb5e1f5b9ea2f6dd 100644 (file)
@@ -44,7 +44,7 @@ Summary(ru.UTF-8):    Самый популярный веб-сервер
 Summary(tr.UTF-8):     Lider WWW tarayıcı
 Name:          apache
 Version:       2.2.24
-Release:       2
+Release:       3
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
 Source0:       http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
@@ -107,6 +107,7 @@ Patch26:    apache-mod_vhost_alias_docroot.patch
 # http://mpm-itk.sesse.net/
 Patch28:       apache-mpm-itk.patch
 Patch29:       libtool-tag.patch
+Patch30:       apache-bug-39653.patch
 URL:           http://httpd.apache.org/
 BuildRequires: apr-devel >= %{apr_ver}
 BuildRequires: apr-util-devel >= 1:1.3.10-2
@@ -1801,6 +1802,7 @@ Dwa programy testowe/przykładowe cgi: test-cgi and print-env.
 %patch26 -p1
 %patch28 -p1
 %patch29 -p1
+%patch30 -p1
 
 # using system apr, apr-util and pcre
 %{__rm} -r srclib/{apr,apr-util,pcre}
This page took 0.09054 seconds and 4 git commands to generate.