]> git.pld-linux.org Git - packages/apache.git/commitdiff
- use upstream patch that adds -T for not doing some checks instead of dropping is_di...
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 25 Sep 2010 10:27:52 +0000 (10:27 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    apache-bug-40970.patch -> 1.5
    apache.spec -> 1.604
    apache.sysconfig -> 1.15

apache-bug-40970.patch
apache.spec
apache.sysconfig

index dd275fbff2073772aa8bda1ca1751ba53e27b32f..d3bf5238ff189d6d55d4ecb9ac58ad1c06cedbaf 100644 (file)
@@ -1,12 +1,87 @@
---- apache/server/core.c~      2008-06-06 11:05:04.956063837 +0200
-+++ apache/server/core.c       2008-06-06 11:11:35.201986198 +0200
-@@ -1176,8 +1176,7 @@
+Index: server/core.c
+===================================================================
+--- server/core.c      (wersja 984170)
++++ server/core.c      (wersja 984171)
+@@ -1183,13 +1183,19 @@
+         return err;
+     }
  
-     /* TODO: ap_configtestonly && ap_docrootcheck && */
++    /* When ap_document_root_check is false; skip all the stuff below */
++    if (!ap_document_root_check) {
++       conf->ap_document_root = arg;
++       return NULL;
++    }
++
+     /* Make it absolute, relative to ServerRoot */
+     arg = ap_server_root_relative(cmd->pool, arg);
+     if (arg == NULL) {
+         return "DocumentRoot must be a directory";
+     }
+-    /* TODO: ap_configtestonly && ap_docrootcheck && */
++    /* TODO: ap_configtestonly */
      if (apr_filepath_merge((char**)&conf->ap_document_root, NULL, arg,
--                           APR_FILEPATH_TRUENAME, cmd->pool) != APR_SUCCESS
--        || !ap_is_directory(cmd->pool, arg)) {
-+                           APR_FILEPATH_TRUENAME, cmd->pool) != APR_SUCCESS) {
-         if (cmd->server->is_virtual) {
-             ap_log_perror(APLOG_MARK, APLOG_STARTUP, 0,
-                           cmd->pool,
+                            APR_FILEPATH_TRUENAME, cmd->pool) != APR_SUCCESS
+         || !ap_is_directory(cmd->pool, arg)) {
+Index: server/main.c
+===================================================================
+--- server/main.c      (wersja 984170)
++++ server/main.c      (wersja 984171)
+@@ -361,7 +361,7 @@
+ #endif /* AP_MPM_WANT_SET_GRACEFUL_SHUTDOWN */
+ #endif
+     ap_log_error(APLOG_MARK, APLOG_STARTUP, 0, NULL,
+-                 "       %s [-v] [-V] [-h] [-l] [-L] [-t] [-S]", pad);
++                 "       %s [-v] [-V] [-h] [-l] [-L] [-t] [-T] [-S]", pad);
+     ap_log_error(APLOG_MARK, APLOG_STARTUP, 0, NULL,
+                  "Options:");
+@@ -440,10 +440,15 @@
+                  "  -M                 : a synonym for -t -D DUMP_MODULES");
+     ap_log_error(APLOG_MARK, APLOG_STARTUP, 0, NULL,
+                  "  -t                 : run syntax check for config files");
++    ap_log_error(APLOG_MARK, APLOG_STARTUP, 0, NULL,
++                "  -T                 : start without DocumentRoot(s) check");
+     destroy_and_exit_process(process, 1);
+ }
++/* Set ap_document_root_check to default value: true */
++AP_DECLARE_DATA int ap_document_root_check = 1;
++
+ int main(int argc, const char * const argv[])
+ {
+     char c;
+@@ -592,6 +597,10 @@
+             configtestonly = 1;
+             break;
++       case 'T':
++           ap_document_root_check = 0;
++           break;
++
+         case 'S':
+             configtestonly = 1;
+             new = (char **)apr_array_push(ap_server_config_defines);
+Index: include/http_main.h
+===================================================================
+--- include/http_main.h        (wersja 984170)
++++ include/http_main.h        (wersja 984171)
+@@ -32,7 +32,7 @@
+  * in apr_getopt() format.  Use this for default'ing args that the MPM
+  * can safely ignore and pass on from its rewrite_args() handler.
+  */
+-#define AP_SERVER_BASEARGS "C:c:D:d:E:e:f:vVlLtSMh?X"
++#define AP_SERVER_BASEARGS "C:c:D:d:E:e:f:vVlLtTSMh?X"
+ #ifdef __cplusplus
+ extern "C" {
+@@ -53,6 +53,8 @@
+ /** An array of all -D defines on the command line.  This allows people to
+  *  effect the server based on command line options */
+ AP_DECLARE_DATA extern apr_array_header_t *ap_server_config_defines;
++/** Available integer for using the -T switch */
++AP_DECLARE_DATA extern int ap_document_root_check;
+ /**
+  * An optional function to send signal to server on presence of '-k'
index 37d43caf023563985561079f8574f0b3254708dd..9aa46e902db4a2ed340cce7c1251fab967996fa4 100644 (file)
@@ -1763,7 +1763,7 @@ Dwa programy testowe/przykładowe cgi: test-cgi and print-env.
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
-%patch11 -p1
+%patch11 -p0
 %patch12 -p1
 %patch14 -p1
 %patch15 -p1
index 9ec16251a232ca9ee08eb7085d1cdd955008ac72..c96afee272a0dbbe1e366ca7cf7369054cb3f5e4 100644 (file)
@@ -8,6 +8,7 @@ SERVICE_RUN_NICE_LEVEL="+5"
 #HTTPD_CONF="/etc/httpd/apache.conf"
 
 # other command-line options
+# -T avoid doing many unneded DocumentRoot checks
 HTTPD_OPTS=""
 
 # choose MPM
This page took 0.162913 seconds and 4 git commands to generate.