]> git.pld-linux.org Git - packages/apache-mod_qos.git/blob - apache-mod_qos.spec
rebuild with openssl 3.0.0
[packages/apache-mod_qos.git] / apache-mod_qos.spec
1 %define         mod_name        qos
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Apache module: Quality Of Service
4 Name:           apache-mod_%{mod_name}
5 Version:        11.59
6 Release:        2
7 License:        Apache
8 Group:          Networking/Daemons/HTTP
9 Source0:        https://downloads.sourceforge.net/project/mod-qos/mod_qos-%{version}.tar.gz
10 # Source0-md5:  ec7af652ad20dac3c004f3d02565c559
11 Source1:        %{name}.conf
12 URL:            http://opensource.adnovum.ch/mod_qos/
13 BuildRequires:  %{apxs}
14 BuildRequires:  apache-devel >= 2.0.0
15 BuildRequires:  autoconf
16 BuildRequires:  libpng-devel
17 BuildRequires:  openssl-devel
18 BuildRequires:  pcre-devel
19 BuildRequires:  rpmbuild(macros) >= 1.268
20 Requires:       apache(modules-api) = %apache_modules_api
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
24 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
25
26 %description
27 mod_qos is a quality of service module for the Apache Web Server. It
28 implements control mechanisms that can provide different priority to
29 different requests and controls server access based on available
30 resources.
31
32 %prep
33 %setup -q -n mod_%{mod_name}-%{version}
34
35 %build
36 cd tools
37 %{__aclocal}
38 %{__autoconf}
39 %{__automake}
40 %configure \
41         --with-pcre=%{_bindir} \
42         --with-png=%{_bindir} \
43         --with-ssl=%{_prefix}
44 %{__make}
45 cd ..
46
47 %{apxs} -c -o mod_qos.la apache2/mod_qos.c
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
52 %{__make} -C tools install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 install -p .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
56 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/97_mod_%{mod_name}.conf
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post
62 %service -q httpd restart
63
64 %postun
65 if [ "$1" = "0" ]; then
66         %service -q httpd restart
67 fi
68
69 %files
70 %defattr(644,root,root,755)
71 %doc doc/*
72 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
73 %attr(755,root,root) %{_pkglibdir}/mod_%{mod_name}.so
74 %attr(755,root,root) %{_bindir}/qscheck
75 %attr(755,root,root) %{_bindir}/qsdt
76 %attr(755,root,root) %{_bindir}/qsexec
77 %attr(755,root,root) %{_bindir}/qsfilter2
78 %attr(755,root,root) %{_bindir}/qsgeo
79 %attr(755,root,root) %{_bindir}/qsgrep
80 %attr(755,root,root) %{_bindir}/qshead
81 %attr(755,root,root) %{_bindir}/qslog
82 %attr(755,root,root) %{_bindir}/qslogger
83 %attr(755,root,root) %{_bindir}/qspng
84 %attr(755,root,root) %{_bindir}/qsre
85 %attr(755,root,root) %{_bindir}/qsrespeed
86 %attr(755,root,root) %{_bindir}/qsrotate
87 %attr(755,root,root) %{_bindir}/qssign
88 %attr(755,root,root) %{_bindir}/qstail
This page took 0.065426 seconds and 4 git commands to generate.