]> git.pld-linux.org Git - packages/apache-mod_python.git/commitdiff
- use standard python macros
authorwrobell <wrobell@pld-linux.org>
Mon, 12 Nov 2001 15:15:11 +0000 (15:15 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    apache-mod_python.spec -> 1.13

apache-mod_python.spec

index f80bd64930cf0b07046a0bcbe9b4e52bd98b8d8a..922d1ca67795d700de9ce4e2908957ed1d14a9d9 100644 (file)
@@ -13,19 +13,17 @@ Patch0:             apache-mod_python-shared.patch
 Patch1:                apache-mod_python-DESTDIR.patch
 URL:           http://www.modpython.org/
 Requires:      apache
-Requires:      python 
+%requires_eq   python
 BuildRequires: autoconf
 BuildRequires: apache
 BuildRequires: apache-devel
 BuildRequires: python-devel
+BuildRequires: rpm-pythonprov
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define        apache_moddir  %(/usr/sbin/apxs -q LIBEXECDIR)
-%define python_prefix  %(echo `python -c "import sys; print sys.prefix"`)
-%define python_version %(echo `python -c "import sys; print sys.version[:3]"`)
-%define python_libdir      %{python_prefix}/lib/python%{python_version}
-%define python_includedir  %{python_prefix}/include/python%{python_version}
-%define python_sitedir     %{python_libdir}/site-packages
+
+%include /usr/lib/rpm/macros.python
 
 %description
 mod_python allows embedding Python within the Apache Web server for a
@@ -53,7 +51,7 @@ autoconf
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{apache_moddir},%{python_sitedir}/mod_%{mod_name}}
+install -d $RPM_BUILD_ROOT{%{apache_moddir},%{py_sitedir}/mod_%{mod_name}}
 
 %{__make} install DESTDIR=$RPM_BUILD_ROOT
 
@@ -81,4 +79,4 @@ fi
 %doc doc/*
 %doc {README,COPYRIGHT,NEWS,CREDITS}.gz
 %attr(755,root,root) %{apache_moddir}/*
-%{python_sitedir}/mod_%{mod_name}
+%{py_sitedir}/mod_%{mod_name}
This page took 0.152577 seconds and 4 git commands to generate.