]> git.pld-linux.org Git - packages/apache-mod_python.git/commitdiff
- rediff patches
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 2 Mar 2021 21:07:00 +0000 (22:07 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 2 Mar 2021 21:07:00 +0000 (22:07 +0100)
apache-mod_python-httpd-not-needed.patch
build.patch
import.patch
install.patch
no-git.patch
set-request-response-status.patch

index 159fb4179b17eacb09974a9a3b2c395e462910ce..05bf0ac732b88e4e311e550234d8969ef9c0c875 100644 (file)
@@ -1,6 +1,7 @@
---- mod_python-3.4.1/configure.in.orig 2013-10-23 04:33:52.000000000 +0200
-+++ mod_python-3.4.1/configure.in      2013-10-30 20:01:00.000000000 +0100
-@@ -73,18 +73,6 @@
+diff -urNp -x '*.orig' mod_python-3.5.0.org/configure.in mod_python-3.5.0/configure.in
+--- mod_python-3.5.0.org/configure.in  2013-11-12 04:21:34.000000000 +0100
++++ mod_python-3.5.0/configure.in      2021-03-02 22:05:35.446699820 +0100
+@@ -73,18 +73,6 @@ else
    DSO="do_dso"
    ALL="dso"
  
index df82c11ba35c39c3dea1007eac8d342678d99207..f5c4b8622407008e65c357e6b36b80122525ddba 100644 (file)
@@ -1,5 +1,6 @@
---- mod_python-3.5.0/src/_apachemodule.c~      2013-11-12 04:21:34.000000000 +0100
-+++ mod_python-3.5.0/src/_apachemodule.c       2018-07-05 21:05:19.623844821 +0200
+diff -urNp -x '*.orig' mod_python-3.5.0.org/src/_apachemodule.c mod_python-3.5.0/src/_apachemodule.c
+--- mod_python-3.5.0.org/src/_apachemodule.c   2013-11-12 04:21:34.000000000 +0100
++++ mod_python-3.5.0/src/_apachemodule.c       2021-03-02 22:05:35.930030347 +0100
 @@ -836,7 +836,7 @@ static struct PyModuleDef _apache_module
  
  PyObject *_apache_module_init()
index defaa88190f0d34ff3c8dd7211409dd09c9304a6..71456f38ff00a7df7fba1843f96801fc45485204 100644 (file)
@@ -1,16 +1,9 @@
-commit 5bb5d6d0113f6bbd72966a5c1f3e6d40c2e9c8fd
-Author: Grisha Trubetskoy <grisha@modpython.org>
-Date:   Tue Dec 1 22:07:50 2015 -0500
-
-    Do not import site.py for the main interpreter. Fixes #46.
-
-diff --git a/src/mod_python.c b/src/mod_python.c
-index 8c33c04..7e0ef1e 100644
---- a/src/mod_python.c
-+++ b/src/mod_python.c
-@@ -775,8 +775,15 @@ static int python_init(apr_pool_t *p, apr_pool_t *ptemp,
-         /* disable user site directories */
-         Py_NoUserSiteDirectory = 1;
+diff -urNp -x '*.orig' mod_python-3.5.0.org/src/mod_python.c mod_python-3.5.0/src/mod_python.c
+--- mod_python-3.5.0.org/src/mod_python.c      2013-11-12 04:21:34.000000000 +0100
++++ mod_python-3.5.0/src/mod_python.c  2021-03-02 22:05:35.833364242 +0100
+@@ -772,8 +772,15 @@ static int python_init(apr_pool_t *p, ap
+     {
+         initialized = 1;
  
 -        /* initialze the interpreter */
 +        /* Initialze the main interpreter. We do not want site.py to
@@ -25,7 +18,7 @@ index 8c33c04..7e0ef1e 100644
  
  #ifdef WITH_THREAD
          /* create and acquire the interpreter lock */
-@@ -2649,7 +2656,7 @@ static void PythonChildInitHandler(apr_pool_t *p, server_rec *s)
+@@ -2646,7 +2653,7 @@ static void PythonChildInitHandler(apr_p
       * problems as well. Thus disable cleanup of Python when
       * child processes are being shutdown. (MODPYTHON-109)
       *
index 5b9249bde1c3fd93d6de5841031c7663e8c11867..93dc7b96a09897f4baccfd2296995426156c1f47 100644 (file)
@@ -1,6 +1,7 @@
---- mod_python-3.5.0/dist/Makefile.in~ 2013-11-12 04:21:34.000000000 +0100
-+++ mod_python-3.5.0/dist/Makefile.in  2016-03-06 12:15:34.649626272 +0100
-@@ -34,9 +34,9 @@
+diff -urNp -x '*.orig' mod_python-3.5.0.org/dist/Makefile.in mod_python-3.5.0/dist/Makefile.in
+--- mod_python-3.5.0.org/dist/Makefile.in      2013-11-12 04:21:34.000000000 +0100
++++ mod_python-3.5.0/dist/Makefile.in  2021-03-02 22:05:35.733364823 +0100
+@@ -34,9 +34,9 @@ install: install_py_lib
  install_py_lib: mod_python src
        @cd src; $(MAKE) psp_parser.c
        if test -z "$(DESTDIR)" ; then \
index c337874ecc93c30851fa6f3d3b2e869072f14a78..65e23458e01eb4eb3d8650d5e90deee0eb762555 100644 (file)
@@ -1,6 +1,18 @@
---- mod_python-3.4.1/src/Makefile.in~  2013-10-23 04:33:52.000000000 +0200
-+++ mod_python-3.4.1/src/Makefile.in   2013-11-04 14:50:49.165054840 +0100
-@@ -64,16 +64,14 @@
+diff -urNp -x '*.orig' mod_python-3.5.0.org/dist/version.sh mod_python-3.5.0/dist/version.sh
+--- mod_python-3.5.0.org/dist/version.sh       2013-11-12 04:21:34.000000000 +0100
++++ mod_python-3.5.0/dist/version.sh   2021-03-02 22:05:35.543365926 +0100
+@@ -5,6 +5,5 @@ MPV_PATH="`dirname $0`/../src/include/mp
+ MAJ=`awk '/MP_VERSION_MAJOR/ {print $3}' $MPV_PATH`
+ MIN=`awk '/MP_VERSION_MINOR/ {print $3}' $MPV_PATH`
+ PCH=`awk '/MP_VERSION_PATCH/ {print $3}' $MPV_PATH`
+-GIT=`git describe --always`
+-echo $MAJ.$MIN.$PCH-$GIT
++echo $MAJ.$MIN.$PCH
+diff -urNp -x '*.orig' mod_python-3.5.0.org/src/Makefile.in mod_python-3.5.0/src/Makefile.in
+--- mod_python-3.5.0.org/src/Makefile.in       2013-11-12 04:21:34.000000000 +0100
++++ mod_python-3.5.0/src/Makefile.in   2021-03-02 22:05:35.543365926 +0100
+@@ -64,16 +64,14 @@ distclean: clean
        rm -f Makefile .depend
  
  version.c:
  
  #     echo "const char * const mp_version_component = \"mod_python/\" #MP_VERSION_MAJOR \".\" #MP_VERSION_MINOR \".\" #MP_VERSION_PATCH \"-$${MP_GIT_SHA}\";" >> version.c
  
---- mod_python-3.4.1/src/include/mod_python.h.in~      2013-10-23 04:33:52.000000000 +0200
-+++ mod_python-3.4.1/src/include/mod_python.h.in       2013-11-04 14:51:56.792279692 +0100
-@@ -133,7 +133,6 @@
- #endif
+diff -urNp -x '*.orig' mod_python-3.5.0.org/src/include/mod_python.h.in mod_python-3.5.0/src/include/mod_python.h.in
+--- mod_python-3.5.0.org/src/include/mod_python.h.in   2013-11-12 04:21:34.000000000 +0100
++++ mod_python-3.5.0/src/include/mod_python.h.in       2021-03-02 22:05:35.543365926 +0100
+@@ -156,7 +156,6 @@ extern module AP_MODULE_DECLARE_DATA pyt
+ #define MUTEX_DIR "@MUTEX_DIR@"
  
  /* version stuff */
 -extern const char * const mp_git_sha;
  extern const int mp_version_major;
  extern const int mp_version_minor;
  extern const int mp_version_patch;
---- mod_python-3.4.1/dist/version.sh~  2013-10-23 04:33:52.000000000 +0200
-+++ mod_python-3.4.1/dist/version.sh   2013-11-04 15:07:59.670516345 +0100
-@@ -5,6 +5,5 @@
- MAJ=`awk '/MP_VERSION_MAJOR/ {print $3}' $MPV_PATH`
- MIN=`awk '/MP_VERSION_MINOR/ {print $3}' $MPV_PATH`
- PCH=`awk '/MP_VERSION_PATCH/ {print $3}' $MPV_PATH`
--GIT=`git describe --always`
--echo $MAJ.$MIN.$PCH-$GIT
-+echo $MAJ.$MIN.$PCH
index 346fffec9cef8e193b970c18643b28d897beee10..67977154aaddff8b95162ba47153d19ab972dff3 100644 (file)
@@ -1,6 +1,7 @@
---- mod_python-3.5.0/src/requestobject.c~      2013-11-28 14:12:06.515765224 +0100
-+++ mod_python-3.5.0/src/requestobject.c       2013-11-28 14:12:23.809244099 +0100
-@@ -378,6 +378,7 @@
+diff -urNp -x '*.orig' mod_python-3.5.0.org/src/requestobject.c mod_python-3.5.0/src/requestobject.c
+--- mod_python-3.5.0.org/src/requestobject.c   2013-11-12 04:21:34.000000000 +0100
++++ mod_python-3.5.0/src/requestobject.c       2021-03-02 22:05:35.636698717 +0100
+@@ -375,6 +375,7 @@ static PyObject *req_wsgi_start_response
      }
  
      self->request_rec->status_line = apr_pstrdup(self->request_rec->pool, status_line);
This page took 0.094665 seconds and 4 git commands to generate.