]> git.pld-linux.org Git - packages/apache-mod_python.git/commitdiff
- updated to 3.4.1
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 30 Oct 2013 19:10:43 +0000 (20:10 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 30 Oct 2013 19:10:43 +0000 (20:10 +0100)
- apache 2.4 support added upstream
- removed obsolete patches

apache-mod_python-apache24.patch [deleted file]
apache-mod_python-apr_brigade_sentinel.patch [deleted file]
apache-mod_python-ldflags.patch [deleted file]
apache-mod_python.spec

diff --git a/apache-mod_python-apache24.patch b/apache-mod_python-apache24.patch
deleted file mode 100644 (file)
index 3c39678..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
---- mod_python-3.3.1/src/mod_python.c~ 2006-11-09 07:21:23.000000000 +0100
-+++ mod_python-3.3.1/src/mod_python.c  2013-05-05 21:57:30.378136612 +0200
-@@ -561,8 +561,8 @@
- #if !defined(OS2) && !defined(WIN32) && !defined(BEOS) && !defined(NETWARE)
-             if  (!geteuid()) {
--                chown(fname, unixd_config.user_id, -1);
--                unixd_set_global_mutex_perms(mutex[n]);
-+                chown(fname, ap_unixd_config.user_id, -1);
-+                ap_unixd_set_global_mutex_perms(mutex[n]);
-             }
- #endif
-         }
---- mod_python-3.3.1/src/serverobject.c~       2006-12-03 05:36:37.000000000 +0100
-+++ mod_python-3.3.1/src/serverobject.c        2013-05-05 22:53:26.721477649 +0200
-@@ -191,7 +191,7 @@
-     {"server_hostname",    T_STRING,  OFF(server_hostname)},
-     {"port",               T_SHORT,   OFF(port)},
-     {"error_fname",        T_STRING,  OFF(error_fname)},
--    {"loglevel",           T_INT,     OFF(loglevel)},
-+    {"loglevel",           T_INT,     OFF(log.level)},
-     {"is_virtual",         T_INT,     OFF(is_virtual)},
-     /* XXX implement module_config ? */
-     /* XXX implement lookup_defaults ? */
-@@ -288,7 +288,9 @@
- static PyObject *my_generation(serverobject *self, void *objname)
- {
--    return PyInt_FromLong((long)ap_my_generation);
-+    ap_generation_t mpm_generation;
-+    ap_mpm_query(AP_MPMQ_GENERATION, &mpm_generation);
-+    return PyInt_FromLong((long)mpm_generation);
- }
- static PyObject *restart_time(serverobject *self, void *objname)
---- mod_python-3.3.1/src/connobject.c.orig     2013-05-05 23:03:40.876114437 +0200
-+++ mod_python-3.3.1/src/connobject.c  2013-05-05 23:10:10.889444946 +0200
-@@ -286,8 +286,10 @@
-     /* XXX vhost_lookup_data? */
-     /* XXX client_socket? */
-     {"local_addr",         T_OBJECT,    0,                       RO},
-+    {"client_addr",        T_OBJECT,    0,                       RO},
-     {"remote_addr",        T_OBJECT,    0,                       RO},
--    {"remote_ip",          T_STRING,    OFF(remote_ip),          RO},
-+    {"client_ip",          T_STRING,    OFF(client_ip),          RO},
-+    {"remote_ip",          T_STRING,    OFF(client_ip),          RO},
-     {"remote_host",        T_STRING,    OFF(remote_host),        RO},
-     {"remote_logname",     T_STRING,    OFF(remote_logname),     RO},
-     {"aborted",            T_INT,       0,                       RO},
-@@ -414,8 +416,11 @@
-     else if (strcmp(name, "local_addr") == 0) {
-         return makesockaddr(self->conn->local_addr);
-     }
-+    else if (strcmp(name, "client_addr") == 0) {
-+        return makesockaddr(self->conn->client_addr);
-+    }
-     else if (strcmp(name, "remote_addr") == 0) {
--        return makesockaddr(self->conn->remote_addr);
-+        return makesockaddr(self->conn->client_addr);
-     }
-     else if (strcmp(name, "notes") == 0) {
-         Py_INCREF(self->notes);
---- mod_python-3.3.1/src/requestobject.c~      2006-12-03 05:36:37.000000000 +0100
-+++ mod_python-3.3.1/src/requestobject.c       2013-06-21 00:41:47.635302626 +0200
-@@ -1230,7 +1230,12 @@
-        follow requires, e.g. "requires role terminator".
-     */
--    const apr_array_header_t *reqs_arr = ap_requires(self->request_rec);
-+    const apr_array_header_t *reqs_arr =
-+#if AP_SERVER_MAJORVERSION_NUMBER > 2 || AP_SERVER_MINORVERSION_NUMBER >= 3
-+    NULL;
-+#else
-+    ap_requires(self->request_rec);
-+#endif
-     require_line *reqs;
-     int i, ti = 0;
diff --git a/apache-mod_python-apr_brigade_sentinel.patch b/apache-mod_python-apr_brigade_sentinel.patch
deleted file mode 100644 (file)
index 95e3ea2..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -burN mod_python-3.3.1.original/src/connobject.c mod_python-3.3.1/src/connobject.c
---- mod_python-3.3.1.original/src/connobject.c 2006-12-03 05:36:37.000000000 +0100
-+++ mod_python-3.3.1/src/connobject.c  2008-07-15 01:05:01.000000000 +0200
-@@ -139,7 +139,7 @@
-     bytes_read = 0;
-     while ((bytes_read < len || len == 0) &&
--           !(b == APR_BRIGADE_SENTINEL(b) ||
-+           !(b == APR_BRIGADE_SENTINEL(bb) ||
-              APR_BUCKET_IS_EOS(b) || APR_BUCKET_IS_FLUSH(b))) {
-         const char *data;
\ No newline at end of file
diff --git a/apache-mod_python-ldflags.patch b/apache-mod_python-ldflags.patch
deleted file mode 100644 (file)
index 4d4c53e..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
---- mod_python-3.1.3/configure.in.ldflags
-+++ mod_python-3.1.3/configure.in
-@@ -225,7 +225,7 @@
-     LDFLAGS="${LDFLAGS} -Wl,-framework,Python"
-   fi
- else
--  LDFLAGS="${LDFLAGS} -L${PyLIBPL}"
-+  #LDFLAGS="${LDFLAGS} -L${PyLIBPL}"
-   AC_CHECK_LIB(python${PyVERSION}, Py_NewInterpreter,
-              [ PyPYTHONLIBS="-lpython${PyVERSION}" ],
-              [ LDFLAGS="$save_LDFLAGS"
-@@ -267,10 +267,7 @@
- AC_MSG_CHECKING(linker flags used to link Python)
- AC_SUBST(LDFLAGS)
- PyLFS=`grep "^LINKFORSHARED=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' '   '`
--PyLDFLAGS=`grep "^LDFLAGS=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' '   '`
--LDFLAGS="${LDFLAGS} ${PyLFS} ${PyLDFLAGS}"
--LDFLAGS="${LDFLAGS} ${PY_LDFLAGS}"
--AC_MSG_RESULT($PY_LDFLAGS)
-+LDFLAGS="${LDFLAGS} ${PyLFS}"
- AC_MSG_CHECKING(where Python include files are)
- AC_SUBST(INCLUDES)
index 14220da04c4fe91b6a31ab8964c1765d443f89f2..7f9453f305cc9434236d47b13bdee8da4f265d6c 100644 (file)
@@ -18,17 +18,14 @@ Summary(sk.UTF-8):  Interpreter jazyka Perl pre webový server Apache
 Summary(sl.UTF-8):     Vključeni pythonski tolmač za spletni strežnik Apache
 Summary(sv.UTF-8):     En inbyggd Python-interpretator för webbservern Apache
 Name:          apache-mod_%{mod_name}
-Version:       3.3.1
-Release:       20
+Version:       3.4.1
+Release:       1
 License:       Apache
 Group:         Networking/Daemons/HTTP
-Source0:       http://www.apache.org/dist/httpd/modpython/mod_%{mod_name}-%{version}.tgz
-# Source0-md5: a3b0150176b726bd2833dac3a7837dc5
+Source0:       http://dist.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
+# Source0-md5: d27804354f1808ad55d432fd76ed9d05
 Source1:       %{name}.conf
 Patch0:                %{name}-httpd-not-needed.patch
-Patch1:                %{name}-ldflags.patch
-Patch2:                %{name}-apr_brigade_sentinel.patch
-Patch3:                %{name}-apache24.patch
 URL:           http://www.modpython.org/
 BuildRequires: apache-devel >= 2.0.52-7
 BuildRequires: apr-devel >= 1:1.0.0
@@ -127,9 +124,6 @@ prestandan jämfört med den traditionella CGI-metoden.
 %prep
 %setup -q -n mod_%{mod_name}-%{version}
 %patch0 -p1
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
 
 %build
 %{__aclocal}
@@ -140,7 +134,7 @@ prestandan jämfört med den traditionella CGI-metoden.
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{apachelibdir},%{apacheconfdir}}
+install -d $RPM_BUILD_ROOT{%{apachelibdir},%{apacheconfdir},%{_bindir}}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
@@ -161,9 +155,10 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc doc-html/* README COPYRIGHT NEWS CREDITS
+%doc doc-html/* README.md COPYRIGHT NEWS CREDITS
 %doc examples
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_%{mod_name}.conf
+%attr(755,root,root) %{_bindir}/mod_python
 %attr(755,root,root) %{apachelibdir}/*.so
 %dir %{py_sitedir}/mod_%{mod_name}
 %if "%{py_ver}" > "2.4"
This page took 0.038206 seconds and 4 git commands to generate.