]> git.pld-linux.org Git - packages/apache-mod_python.git/commitdiff
- rel 31; fix build auto/th/apache-mod_python-3.5.0-31
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 5 Jul 2018 19:07:46 +0000 (21:07 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 5 Jul 2018 19:07:46 +0000 (21:07 +0200)
apache-mod_python.spec
build.patch [new file with mode: 0644]

index 6277a9cc5ef9e3924fc360da148b591e48d84fba..cb09cf3ebb4f0400d769af3951e801038b293eca 100644 (file)
@@ -20,7 +20,7 @@ Summary(pl.UTF-8):    Wbudowany interpreter języka Python dla serwera WWW Apache
 Summary(sv.UTF-8):     En inbyggd Python-interpretator för webbservern Apache
 Name:          apache-mod_%{mod_name}
 Version:       3.5.0
-Release:       30
+Release:       31
 License:       Apache
 Group:         Networking/Daemons/HTTP
 Source0:       http://dist.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
@@ -32,6 +32,7 @@ Patch1:               no-git.patch
 Patch2:                set-request-response-status.patch
 Patch3:                install.patch
 Patch4:                import.patch
+Patch5:                build.patch
 URL:           http://www.modpython.org/
 BuildRequires: apache-devel >= 2.0.52-7
 BuildRequires: apr-devel >= 1:1.0.0
@@ -241,6 +242,7 @@ prestandan jämfört med den traditionella CGI-metoden.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %build
 %{__aclocal}
diff --git a/build.patch b/build.patch
new file mode 100644 (file)
index 0000000..df82c11
--- /dev/null
@@ -0,0 +1,20 @@
+--- mod_python-3.5.0/src/_apachemodule.c~      2013-11-12 04:21:34.000000000 +0100
++++ mod_python-3.5.0/src/_apachemodule.c       2018-07-05 21:05:19.623844821 +0200
+@@ -836,7 +836,7 @@ static struct PyModuleDef _apache_module
+ PyObject *_apache_module_init()
+ {
+-    PyObject *m, *d, *o;
++    PyObject *m, *d, *o, *mod;
+     PyType_Ready(&MpTable_Type);
+     PyType_Ready(&MpTableIter_Type);
+@@ -851,7 +851,7 @@ PyObject *_apache_module_init()
+ #else
+     m = PyModule_Create(&_apache_moduledef);
+     PyObject *name = PyUnicode_FromString("_apache");
+-    _PyImport_FixupExtensionObject(m, name, name);
++    _PyImport_FixupExtensionObject(m, name, name, mod);
+ #endif
+     d = PyModule_GetDict(m);
+     Mp_ServerReturn = PyErr_NewException("_apache.SERVER_RETURN", NULL, NULL);
This page took 0.034226 seconds and 4 git commands to generate.