]> git.pld-linux.org Git - packages/apache-mod_python.git/commitdiff
- can be build with rh-like python package
authormis <mis@pld-linux.org>
Wed, 7 Jun 2000 08:23:46 +0000 (08:23 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    apache-mod_python.spec -> 1.4

apache-mod_python.spec

index a3f324c4537436d8638d1ea61f3c4ed73ef67253..e1b7fdbb1aebebd00d3cef30be8028207d0a4cb8 100644 (file)
@@ -36,12 +36,21 @@ NOTE: This versions should still be considered Beta
 %build
 python %{python_libdir}/compileall.py lib/python/mod_python/
 
-PTHREADS=
+LDFLAGS=
+# RH  
+if [ -f %{python_libdir}/config/libpython%{python_version}.a ]; then 
+       LDFLAGS="$LDFLAGS -L%{python_libdir}/config/ -lpython%{python_version}"
+# PLD 
+else  
+       LDFLAGS="$LDFLAGS -lpython"
+fi  
 if ldd %{python_prefix}/bin/python | grep libpthread >/dev/null; then 
-        PTHREADS=-lpthread
-fi   
+        LDFLAGS="$LDFLAGS -lpthread"
+fi 
+
 cd src
-/usr/sbin/apxs -I%{python_includedir} -lpython $PTHREADS -o mod_%{mod_name}.so -c mod_%{mod_name}.c
+/usr/sbin/apxs -I%{python_includedir} $LDFLAGS -o mod_%{mod_name}.so -c mod_%{mod_name}.c
 cd ..
 gzip -9nf README COPYRIGHT
 
This page took 0.031283 seconds and 4 git commands to generate.