- updated to 3.4.1
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 30 Oct 2013 19:26:04 +0000 (20:26 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 30 Oct 2013 19:26:04 +0000 (20:26 +0100)
apache-mod_python-httpd-not-needed.patch

index d95e4989d391eb40fa773462eb2fdabcad56408d..159fb4179b17eacb09974a9a3b2c395e462910ce 100644 (file)
@@ -1,18 +1,19 @@
---- mod_python-3.1.3/configure.in.orig 2004-12-23 13:38:04.850127608 +0000
-+++ mod_python-3.1.3/configure.in      2004-12-23 13:38:50.148241248 +0000
-@@ -95,17 +95,6 @@
+--- mod_python-3.4.1/configure.in.orig 2013-10-23 04:33:52.000000000 +0200
++++ mod_python-3.4.1/configure.in      2013-10-30 20:01:00.000000000 +0100
+@@ -73,18 +73,6 @@
    DSO="do_dso"
    ALL="dso"
  
 -  # check Apache version
 -  AC_MSG_CHECKING(Apache version)
 -  HTTPD="`${APXS} -q SBINDIR`/`${APXS} -q TARGET`"
--  ver=`$HTTPD -v | awk '/version/ {print $3}' | awk -F/ '{print $2}'`
--  AC_MSG_RESULT($ver)
+-  HTTPD_VERSION=`$HTTPD -v | awk '/version/ {print $3}' | awk -F/ '{print $2}' | awk '{print $1}'`
+-  APR_VERSION=`${APXS} -q APR_VERSION`
+-  AC_MSG_RESULT($HTTPD_VERSION)
 -
 -  # make sure version begins with 2
--  if test -z "`echo $ver | egrep \^2`"; then
--    AC_MSG_ERROR([This version of mod_python only works with Apache 2. The one you have seems to be $ver.])
+-  if test -z "`echo $HTTPD_VERSION | egrep \^2`"; then
+-    AC_MSG_ERROR([This version of mod_python only works with Apache 2. The one we have ($HTTPD) seems to be $HTTPD_VERSION.])
 -  fi
 -
    # determine LIBEXEC
This page took 0.113075 seconds and 4 git commands to generate.