]> git.pld-linux.org Git - packages/apache-mod_python.git/blobdiff - apache-mod_python.spec
- apr-status-is-success patch (macro APR_STATUS_IS_SUCCESS was removed from
[packages/apache-mod_python.git] / apache-mod_python.spec
index 8f576ffe4ebb71a9dca7cce30a31bf0a97ffb3f8..ef0a749a15696514bdc544cfc0f3f9c708ed0e52 100644 (file)
@@ -1,8 +1,5 @@
-
-%include       /usr/lib/rpm/macros.python
 %define                mod_name        python
 %define        apxs            /usr/sbin/apxs
-
 Summary:       An embedded Python interpreter for the Apache Web server
 Summary(cs):   Vestavìný interpret Pythonu pro WWW server Apache
 Summary(da):   En indbygget Python-fortolker for webtjeneren Apache
@@ -22,15 +19,17 @@ Summary(sl):        Vklju
 Summary(sv):   En inbyggd Python-interpretator för webbservern Apache
 Name:          apache-mod_%{mod_name}
 Version:       3.1.3
-Release:       2
+Release:       5
 License:       Apache Group License
 Group:         Networking/Daemons
 Source0:       http://www.apache.org/dist/httpd/modpython/mod_%{mod_name}-%{version}.tgz
 # Source0-md5: 2e1983e35edd428f308b0dfeb1c23bfe
 Source1:       %{name}.conf
 Patch0:                %{name}-lib64.patch
+Patch1:                %{name}-apr-status-is-success.patch
 URL:           http://www.modpython.org/
 BuildRequires: %{apxs}
+BuildRequires: apache >= 2.0.44
 BuildRequires: apache-devel >= 2.0.44
 BuildRequires: apr-devel >= 1:0.9.4-1
 BuildRequires: autoconf
@@ -40,11 +39,13 @@ BuildRequires:      python-devel >= 2.2
 BuildRequires: rpm-pythonprov
 Requires(post,preun):  %{apxs}
 Requires:      apache >= 2.0.44
+# apache.py uses pdb module
 Requires:      python-devel-tools
 %pyrequires_eq python
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                apache_moddir   %(%{apxs} -q LIBEXECDIR)
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR)
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
 
 %description
 Mod_python is a module that embeds the Python language interpreter
@@ -126,6 +127,7 @@ prestandan j
 %if "%{_libdir}" == "%{_prefix}/lib64"
 %patch0
 %endif
+%patch1 -p1
 
 %build
 %{__aclocal}
@@ -140,13 +142,13 @@ CFLAGS="-DEAPI %{rpmcflags}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{apache_moddir} \
-       $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf
+install -d $RPM_BUILD_ROOT%{_pkglibdir} \
+       $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/60_mod_python.conf
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/60_mod_python.conf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -166,8 +168,8 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc doc-html/* README COPYRIGHT NEWS CREDITS
-%{_sysconfdir}/httpd/httpd.conf/60_mod_python.conf
-%attr(755,root,root) %{apache_moddir}/*
+%{_sysconfdir}/httpd.conf/60_mod_python.conf
+%attr(755,root,root) %{_pkglibdir}/*.so
 %dir %{py_sitedir}/mod_%{mod_name}
 %attr(755,root,root) %{py_sitedir}/mod_%{mod_name}/*.so
 %{py_sitedir}/mod_%{mod_name}/*.py[co]
This page took 0.029299 seconds and 4 git commands to generate.