]> git.pld-linux.org Git - packages/apache-mod_python.git/blobdiff - apache-mod_python.spec
- unified
[packages/apache-mod_python.git] / apache-mod_python.spec
index c7f2b92faac0228cf47b346d363c1d0aec0373ff..e939fdcc9dec209b793ab0b559c5a72f2b5d15ba 100644 (file)
@@ -1,8 +1,5 @@
-
-%include       /usr/lib/rpm/macros.python
 %define                mod_name        python
 %define        apxs            /usr/sbin/apxs
-
 Summary:       An embedded Python interpreter for the Apache Web server
 Summary(cs):   Vestavìný interpret Pythonu pro WWW server Apache
 Summary(da):   En indbygget Python-fortolker for webtjeneren Apache
@@ -22,7 +19,7 @@ Summary(sl):  Vklju
 Summary(sv):   En inbyggd Python-interpretator för webbservern Apache
 Name:          apache-mod_%{mod_name}
 Version:       3.1.3
-Release:       2
+Release:       3
 License:       Apache Group License
 Group:         Networking/Daemons
 Source0:       http://www.apache.org/dist/httpd/modpython/mod_%{mod_name}-%{version}.tgz
@@ -40,10 +37,13 @@ BuildRequires:      python-devel >= 2.2
 BuildRequires: rpm-pythonprov
 Requires(post,preun):  %{apxs}
 Requires:      apache >= 2.0.44
+# apache.py uses pdb module
+Requires:      python-devel-tools
 %pyrequires_eq python
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                apache_moddir   %(%{apxs} -q LIBEXECDIR)
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR)
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
 
 %description
 Mod_python is a module that embeds the Python language interpreter
@@ -139,13 +139,13 @@ CFLAGS="-DEAPI %{rpmcflags}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{apache_moddir} \
-       $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf
+install -d $RPM_BUILD_ROOT%{_pkglibdir} \
+       $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/60_mod_python.conf
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/60_mod_python.conf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -165,8 +165,8 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc doc-html/* README COPYRIGHT NEWS CREDITS
-%{_sysconfdir}/httpd/httpd.conf/60_mod_python.conf
-%attr(755,root,root) %{apache_moddir}/*
+%{_sysconfdir}/httpd.conf/60_mod_python.conf
+%attr(755,root,root) %{_pkglibdir}/*.so
 %dir %{py_sitedir}/mod_%{mod_name}
 %attr(755,root,root) %{py_sitedir}/mod_%{mod_name}/*.so
 %{py_sitedir}/mod_%{mod_name}/*.py[co]
This page took 0.030585 seconds and 4 git commands to generate.