]> git.pld-linux.org Git - packages/apache-mod_python.git/blobdiff - apache-mod_python.spec
- small fix in make install
[packages/apache-mod_python.git] / apache-mod_python.spec
index c70179e541b5d79f02162f7699f9c2c45b079585..d2ec00ce38dbd73a4bd9984d56161b46d901b8da 100644 (file)
@@ -1,59 +1,64 @@
+%include       /usr/lib/rpm/macros.python
 %define                mod_name        python
 Summary:       A Python for the Apache Web server
 Summary(pl):   Python dla serwera WWW Apache
 Name:          apache-mod_%{mod_name}
-Version:       2.7.2
-Release:       0.1
+Version:       2.7.6
+Release:       4
 License:       distributable
 Group:         Networking/Daemons
 Group(de):     Netzwerkwesen/Server
+Group(es):     Red/Servidores
+Group(fr):     Réseau/Serveurs
 Group(pl):     Sieciowe/Serwery
+Group(pt):     Rede/Server
 Source0:       http://www.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
 Patch0:                apache-mod_python-shared.patch
 Patch1:                apache-mod_python-DESTDIR.patch
+Patch2:                apache-mod_python-Makefile-in.patch
 URL:           http://www.modpython.org/
-Requires:      apache
-Requires:      python 
 BuildRequires: autoconf
+BuildRequires: automake
 BuildRequires: apache
 BuildRequires: apache-devel
-BuildRequires: python-devel
+BuildRequires: python-devel >= 2.2
+BuildRequires: rpm-pythonprov
+Requires:      apache
+%requires_eq   python
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define        apache_moddir  %(/usr/sbin/apxs -q LIBEXECDIR)
-%define python_prefix  %(echo `python -c "import sys; print sys.prefix"`)
-%define python_version %(echo `python -c "import sys; print sys.version[:3]"`)
-%define python_libdir      %{python_prefix}/lib/python%{python_version}
-%define python_includedir  %{python_prefix}/include/python%{python_version}
-%define python_sitedir     %{python_libdir}/site-packages
+%define                apache_moddir   %(/usr/sbin/apxs -q LIBEXECDIR)
 
 %description
 mod_python allows embedding Python within the Apache Web server for a
 considerable boost in performance and added flexibility in designing
 web based applications.
 
-NOTE: This versions should still be considered Beta.
-
 %description -l pl
 mod_python pozwala na zagnie¿d¿enie pythona w serwerze WWW Apache w
 celu zauwa¿alnej poprawy wydajno¶ci i zwiêkszonej elastyczno¶ci przy
 tworzeniu aplikacji opartych na WWW.
 
-Uwaga: ta wersja nadal powinna byæ uwa¿ana za Beta.
-
 %prep 
 %setup -q -n mod_%{mod_name}-%{version}
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
+aclocal
 autoconf
-%configure --with-apxs=/usr/sbin/apxs
+
+# new apache needs it
+CFLAGS="-DEAPI %{rpmcflags}"
+%configure \
+       --with-apxs=/usr/sbin/apxs
 %{__make} dso
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{apache_moddir},%{python_sitedir}/mod_%{mod_name}}
+install -d $RPM_BUILD_ROOT{%{apache_moddir},%{py_sitedir}/mod_%{mod_name}}
 
 %{__make} install DESTDIR=$RPM_BUILD_ROOT
 
@@ -78,7 +83,7 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc doc/*
+%doc doc-html/*
 %doc {README,COPYRIGHT,NEWS,CREDITS}.gz
 %attr(755,root,root) %{apache_moddir}/*
-%{python_sitedir}/mod_%{mod_name}
+%{py_sitedir}/mod_%{mod_name}
This page took 0.026585 seconds and 4 git commands to generate.