]> git.pld-linux.org Git - packages/apache-mod_python.git/blobdiff - apache-mod_python.spec
- simplified and fixed installation procedure (now it works)
[packages/apache-mod_python.git] / apache-mod_python.spec
index a8edc75eefe4e541cc5aec15e32927a25671ac26..c7f2b92faac0228cf47b346d363c1d0aec0373ff 100644 (file)
@@ -1,6 +1,8 @@
+
 %include       /usr/lib/rpm/macros.python
 %define                mod_name        python
 %define        apxs            /usr/sbin/apxs
+
 Summary:       An embedded Python interpreter for the Apache Web server
 Summary(cs):   Vestavìný interpret Pythonu pro WWW server Apache
 Summary(da):   En indbygget Python-fortolker for webtjeneren Apache
@@ -11,32 +13,33 @@ Summary(id):        Interpreter Perl untuk web server Apache
 Summary(is):   Perl túlkur fyrir Apache vefþjóninn
 Summary(it):   Interprete Python integrato per il server Web Apache
 Summary(ja):   Apache Web ¥µ¡¼¥Ð¡¼ÍѤÎÁȹþ¤ß Perl ¥¤¥ó¥¿¡¼¥×¥ê¥¿
-Summary(no):   En Python-fortolker for webtjeneren Apache
-Summary(pl):   Wbudowany interpreter Pythona dla serwera WWW Apache
+Summary(nb):   En Python-fortolker for webtjeneren Apache
+Summary(pl):   Wbudowany interpreter jêzyka Python dla serwera WWW Apache
 Summary(pt):   Um interpretador de Perl embebido para o servidor Web Apache
 Summary(ru):   ÷ÓÔÒÏÅÎÎÙÊ ÉÎÔÅÒÐÒÅÔÁÔÏÒ Perl ÄÌÑ WWW-ÓÅÒ×ÅÒÁ Apache
 Summary(sk):   Interpreter jazyka Perl pre webový server Apache
 Summary(sl):   Vkljuèeni pythonski tolmaè za spletni stre¾nik Apache
 Summary(sv):   En inbyggd Python-interpretator för webbservern Apache
 Name:          apache-mod_%{mod_name}
-Version:       2.7.8
-Release:       3
-License:       distributable
+Version:       3.1.3
+Release:       2
+License:       Apache Group License
 Group:         Networking/Daemons
-Source0:       http://www.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
-Patch0:                %{name}-shared.patch
-Patch1:                %{name}-DESTDIR.patch
-Patch2:                %{name}-Makefile-in.patch
-Patch3:                %{name}-cleanup.patch
+Source0:       http://www.apache.org/dist/httpd/modpython/mod_%{mod_name}-%{version}.tgz
+# Source0-md5: 2e1983e35edd428f308b0dfeb1c23bfe
+Source1:       %{name}.conf
+Patch0:                %{name}-lib64.patch
 URL:           http://www.modpython.org/
+BuildRequires: %{apxs}
+BuildRequires: apache-devel >= 2.0.44
+BuildRequires: apr-devel >= 1:0.9.4-1
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: apache-devel
+BuildRequires: flex >= 2.5.31
 BuildRequires: python-devel >= 2.2
 BuildRequires: rpm-pythonprov
-BuildRequires: %{apxs}
-Prereq:                %{_sbindir}/apxs
-Requires:      apache
+Requires(post,preun):  %{apxs}
+Requires:      apache >= 2.0.44
 %pyrequires_eq python
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -119,13 +122,12 @@ prestandan j
 
 %prep
 %setup -q -n mod_%{mod_name}-%{version}
-%patch0 -p1
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
+%if "%{_libdir}" == "%{_prefix}/lib64"
+%patch0
+%endif
 
 %build
-aclocal
+%{__aclocal}
 %{__autoconf}
 
 # new apache needs it
@@ -137,24 +139,24 @@ CFLAGS="-DEAPI %{rpmcflags}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{apache_moddir},%{py_sitedir}/mod_%{mod_name}}
+install -d $RPM_BUILD_ROOT%{apache_moddir} \
+       $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
-gzip -9nf README COPYRIGHT NEWS CREDITS
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/60_mod_python.conf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-%{_sbindir}/apxs -e -a -n %{mod_name} %{apache_moddir}/mod_%{mod_name}.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 fi
 
 %preun
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n %{mod_name} %{apache_moddir}/mod_%{mod_name}.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
@@ -162,7 +164,9 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc doc-html/*
-%doc {README,COPYRIGHT,NEWS,CREDITS}.gz
+%doc doc-html/* README COPYRIGHT NEWS CREDITS
+%{_sysconfdir}/httpd/httpd.conf/60_mod_python.conf
 %attr(755,root,root) %{apache_moddir}/*
-%{py_sitedir}/mod_%{mod_name}
+%dir %{py_sitedir}/mod_%{mod_name}
+%attr(755,root,root) %{py_sitedir}/mod_%{mod_name}/*.so
+%{py_sitedir}/mod_%{mod_name}/*.py[co]
This page took 0.043194 seconds and 4 git commands to generate.