]> git.pld-linux.org Git - packages/apache-mod_python.git/blobdiff - apache-mod_python.spec
- fix ldflags to link with shared libpython
[packages/apache-mod_python.git] / apache-mod_python.spec
index c7f2b92faac0228cf47b346d363c1d0aec0373ff..c66df8eef0314435a881d8aedd29f7aba4240e08 100644 (file)
@@ -1,8 +1,5 @@
-
-%include       /usr/lib/rpm/macros.python
 %define                mod_name        python
 %define        apxs            /usr/sbin/apxs
-
 Summary:       An embedded Python interpreter for the Apache Web server
 Summary(cs):   Vestavìný interpret Pythonu pro WWW server Apache
 Summary(da):   En indbygget Python-fortolker for webtjeneren Apache
@@ -21,29 +18,37 @@ Summary(sk):        Interpreter jazyka Perl pre webov
 Summary(sl):   Vkljuèeni pythonski tolmaè za spletni stre¾nik Apache
 Summary(sv):   En inbyggd Python-interpretator för webbservern Apache
 Name:          apache-mod_%{mod_name}
-Version:       3.1.3
-Release:       2
+Version:       3.1.4
+Release:       5
 License:       Apache Group License
 Group:         Networking/Daemons
 Source0:       http://www.apache.org/dist/httpd/modpython/mod_%{mod_name}-%{version}.tgz
-# Source0-md5: 2e1983e35edd428f308b0dfeb1c23bfe
+# Source0-md5: 607175958137b06bcda91110414c82a1
 Source1:       %{name}.conf
 Patch0:                %{name}-lib64.patch
+Patch1:                %{name}-apr-status-is-success.patch
+Patch2:                %{name}-httpd-not-needed.patch
+Patch3:                %{name}-ldflags.patch
 URL:           http://www.modpython.org/
 BuildRequires: %{apxs}
-BuildRequires: apache-devel >= 2.0.44
-BuildRequires: apr-devel >= 1:0.9.4-1
+BuildRequires: apache-devel >= 2.0.52-7
+BuildRequires: apr-devel >= 1:1.0.0
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: flex >= 2.5.31
+BuildRequires: python
 BuildRequires: python-devel >= 2.2
 BuildRequires: rpm-pythonprov
-Requires(post,preun):  %{apxs}
-Requires:      apache >= 2.0.44
-%pyrequires_eq python
+BuildRequires: rpmbuild(macros) >= 1.268
+Requires:      apache(modules-api) = %apache_modules_api
+Requires:      apr >= 1:1.0.0
+# apache.py uses pdb module
+Requires:      python-devel-tools
+%requires_eq   python-libs
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                apache_moddir   %(%{apxs} -q LIBEXECDIR)
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
 
 %description
 Mod_python is a module that embeds the Python language interpreter
@@ -125,48 +130,44 @@ prestandan j
 %if "%{_libdir}" == "%{_prefix}/lib64"
 %patch0
 %endif
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
 
 %build
 %{__aclocal}
 %{__autoconf}
-
-# new apache needs it
-CFLAGS="-DEAPI %{rpmcflags}"
 %configure \
        --with-apxs=%{apxs}
-
 %{__make} dso
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{apache_moddir} \
-       $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/60_mod_python.conf
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/60_mod_python.conf
+%py_postclean
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
-fi
+%service -q httpd restart
 
 %preun
 if [ "$1" = "0" ]; then
-       if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd restart 1>&2
-       fi
+       %service -q httpd restart
 fi
 
 %files
 %defattr(644,root,root,755)
 %doc doc-html/* README COPYRIGHT NEWS CREDITS
-%{_sysconfdir}/httpd/httpd.conf/60_mod_python.conf
-%attr(755,root,root) %{apache_moddir}/*
+%doc examples
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
+%attr(755,root,root) %{_pkglibdir}/*.so
 %dir %{py_sitedir}/mod_%{mod_name}
 %attr(755,root,root) %{py_sitedir}/mod_%{mod_name}/*.so
 %{py_sitedir}/mod_%{mod_name}/*.py[co]
This page took 0.108473 seconds and 4 git commands to generate.