]> git.pld-linux.org Git - packages/apache-mod_python.git/blobdiff - apache-mod_python.spec
- fix ldflags to link with shared libpython
[packages/apache-mod_python.git] / apache-mod_python.spec
index 504bb1aea661acefa8bf53a4ce5e58f99ed091a9..c66df8eef0314435a881d8aedd29f7aba4240e08 100644 (file)
@@ -1,4 +1,3 @@
-%include       /usr/lib/rpm/macros.python
 %define                mod_name        python
 %define        apxs            /usr/sbin/apxs
 Summary:       An embedded Python interpreter for the Apache Web server
@@ -11,36 +10,45 @@ Summary(id):        Interpreter Perl untuk web server Apache
 Summary(is):   Perl túlkur fyrir Apache vefþjóninn
 Summary(it):   Interprete Python integrato per il server Web Apache
 Summary(ja):   Apache Web ¥µ¡¼¥Ð¡¼ÍѤÎÁȹþ¤ß Perl ¥¤¥ó¥¿¡¼¥×¥ê¥¿
-Summary(no):   En Python-fortolker for webtjeneren Apache
-Summary(pl):   Wbudowany interpreter Pythona dla serwera WWW Apache
+Summary(nb):   En Python-fortolker for webtjeneren Apache
+Summary(pl):   Wbudowany interpreter jêzyka Python dla serwera WWW Apache
 Summary(pt):   Um interpretador de Perl embebido para o servidor Web Apache
 Summary(ru):   ÷ÓÔÒÏÅÎÎÙÊ ÉÎÔÅÒÐÒÅÔÁÔÏÒ Perl ÄÌÑ WWW-ÓÅÒ×ÅÒÁ Apache
 Summary(sk):   Interpreter jazyka Perl pre webový server Apache
 Summary(sl):   Vkljuèeni pythonski tolmaè za spletni stre¾nik Apache
 Summary(sv):   En inbyggd Python-interpretator för webbservern Apache
 Name:          apache-mod_%{mod_name}
-Version:       2.7.8
-Release:       3
-License:       distributable
+Version:       3.1.4
+Release:       5
+License:       Apache Group License
 Group:         Networking/Daemons
-Source0:       http://www.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
-Patch0:                %{name}-shared.patch
-Patch1:                %{name}-DESTDIR.patch
-Patch2:                %{name}-Makefile-in.patch
-Patch3:                %{name}-cleanup.patch
+Source0:       http://www.apache.org/dist/httpd/modpython/mod_%{mod_name}-%{version}.tgz
+# Source0-md5: 607175958137b06bcda91110414c82a1
+Source1:       %{name}.conf
+Patch0:                %{name}-lib64.patch
+Patch1:                %{name}-apr-status-is-success.patch
+Patch2:                %{name}-httpd-not-needed.patch
+Patch3:                %{name}-ldflags.patch
 URL:           http://www.modpython.org/
+BuildRequires: %{apxs}
+BuildRequires: apache-devel >= 2.0.52-7
+BuildRequires: apr-devel >= 1:1.0.0
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: apache-devel
+BuildRequires: flex >= 2.5.31
+BuildRequires: python
 BuildRequires: python-devel >= 2.2
 BuildRequires: rpm-pythonprov
-BuildRequires: %{apxs}
-Prereq:                %{_sbindir}/apxs
-Requires:      apache
-%pyrequires_eq python
+BuildRequires: rpmbuild(macros) >= 1.268
+Requires:      apache(modules-api) = %apache_modules_api
+Requires:      apr >= 1:1.0.0
+# apache.py uses pdb module
+Requires:      python-devel-tools
+%requires_eq   python-libs
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                apache_moddir   %(%{apxs} -q LIBEXECDIR)
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
 
 %description
 Mod_python is a module that embeds the Python language interpreter
@@ -119,7 +127,9 @@ prestandan j
 
 %prep
 %setup -q -n mod_%{mod_name}-%{version}
-%patch0 -p1
+%if "%{_libdir}" == "%{_prefix}/lib64"
+%patch0
+%endif
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
@@ -127,42 +137,37 @@ prestandan j
 %build
 %{__aclocal}
 %{__autoconf}
-
-# new apache needs it
-CFLAGS="-DEAPI %{rpmcflags}"
 %configure \
        --with-apxs=%{apxs}
-
 %{__make} dso
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{apache_moddir},%{py_sitedir}/mod_%{mod_name}}
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
-gzip -9nf README COPYRIGHT NEWS CREDITS
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/60_mod_python.conf
+%py_postclean
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-%{apxs} -e -a -n %{mod_name} %{apache_moddir}/mod_%{mod_name}.so 1>&2
-if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
-fi
+%service -q httpd restart
 
 %preun
 if [ "$1" = "0" ]; then
-       %{apxs} -e -A -n %{mod_name} %{apache_moddir}/mod_%{mod_name}.so 1>&2
-       if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd restart 1>&2
-       fi
+       %service -q httpd restart
 fi
 
 %files
 %defattr(644,root,root,755)
-%doc doc-html/*
-%doc {README,COPYRIGHT,NEWS,CREDITS}.gz
-%attr(755,root,root) %{apache_moddir}/*
-%{py_sitedir}/mod_%{mod_name}
+%doc doc-html/* README COPYRIGHT NEWS CREDITS
+%doc examples
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
+%attr(755,root,root) %{_pkglibdir}/*.so
+%dir %{py_sitedir}/mod_%{mod_name}
+%attr(755,root,root) %{py_sitedir}/mod_%{mod_name}/*.so
+%{py_sitedir}/mod_%{mod_name}/*.py[co]
This page took 0.038304 seconds and 4 git commands to generate.