]> git.pld-linux.org Git - packages/apache-mod_python.git/blobdiff - apache-mod_python.spec
- release 4: rebuild against python 2.2.
[packages/apache-mod_python.git] / apache-mod_python.spec
index 069363e3f8d52e4be9b9aeb3ea40a56cffee8346..bf59fa2a3cc82884d203a6268cb292b3069ec366 100644 (file)
@@ -1,35 +1,43 @@
 %define                mod_name        python
 Summary:       A Python for the Apache Web server
+Summary(pl):   Python dla serwera WWW Apache
 Name:          apache-mod_%{mod_name}
-Version:       2.6.4
-Release:       1
+Version:       2.7.6
+Release:       4
 License:       distributable
 Group:         Networking/Daemons
+Group(de):     Netzwerkwesen/Server
 Group(pl):     Sieciowe/Serwery
-Source:                http://www.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
+Source0:       http://www.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
 Patch0:                apache-mod_python-shared.patch
 Patch1:                apache-mod_python-DESTDIR.patch
 URL:           http://www.modpython.org/
-Requires:      apache
-Requires:      python 
+BuildRequires: autoconf
 BuildRequires: apache
 BuildRequires: apache-devel
-BuildRequires: python-devel
+BuildRequires: python-devel >= 2.2
+BuildRequires: rpm-pythonprov
+Requires:      apache
+%requires_eq   python
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define        apache_moddir  %(/usr/sbin/apxs -q LIBEXECDIR)
-%define python_prefix  %(echo `python -c "import sys; print sys.prefix"`)
-%define python_version %(echo `python -c "import sys; print sys.version[:3]"`)
-%define python_libdir      %{python_prefix}/lib/python%{python_version}
-%define python_includedir  %{python_prefix}/include/python%{python_version}
-%define python_sitedir     %{python_libdir}/site-packages
+
+%include /usr/lib/rpm/macros.python
 
 %description
-mod_python allows embedding Python within the Apache Web server 
-for a considerable boost in performance and added flexibility 
-in designing web based applications. 
+mod_python allows embedding Python within the Apache Web server for a
+considerable boost in performance and added flexibility in designing
+web based applications.
 
-NOTE: This versions should still be considered Beta
+NOTE: This versions should still be considered Beta.
+
+%description -l pl
+mod_python pozwala na zagnie¿d¿enie pythona w serwerze WWW Apache w
+celu zauwa¿alnej poprawy wydajno¶ci i zwiêkszonej elastyczno¶ci przy
+tworzeniu aplikacji opartych na WWW.
+
+Uwaga: ta wersja nadal powinna byæ uwa¿ana za Beta.
 
 %prep 
 %setup -q -n mod_%{mod_name}-%{version}
@@ -38,17 +46,25 @@ NOTE: This versions should still be considered Beta
 
 %build
 autoconf
-%{configure} --with-apxs=/usr/sbin/apxs
+
+# new apache needs it
+CFLAGS=-DEAPI
+%configure \
+       --with-apxs=/usr/sbin/apxs
 %{__make} dso
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{apache_moddir},%{python_sitedir}/mod_%{mod_name}}
+install -d $RPM_BUILD_ROOT{%{apache_moddir},%{py_sitedir}/mod_%{mod_name}}
 
 %{__make} install DESTDIR=$RPM_BUILD_ROOT
 
 gzip -9nf README COPYRIGHT NEWS CREDITS
 
+%clean
+rm -rf $RPM_BUILD_ROOT
+
 %post
 /usr/sbin/apxs -e -a -n %{mod_name} %{apache_moddir}/mod_%{mod_name}.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
@@ -63,12 +79,9 @@ if [ "$1" = "0" ]; then
        fi
 fi
 
-%clean
-rm -rf $RPM_BUILD_ROOT
-
 %files
 %defattr(644,root,root,755)
-%doc doc/*
+%doc doc-html/*
 %doc {README,COPYRIGHT,NEWS,CREDITS}.gz
 %attr(755,root,root) %{apache_moddir}/*
-%{python_sitedir}/mod_%{mod_name}
+%{py_sitedir}/mod_%{mod_name}
This page took 0.053888 seconds and 4 git commands to generate.