]> git.pld-linux.org Git - packages/apache-mod_python.git/blobdiff - apache-mod_python.spec
- added aclocal
[packages/apache-mod_python.git] / apache-mod_python.spec
index 640aaca0dcbce6a3e126e8b2086ebdc30af5ffff..aa634897f55655e571af67531bf02827681f049b 100644 (file)
@@ -1,35 +1,42 @@
+%include       /usr/lib/rpm/macros.python
 %define                mod_name        python
 Summary:       A Python for the Apache Web server
+Summary(pl):   Python dla serwera WWW Apache
 Name:          apache-mod_%{mod_name}
-Version:       2.7.2
-Release:       0.1
+Version:       2.7.6
+Release:       4
 License:       distributable
 Group:         Networking/Daemons
+Group(de):     Netzwerkwesen/Server
+Group(es):     Red/Servidores
+Group(fr):     Réseau/Serveurs
 Group(pl):     Sieciowe/Serwery
-Source:                http://www.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
+Group(pt):     Rede/Server
+Source0:       http://www.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
 Patch0:                apache-mod_python-shared.patch
 Patch1:                apache-mod_python-DESTDIR.patch
 URL:           http://www.modpython.org/
-Requires:      apache
-Requires:      python 
+BuildRequires: autoconf
+BuildRequires: automake
 BuildRequires: apache
 BuildRequires: apache-devel
-BuildRequires: python-devel
+BuildRequires: python-devel >= 2.2
+BuildRequires: rpm-pythonprov
+Requires:      apache
+%requires_eq   python
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define        apache_moddir  %(/usr/sbin/apxs -q LIBEXECDIR)
-%define python_prefix  %(echo `python -c "import sys; print sys.prefix"`)
-%define python_version %(echo `python -c "import sys; print sys.version[:3]"`)
-%define python_libdir      %{python_prefix}/lib/python%{python_version}
-%define python_includedir  %{python_prefix}/include/python%{python_version}
-%define python_sitedir     %{python_libdir}/site-packages
+%define                apache_moddir   %(/usr/sbin/apxs -q LIBEXECDIR)
 
 %description
-mod_python allows embedding Python within the Apache Web server 
-for a considerable boost in performance and added flexibility 
-in designing web based applications. 
+mod_python allows embedding Python within the Apache Web server for a
+considerable boost in performance and added flexibility in designing
+web based applications.
 
-NOTE: This versions should still be considered Beta
+%description -l pl
+mod_python pozwala na zagnie¿d¿enie pythona w serwerze WWW Apache w
+celu zauwa¿alnej poprawy wydajno¶ci i zwiêkszonej elastyczno¶ci przy
+tworzeniu aplikacji opartych na WWW.
 
 %prep 
 %setup -q -n mod_%{mod_name}-%{version}
@@ -37,18 +44,27 @@ NOTE: This versions should still be considered Beta
 %patch1 -p1
 
 %build
+aclocal
 autoconf
-%{configure} --with-apxs=/usr/sbin/apxs
+
+# new apache needs it
+CFLAGS="-DEAPI %{rpmcflags}"
+%configure \
+       --with-apxs=/usr/sbin/apxs
 %{__make} dso
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{apache_moddir},%{python_sitedir}/mod_%{mod_name}}
+install -d $RPM_BUILD_ROOT{%{apache_moddir},%{py_sitedir}/mod_%{mod_name}}
 
 %{__make} install DESTDIR=$RPM_BUILD_ROOT
 
 gzip -9nf README COPYRIGHT NEWS CREDITS
 
+%clean
+rm -rf $RPM_BUILD_ROOT
+
 %post
 /usr/sbin/apxs -e -a -n %{mod_name} %{apache_moddir}/mod_%{mod_name}.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
@@ -63,12 +79,9 @@ if [ "$1" = "0" ]; then
        fi
 fi
 
-%clean
-rm -rf $RPM_BUILD_ROOT
-
 %files
 %defattr(644,root,root,755)
-%doc doc/*
+%doc doc-html/*
 %doc {README,COPYRIGHT,NEWS,CREDITS}.gz
 %attr(755,root,root) %{apache_moddir}/*
-%{python_sitedir}/mod_%{mod_name}
+%{py_sitedir}/mod_%{mod_name}
This page took 0.046282 seconds and 4 git commands to generate.