]> git.pld-linux.org Git - packages/apache-mod_python.git/blobdiff - apache-mod_python.spec
- configuration file for modpython
[packages/apache-mod_python.git] / apache-mod_python.spec
index 948a0437c7ce32497a26e69796eff98c50a6e9b3..a49ee1f7e74ccd2f3c224fa4aa1cccd548311f0d 100644 (file)
@@ -1,3 +1,9 @@
+
+#
+# todo:
+# - configuration file in /etc/httpd/httpd.conf/ _directory_
+#
+
 %include       /usr/lib/rpm/macros.python
 %define                mod_name        python
 %define        apxs            /usr/sbin/apxs
@@ -19,19 +25,17 @@ Summary(sk):        Interpreter jazyka Perl pre webov
 Summary(sl):   Vkljuèeni pythonski tolmaè za spletni stre¾nik Apache
 Summary(sv):   En inbyggd Python-interpretator för webbservern Apache
 Name:          apache-mod_%{mod_name}
-Version:       2.7.8
-Release:       3
-License:       distributable
+Version:       3.0.1
+Release:       0.2
+License:       Apache Group License
 Group:         Networking/Daemons
 Source0:       http://www.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
-Patch0:                %{name}-shared.patch
-Patch1:                %{name}-DESTDIR.patch
-Patch2:                %{name}-Makefile-in.patch
-Patch3:                %{name}-cleanup.patch
+Patch0:                %{name}-DESTDIR.patch
+Patch1:                %{name}-no-compile.patch
 URL:           http://www.modpython.org/
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: apache-devel
+BuildRequires: apache-devel >= 2.0.44
 BuildRequires: python-devel >= 2.2
 BuildRequires: rpm-pythonprov
 BuildRequires: %{apxs}
@@ -121,11 +125,9 @@ prestandan j
 %setup -q -n mod_%{mod_name}-%{version}
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
 
 %build
-aclocal
+%{__aclocal}
 %{__autoconf}
 
 # new apache needs it
@@ -141,20 +143,19 @@ install -d $RPM_BUILD_ROOT{%{apache_moddir},%{py_sitedir}/mod_%{mod_name}}
 
 %{__make} install DESTDIR=$RPM_BUILD_ROOT
 
-gzip -9nf README COPYRIGHT NEWS CREDITS
+%py_comp $RPM_BUILD_ROOT%{py_sitedir}
+%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-%{apxs} -e -a -n %{mod_name} %{apache_moddir}/mod_%{mod_name}.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 fi
 
 %preun
 if [ "$1" = "0" ]; then
-       %{apxs} -e -A -n %{mod_name} %{apache_moddir}/mod_%{mod_name}.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
@@ -163,6 +164,7 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc doc-html/*
-%doc {README,COPYRIGHT,NEWS,CREDITS}.gz
+%doc README COPYRIGHT NEWS CREDITS
 %attr(755,root,root) %{apache_moddir}/*
-%{py_sitedir}/mod_%{mod_name}
+%dir %{py_sitedir}/mod_%{mod_name}
+%{py_sitedir}/mod_%{mod_name}/*.py[co]
This page took 0.037894 seconds and 4 git commands to generate.