]> git.pld-linux.org Git - packages/apache-mod_python.git/blobdiff - apache-mod_python.spec
- corrected %doc - adds html documetation
[packages/apache-mod_python.git] / apache-mod_python.spec
index f80bd64930cf0b07046a0bcbe9b4e52bd98b8d8a..61f93d2598363bf7c952e6a2a65a3d1b3d277be5 100644 (file)
@@ -3,7 +3,7 @@ Summary:        A Python for the Apache Web server
 Summary(pl):   Python dla serwera WWW Apache
 Name:          apache-mod_%{mod_name}
 Version:       2.7.6
-Release:       1
+Release:       3
 License:       distributable
 Group:         Networking/Daemons
 Group(de):     Netzwerkwesen/Server
@@ -13,19 +13,17 @@ Patch0:             apache-mod_python-shared.patch
 Patch1:                apache-mod_python-DESTDIR.patch
 URL:           http://www.modpython.org/
 Requires:      apache
-Requires:      python 
+%requires_eq   python
 BuildRequires: autoconf
 BuildRequires: apache
 BuildRequires: apache-devel
 BuildRequires: python-devel
+BuildRequires: rpm-pythonprov
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define        apache_moddir  %(/usr/sbin/apxs -q LIBEXECDIR)
-%define python_prefix  %(echo `python -c "import sys; print sys.prefix"`)
-%define python_version %(echo `python -c "import sys; print sys.version[:3]"`)
-%define python_libdir      %{python_prefix}/lib/python%{python_version}
-%define python_includedir  %{python_prefix}/include/python%{python_version}
-%define python_sitedir     %{python_libdir}/site-packages
+
+%include /usr/lib/rpm/macros.python
 
 %description
 mod_python allows embedding Python within the Apache Web server for a
@@ -48,12 +46,17 @@ Uwaga: ta wersja nadal powinna by
 
 %build
 autoconf
-%configure --with-apxs=/usr/sbin/apxs
+
+# new apache needs it
+CFLAGS=-DEAPI
+%configure \
+  --with-apxs=/usr/sbin/apxs
 %{__make} dso
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{apache_moddir},%{python_sitedir}/mod_%{mod_name}}
+install -d $RPM_BUILD_ROOT{%{apache_moddir},%{py_sitedir}/mod_%{mod_name}}
 
 %{__make} install DESTDIR=$RPM_BUILD_ROOT
 
@@ -78,7 +81,7 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc doc/*
+%doc doc-html/*
 %doc {README,COPYRIGHT,NEWS,CREDITS}.gz
 %attr(755,root,root) %{apache_moddir}/*
-%{python_sitedir}/mod_%{mod_name}
+%{py_sitedir}/mod_%{mod_name}
This page took 0.033516 seconds and 4 git commands to generate.