]> git.pld-linux.org Git - packages/apache-mod_python.git/blobdiff - apache-mod_python.spec
rebuild with python 3.10
[packages/apache-mod_python.git] / apache-mod_python.spec
index 78431549e026eb7b0f972c77cdbd43cadb6bb0d8..2c7d4d0a4e9265738885a53701d5f72def22cda2 100644 (file)
@@ -20,8 +20,8 @@ Summary(pl.UTF-8):    Wbudowany interpreter języka Python dla serwera WWW Apache
 Summary(sv.UTF-8):     En inbyggd Python-interpretator för webbservern Apache
 Name:          apache-mod_%{mod_name}
 Version:       3.5.0
-Release:       2
-License:       Apache
+Release:       61
+License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
 Source0:       http://dist.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
 # Source0-md5: 2e61621e8d030f535f112d8e739161e2
@@ -30,27 +30,33 @@ Source2:    %{name}3.conf
 Patch0:                %{name}-httpd-not-needed.patch
 Patch1:                no-git.patch
 Patch2:                set-request-response-status.patch
-URL:           http://www.modpython.org/
+Patch3:                install.patch
+Patch4:                import.patch
+Patch5:                build.patch
+URL:           http://modpython.org/
 BuildRequires: apache-devel >= 2.0.52-7
 BuildRequires: apr-devel >= 1:1.0.0
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: flex >= 2.5.31
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: rpmbuild(macros) >= 1.671
 %if %{with python2}
 BuildRequires: python
-BuildRequires: python-devel >= 2.6
+BuildRequires: python-devel >= 1:2.6
 %endif
 %if %{with python3}
 BuildRequires: python3
-BuildRequires: python3-devel >= 3.3
+BuildRequires: python3-devel >= 1:3.3
 %endif
+Requires(post,preun,postun):   systemd-units >= 38
+Requires:      rc-scripts
 Requires:      apache(modules-api) = %apache_modules_api
 Requires:      apr >= 1:1.0.0
 # apache.py uses pdb module
 Requires:      python-devel-tools
 %requires_eq   python-libs
+Requires:      systemd-units >= 38
 Conflicts:     apache-mod_python3
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -143,11 +149,14 @@ Summary(ja.UTF-8):        Apache Web サーバー用の組込み Python 3 インター
 Summary(pl.UTF-8):     Wbudowany interpreter języka Python 3 dla serwera WWW Apache
 Summary(sv.UTF-8):     En inbyggd Python3-interpretator för webbservern Apache
 Group:         Networking/Daemons/HTTP
+Requires(post,preun,postun):   systemd-units >= 38
+Requires:      rc-scripts
 Requires:      apache(modules-api) = %apache_modules_api
 Requires:      apr >= 1:1.0.0
 # apache.py uses pdb module
 Requires:      python3-devel-tools
 %requires_eq   python3-libs
+Requires:      systemd-units >= 38
 Conflicts:     apache-mod_python
 
 %description -n apache-mod_python3
@@ -231,6 +240,9 @@ prestandan jämfört med den traditionella CGI-metoden.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
 
 %build
 %{__aclocal}
@@ -245,7 +257,9 @@ prestandan jämfört med den traditionella CGI-metoden.
 %{__make} dso
 install -d apache-mod_python{%{apachelibdir},%{apacheconfdir},%{_bindir}}
 %{__make} install \
-       DESTDIR=`pwd`/apache-mod_python
+       DESTDIR=`pwd`/apache-mod_python \
+       PY_SITESCRIPTDIR=%{py_sitescriptdir} \
+       PY_SITEDIR=%{py_sitedir}
 %endif
 
 %if %{with python3}
@@ -257,7 +271,9 @@ install -d apache-mod_python{%{apachelibdir},%{apacheconfdir},%{_bindir}}
 %{__make} dso
 install -d apache-mod_python3{%{apachelibdir},%{apacheconfdir},%{_bindir}}
 %{__make} install \
-       DESTDIR=`pwd`/apache-mod_python3
+       DESTDIR=`pwd`/apache-mod_python3 \
+       PY_SITESCRIPTDIR=%{py3_sitescriptdir} \
+       PY_SITEDIR=%{py3_sitedir}
 %{__mv} apache-mod_python3%{_bindir}/mod_python{,3}
 %{__mv} apache-mod_python3%{apachelibdir}/mod_python{,3}.so
 %endif
@@ -283,18 +299,22 @@ rm -rf $RPM_BUILD_ROOT
 
 %post
 %service -q httpd restart
+%systemd_service_restart httpd.service
 
 %postun
 if [ "$1" = "0" ]; then
        %service -q httpd restart
+       %systemd_service_restart httpd.service
 fi
 
 %post -n apache-mod_python3
 %service -q httpd restart
+%systemd_service_restart httpd.service
 
 %postun -n apache-mod_python3
 if [ "$1" = "0" ]; then
        %service -q httpd restart
+       %systemd_service_restart httpd.service
 fi
 
 %if %{with python2}
This page took 0.028377 seconds and 4 git commands to generate.